Support » Allgemeine Fragen » Login ohne Unterlass

  • Hallo im Forum,

    Ich bräuchte dringend Eure Hilfe bei der Lösung eines ziemlich nervenaufreibenden Problems: seit geraumer Zeit (wann genau und nach welchen Manipulationen das angefangen hat, weiß ich leider nicht mehr) muß ich mich ununterbrochen neu einloggen, wenn ich an meiner Homepage arbeite, d.h. nach fast jedem Speichervorgang oder Seitenwechsel.

    Woran kann’s liegen?

    Liebe Grüße und Danke im Voraus für Eure Antworten!
    Dagobert

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 85)
  • Hast du schon die üblichen Troubleshooting-Schritte probiert und mal getestet, ob das Problem auch dann auftritt, wenn alle Plugins deaktiviert sind bzw. wenn auf ein Standard-Theme wie z.B. Twenty-Sixteen gewechselt wird?

    Ich vermute dahinter eine Fehlkonfiguration der Website- und WordPress-Adresse in Einstellungen > Allgemein. Schau doch mal, ob diese Einstellungen stimmen, insbesondere ob es eine Abweichung (z.B. mal mit/mal ohne www oder http/https) gibt.

    Danke für Eure Antworten!
    @mario: beide Adressen sind gleichlautend http//….An diesen Einstellungen habe ich übrigens nie was geändert…
    @flower33: was bringt das Abschalten aller Plugins und der Wechsel zu einem anderen Thema? Wenn diese rudimentäre Seite funktionieren sollte, wie finde ich dann den Übeltäter? Abgesehen davon habe ich seit dem Einsetzen des beschriebenen Problems kein neues Plugin installiert, sondern nur ganz brav alle sämtlichen Updates vorgenommen. Möglich natürlich, daß dabei irgend ein Virus eingeschleppt wurde…

    Ein Hosting-Problem? Der hat allerdings auf Nachfrage WP als Fehlerquelle ausgemacht…

    was bringt das Abschalten aller Plugins und der Wechsel zu einem anderen Thema?

    Das ist Teil der üblichen Vorgehensweise, um bei der Fehlersuche mögliche Quellen auszuschließen bzw. einzugrenzen. Zusätzlich sollte in der wp-config.php die Konstante WP_DEBUG auf true gesetzt werden (einfach in der Zeile das Wort false ersetzen).

    beide Adressen sind gleichlautend http//….

    Das wäre dann ja schon mal ein Fehler. 🙂 Schau dir den Eintrag doch nochmal genau an.

    Von „false“ auf „true“ ausgeführt…..:-)

    „Das wäre dann ja schon mal ein Fehler. 🙂 Schau dir den Eintrag doch nochmal genau an.“
    Hm, verstehe ich jetzt nicht. Sollen die zwei Einträge jetzt identisch sein oder nicht? Beide Adressenn lauten http://commpell.com

    Das wäre soweit richtig (vorher hattest du nur http// geschrieben, ohne Doppelpunkt), sofern nicht eine Weiterleitungsregel in der .htaccess versucht, auf eine Adresse mit www umzuleiten.

    Bleiben also die Plugins … 

    Habe eben die Version 4.6 geladen und die Updates des Plugins gemacht – am Problem des dauernden Logins hat sich nichts geändert…
    Werde als mal die Plugins eines nach dem anderen abschalten.

    Eigentlich geht es andersherum besser: Erst alle ausschalten, um zu sehen, ob es überhaupt an den Plugins liegt. Falls nicht, hat sich der Schritt erübrigt. Falls doch, schaltest du sie nach und nach wieder ein, um zu sehen, ab wann der Fehler auftritt.

    Stimmt, danke!
    Melde mich nach der Prozedur wieder…

    Hallo Dagobert,

    @flower33: was bringt das Abschalten aller Plugins und der Wechsel zu einem anderen Thema? Wenn diese rudimentäre Seite funktionieren sollte, wie finde ich dann den Übeltäter?

    habe deine Frage erst gesehen, nachdem Bego sie schon beantwortet hatte, sorry.

    Ein Hosting-Problem? Der hat allerdings auf Nachfrage WP als Fehlerquelle ausgemacht…

    Abgesehen davon, dass das hier durchaus zutreffen mag, muss man aber immer auch im Hinterkopf haben, dass das bei weniger guten Hostern erst mal die Standard-Antwort ist und nicht immer den Fakten entspricht. 🙂

    Problem schon gelöst?

    Da es ja offensichtlich ein Problem mit dem Login-Cookie gibt, würde ich mal ganz andere Ursachen in Betracht ziehen: Browser-Problem/Konfiguration (anderen Browser probieren, Cookie-Einstellungen überprüfen) und Festplatte voll (Login-Cookie kann nicht geschrieben werden, da kein einziges Byte mehr auf die Platte passt …

    Hallo Torsten,

    Danke für die Nachfrage: nein, Problem leider noch nicht gelöst!

    Den Vorschlag, alle Plugins zu deaktivieren und sukzessive wieder anzuknipsen, habe ich noch nicht ausgeführt. Die Seite wird von unseren Mitgliedern (Kollektivbestellung von Holzpellets:-) z.Zt. rege benutzt und Plugins zeitlich abzuschalten würde den Funktionsumfang der Seite zu sehr beeinträchtigen.

    Ich habe mal in den Cookie-Einstellungen des Browsers (Safari) nachgeschaut. Im Reiter „Datenschutz“ ist die Option „Cookies und Webseite-Daten immer zulassen“ ausgewählt. Richtig, oder? War jedenfalls immer so, habe nie was dran geändert. Was die Festplatte betrifft, sind noch 1,21 (von insgesamt 2,11) TB frei. Dann habe ich meine Seite mit Firefox bearbeitet: ist fast noch schlimmer. Der Wechsel von einer Seite zur anderen geht sehr träge vor sich, bei fast jedem zweiten Wechsel muß ich mich neu einloggen. Also zurück zu Safari. Seitenwechsel etwas flotter, aber immer noch schleppend, sehr oft „error“-Meldung. Mein Internet-Anschluß ist relativ flott, stark datenbeladene Seiten (z.B. Amazon oder eBay) sind in Windeseile da, das Blättern geht ruck-zuck…

    Kann es denn nicht sein, daß der Fehler doch bei meinem Hoster (http://www.hostinger.fr) liegt? Muß es zwangsläufig ein WP-Problem sein? Das sehr zähflüssige Laden der Seiten (commpell.com) ist nämlich immer schon so gewesen…

    Viele Grüße,
    Dagobert

    Mein Beitrag von eben ist offenbar wegen der Links im Spam-Ordner gelandet.
    Bego wird ihn vermutlich später freischalten.

    Moderationshinweis: So ist es. 🙂

    • Diese Antwort wurde geändert vor 3 Jahre, 11 Monaten von Bego Mario Garde. Grund: Moderationshinweis

    Hallo Dagobert,

    Kann es denn nicht sein, daß der Fehler doch bei meinem Hoster (http://www.hostinger.fr) liegt? Muß es zwangsläufig ein WP-Problem sein? Das sehr zähflüssige Laden der Seiten (commpell.com) ist nämlich immer schon so gewesen…

    doch, das kann schon sein.
    Du könntest z.B. mal übeprüfen, ob dir überhaupt genügend Speicherlimit zur Verfügung steht.

    Falls du nicht weiß, wie du das herausfindest:
    Entweder ein Plugin dafür einsetzen, oder mit einem Texteditor wie Notepad++ oder Atom in eine neue, leere Datei

    
    <? phpinfo();
    

    eingeben, die Datei als phpinfo.php abspeichern (Kodierung: UTF-8 ohne BOM) und ins Hauptverzeichnis deines Servers hochladen. Danach rufst du die URL deinedomain.de/phpinfo.php auf und bekommst eine Übersicht der wichtigsten Einstellungen deines Servers. Suche auf der Infoseite nach memory_limit.

    Wie lauten bei dir die entsprechenden Einstellungen?

    Nicht vergessen: Hinterher die Datei phpinfo.php wieder löschen.

    Ansonsten:

    (1)
    Bei dir ist die PHP-Version 5.5 eingestellt.
    Du könntest über das Kundenmenü mal die eine neuere/höhere Version testen (heute ist eigentlich mindstens 5.6 empfehlenswert, Version 7 ist noch schneller, aber es könnte bei einigen wenigen Plugins noch Konflikte geben, was man aber vorher abklären kann).

    (2)
    Dein installiertes Theme hat die Version 1.3.27 (vom Januar 2016), danach gab es eine ganze Reihe von Updates (vgl. das Changelog: https://generatepress.com/category/development/page/2/).

    • Diese Antwort wurde geändert vor 3 Jahre, 11 Monaten von Bego Mario Garde.
    • Diese Antwort wurde geändert vor 3 Jahre, 11 Monaten von Flower33. Grund: Schlechtschreibung

    Au Mist, durch meine Rechtschreibkorrektur ist er jetzt wieder dort gelandet, sorry, Bego! 🙂

    Moderationshinweis: 😂
    Ich mach ja schon …

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 85)
  • Das Thema „Login ohne Unterlass“ ist für neue Antworten geschlossen.