Support » Allgemeine Fragen » Login ohne Unterlass

  • Hallo im Forum,

    Ich bräuchte dringend Eure Hilfe bei der Lösung eines ziemlich nervenaufreibenden Problems: seit geraumer Zeit (wann genau und nach welchen Manipulationen das angefangen hat, weiß ich leider nicht mehr) muß ich mich ununterbrochen neu einloggen, wenn ich an meiner Homepage arbeite, d.h. nach fast jedem Speichervorgang oder Seitenwechsel.

    Woran kann’s liegen?

    Liebe Grüße und Danke im Voraus für Eure Antworten!
    Dagobert

Ansicht von 15 Antworten - 31 bis 45 (von insgesamt 85)
  • Also, erst mal muß ich sagen, daß mich Eure Hilfsbereitschaft sehr berührt!

    Den Code für die max_execution_time hab ich eingegeben, das hat in der PHP-Übersicht den Wert von 120 aber nicht beeinflußt…sei’s drum! Die Geschwindigkeit ist jetzt wirklich ok.

    Die von Angelika angesprochenen Plugins WP-SpamShield und Really Simple CAPTCHA hab ich jetzt einfach mal deaktiviert, auf die kann ich getrost verzichten. Die beiden verlinkten Texte zu lesen fällt mir verdammt schwer, mein Englisch ist unter aller Kanone (Französisch wurde drübergebügelt).

    Dann habe ich das Theme gewechselt (Twenty Sixteen).

    Nach jeder Maßnahme ausgiebigst an der Site rumgefummelt (Texte geändert und hochgeladen) und feststellen müssen, daß das Login-Problem immer noch nicht tot ist. Der Rhythmus der geforderten Neuanmeldungen ist gefühlsmäßig völlig zufällig, mal nach 10, mal nach 3, mal nach jeder Seite. Ab und zu muß das Passwort sogar zwei Mal hintereinander neu eingeben und eine Rechenaufgabe gelöst werden – das war bei den letztgenannten Versuchen allerdings nicht mehr der Fall.

    Ach ja, andrer Rechner! Hab leider keinen anderen, nur mein iPad, und da ist es exakt das selbe, vielleicht in einem anderen Rhythmus, das kann ich schwer beurteilen…

    Ob ich der einzige bin, der diese Probleme hat? Weiß ich nicht, bin der einzige Admin, der Kollege Alain kümmert sich nicht drum…:-(

    • Diese Antwort wurde geändert vor 4 Jahre, 4 Monaten von Dagobert48.

    Hallo Dagobert,

    Die von Angelika angesprochenen Plugins WP-SpamShield und Really Simple CAPTCHA hab ich jetzt einfach mal deaktiviert, auf die kann ich getrost verzichten

    Ich war eigentlich davon ausgegangen, dass bereits mit deaktivierten Plugins getestet wurde, denn ich hatte im allerersten Beitrag gefragt:

    Hast du schon die üblichen Troubleshooting-Schritte probiert und mal getestet, ob das Problem auch dann auftritt, wenn alle Plugins deaktiviert sind bzw. wenn auf ein Standard-Theme wie z.B. Twenty-Sixteen gewechselt wird?

    Darauf hattest du geantwortet:

    Habe also doch alle Plugins mal abgeschaltet und bin eine Weile durch die Webseite gewandert. War tatsächlich ein bißchen flotter, das Login-Problem bestand aber nach wie vor

    Das ist wirklich ein hartnäckiges Problem und ich kann mir vorstellen, dass das ganz schön nervt.

    Sprich die Erhöhug der max_execution_time bzw. mögliche Timeout-Probleme doch mal noch bei deinem Webhoster an, denn wir haben hier jetzt so ziemlich alle üblichen Verdächtigen durch. 🙂

    Allerdings hast du nach mehrmaligem Nachfragen immer noch nicht explizit geantwortet, welche Plugins genau bei dir eingesetzt werden. Setzt du z.B. auch ein Caching-Plugin ein? Dann solltest du auch dessen Cache mal löschen oder es eventuell sogar mal deinstallieren, da bei bestimmten Caching-Plugins das Deaktivieren allein nicht ausreicht.

    • Diese Antwort wurde geändert vor 4 Jahre, 4 Monaten von Flower33.

    Ich sehe grade, dass mein letzter Punkt ja auch schon von Angelika angesprochen wurde:

    Auch wenn du alle Plug-ins deaktiviert hattest, könnte dennoch das Cache des oder der Plug-ins aktiv gewesen sein und daher trotzdem noch die Probleme extistent gewesen sein. Ist leider manchmal so.

    Ich weiß, bin ein bißchen chaotisch…hatte alle Plugins deaktiviert, die Seiten getestet, sie dann alle nach und nach wieder angeschaltet, die Seiten getestet – but nothing has changed…

    Was ein „Caching-Plugin“ ist, weiß ich nicht, denke nicht, daß ich so was installiert habe. Kann man in diesem Forum ein screenshot hochladen?

    Um das Cache aller Plugins zu löschen, wie gehe ich da genau vor? Alle nochmals deaktivieren, dann den Safari-Cache löschen?

    Das Timeout-Problem werden ich gleich mal den Hostinger-Jungs unterbreiten.

    ___________________________________________
    Habe das Gefühl, ein Sumpfbad zu nehmen…

    Das Timeout-Problem werden ich gleich mal den Hostinger-Jungs unterbreiten.

    Ist bloß eine vage Möglichkeit, vergiss aber nicht, auch nach einer Erhöhung der max_execution_time auf 300 zu fragen, um das als Ursache auszuschließen.
    Hmm, immer noch keine Aufzählung deiner Plugins, das wäre weniger zeitaufwändug, als zu erklären, was ein Caching-Plugin ist. 🙂

    Ich persönlich würde das mit dem Hoster-Kontakt schriftlich machen und die bisher durchgeführten Schritte knapp und präzise auflisten, dann wirst du auch ernster genommen.

    Gleichzeitig anfragen, ob da angesichts der vielen bereits WP-seitig durchgeführten Schritte nicht doch Server-Einstellungen verantwortlich sein könnten und mal das Thema max_execution_time oder Timeout ansprechen (es können natürlich auch andere sein), denn das weiß keiner besser als diese Leute.

    Auf diese Art kannst du nicht mündlich knapp abgespeist werden, sondern hast deren Antwort schriflich und kannst sie auch mal hier zur etwaigen weiteren Diskussion anführen.

    Nachtrag:
    Nicht vergessen, auch mal anzufragen, wieso die output_compression deaktiviert werden musste, denn das sollte auch nicht unbedingt so bleiben, da sie grundsätzlich die Performance verbessert.

    • Diese Antwort wurde geändert vor 4 Jahre, 4 Monaten von Flower33. Grund: Nachtrag

    Also hier mal alle 13 Plugins, die ich installiert habe:

    Contact Form 7
    Contact Form DB
    Easy Google Fonts
    GP Premium
    Iframe Preserver
    MailPoet Newsletters
    Shortcodes Ultimate
    TablePress
    TinyMCE Advanced
    WP Google Maps
    WP Maintenance Mode
    WP Statistics
    WP-SpamShield

    Der Kontakt mit den Hosterjungs ist immer in schriftlicher Form, geht gar nicht anders, ist eine Fa. mit Sitz in Litauen und die drei netten Jungs, die sich regelmäßig um mich kümmern, sitzen vermutlich in Algerien oder Marokko.

    Schreibe denen nach dem Mittagessen…

    • Diese Antwort wurde geändert vor 4 Jahre, 4 Monaten von Dagobert48.

    @flower33:
    Hab ich regelmäßig, wenn ich eine Mirror-Website aufsetze und auf der Original-Website laufen JCHoptimize und HyperCache. Da hilft kein Deaktivieren der Plug-ins oder Löschen des Caches, sondern nur das radikale Löschen der Plug-ins.

    @dagobert: Bego schrieb auf Seite 1:

    sofern nicht eine Weiterleitungsregel in der .htaccess versucht, auf eine Adresse mit www umzuleiten.

    Das wurde noch nicht ausgeschlossen. Die .htaccess liegt im Stammverzeichnis deiner WordPress-Installation. Was steht da drin?

    Ferner:
    Brauchst du das Plug-in „WP Maintenance Mode“? Falls nicht, deaktiviere UND lösche es. Das nimmt ja i. d. R. auch Einfluss auf den Login-Prozess. Wenn das irgendeinen Bug hat, könnte das ursächlich sein.

    @angelika: In der .htaccess steht Folgendes drin:

    php_value max_execution_time 300
    php_flag zlib.output_compression Off
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Die beiden ersten Zeilen (vor „BEGIN WordPress“) wurden auf Vorschlag von Flower33 eingefügt…

    Das „WP Maintenance Mode“ habe ich jetzt gelöscht und den Safari-Casch ebenfalls – hat aber nichts gebracht, die ständige Login-Pflicht besteht weiterhin.

    Den „Hostiger-Jungs“ habe ich geschrieben, Antwort steht aus…

    Wobei sich ja durch den Test mit dem phpinfo-Plugin herausstellte, dass die Direktive

    php_value max_execution_time 300

    bei deinem Hostingpaket per .htaccess nicht greift (bleibt offenbar weiter auf dem Wert 120), womit der Faktor max_execution_time weiterhin eine der möglichen Ursachen ist.

    So kann etwa das eingesetzte Plugin WP Statistics einiges an Ressourcen beanspruchen:
    Im Support-Forum schreibt ein Unser

    I have this plugin on 7 of my sites. One day, one of my sites slowed down to a crawl. I checked the pages that didn’t depend on WordPress and they were working fine. So it seemed like a WP issue. I then tried to log in to the Admin panel but kept getting the “Maximum execution time of 30 seconds exceeded” error message and it was too slow to even bring up the interface to uninstall or update plugins.

    So I had to manually log in to my Webhost and disable the plugins 1 by 1 until I found the culprit: WP Statistics.

    Antwort des Entwicklers:

    Local statistics process can be a very high load process, if your hosting provider limits your resources WP Statistics may not be for you.

    Gut, 30 Sekunden ist ein Vielfaches weniger als 120 Sekunden, aber warten wir einfach mal die Rückmeldung der Webhoster auf die verschiedenen angesprochenen Punkte ab. 🙂

    Noch kurz was zu zwei der genannten Plugins, die eventuell durch bessere bzw. aktuelle Lösungen ersetzt werden sollten:

    (1)
    Beim Plugin WP Maintenance Mode gibt es bei den Bewertungen zahlreiche kritische Stimmen bzgl. Spam:

    This plugin’s developer has chosen to place spam and advertismenets completely unrelated to the plugin in the WordPress dashboard. This is worrisome. Without doing a full code audit, I couldn’t guarantee they wouldn’t do other “blackhat” tactics now or in future updates.

    Es gibt zwar anscheinend einen Button, um den Spam zu verstecken, aber der besagte User wendet ein:

    Having a button to hide the spam does not make it legitimate. That’s like saying that because your email has a delete button, none of the spam emails are spam.

    (2)
    Das Plugin Iframe Preserver wurde zuletzt vor 4 Jahren upgedatet, das ist verdammt lang her und stellt ein potenzielles Sicherheitsrisiko dar. Fragt sich auch, was hier per Iframe eingebettet wird und eine etwaige Ursache sein könnte.

    Hallo Flower33,

    Vielen Dank für die Mühe, die Du Dir meinetwegen machst!

    Auf die Antwort des Hosters warte ich immer noch…

    Das Plugin WP Statistics hatte ich bereits gestern deaktiviert (nicht gelöscht!), war aber ohne Einfluß auf das Login-Problem. Idem WP Maintenance Mode: gelöscht, keine Besserung…

    Den Iframe Preserver habe ich jetzt auch gelöscht, weiß gar nicht mehr, wozu der gut sein soll: keine Besserung…:-(

    Grade mal wieder durch einige Seiten gewandert, jedes Mal kleine Änderungen vorgenommen, die ich dann gespeichert habe. Nach jedem (!) Speichervorgang mußte ich mich wieder neu einloggen (Benutzername behält er, Passwort manchmal, manchmal nicht) und landete aber auf einer ganz anderen Seite als auf der, die ich eben verlassen (und gespeichert) hatte. Ist auch ziemlich neu…

    Das ist schon ein mysteriöser Fall 🙂
    Ich bin wirklich sehr gespannt auf die Antwort des Webhosters, ob da was Serverseitiges eine Rolle spielt. Sag mal, diese Rechenaufgabe im Rahmen des Logins, ist das diejenige, die auch für das Login in den gesicherten Mitgliederbereich kommt? Oder läuft das Mitglieder-Login anders ab? Irgendwo her muss diese Captcha-Rechenaufgabe ja kommen… Oder musstest du auch schon vor dem spezifischen Problem hier beim WP-Login manchmal eine Rechenaufgabe lösen, also etwas, das vielleicht von dem ursprünglichen Dienstleister eingebaut wurde, der euch die Website eingerichtet hat?

    Probiere mal noch Folgendes:

    1. Cache und Cookies löschen
    2. Einloggen, nichts ändern, gleich wieder ausloggen
    3. Erneutes Login, dazu Benutzername + Passwort eingeben sowie:
    5. „Remember Me“ anhaken (bzw. das deutsche Pendant)
    6. Aktionen durchführen + hoffen

    …noch kein Lebenszeichen aus Litauen/Marokko/Algerien…

    Was die Rechenaufgabe betrifft: im Mitgliederbereich gibt es kein Login, nur ein Passwort für vier Seiten und zwei Formulare (Plugin Contact Form7) mit Captcha (Buchstaben-Eingabe), das ich allerdings auf Angelikas Anraten gelöscht habe.
    Nein, die Rechenaufgabe mußte ich vor dem spezifischen Problem nicht lösen und die Webseite habe ich selber mühselig zusammengebastelt (die Installation von WP konnte ich auf der Serverseite mit einem Klick selbst bewerkstelligen).

    Als ich heute Morgen an den Rechner ging, war ich auf meiner Webseite immer noch eingeloggt (hatte mich gestern Abend versehentlich nicht ausgeloggt) und konnte ohne Anmeldung sofort an die Arbeit gehen. Nach den ersten Aktionen mußte ich mich dann aber wieder ständig neu anmelden. Irgend was stimmt nicht mit dem Code, der die Anmeldedauer bzw. den Anmelderhythmus steuert…

    Eben Dein 6-Punkte-Programm durchgeführt: Hoffnung bitter enttäuscht, Neuanmeldung alle zwei Seiten notwendig (manchmal lädt das Anmeldefensterchen zwei Mal), keine Rechenaufgabe mehr…

    Tja, wenn Mutter Theresa noch lebte…

    Noch zwei Vorschläge, am besten beides machen:

    1.) Füge diese beiden Zeilen in die wp-config.php ein

    
    define('WP_HOME','http://commpell.com');
    define('WP_SITEURL','http://commpell.com');

    2.) Lade die .htaccess-Datei herunter und lösche sie auf dem Server. Geh dann dorthin:
    http://commpell.com/wp-admin/options-permalink.php

    und speicher die permalinks erneut ab.

    Melde dich ab, lösche Browser-Cookies und -Cache und dann Daumen drücken.

    Quellen:
    https://codex.wordpress.org/Changing_The_Site_URL
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-wordpress-login-page-refreshing-and-redirecting-issue/

Ansicht von 15 Antworten - 31 bis 45 (von insgesamt 85)
  • Das Thema „Login ohne Unterlass“ ist für neue Antworten geschlossen.