Support » Allgemeine Fragen » Login ohne Unterlass

  • Hallo im Forum,

    Ich bräuchte dringend Eure Hilfe bei der Lösung eines ziemlich nervenaufreibenden Problems: seit geraumer Zeit (wann genau und nach welchen Manipulationen das angefangen hat, weiß ich leider nicht mehr) muß ich mich ununterbrochen neu einloggen, wenn ich an meiner Homepage arbeite, d.h. nach fast jedem Speichervorgang oder Seitenwechsel.

    Woran kann’s liegen?

    Liebe Grüße und Danke im Voraus für Eure Antworten!
    Dagobert

Ansicht von 15 Antworten - 46 bis 60 (von insgesamt 85)
  • Moderator Angelika Reisiger

    (@la-geek)

    Der letzte Post von mir ist verschwunden.

    Moderationshinweis: Dein Beitrag war nicht verschwunden, sondern wartete wegen der Anzahl an Links auf Moderation. Das neue Support-Forum gibt Anwendern bisher noch keinen entsprechenden Hinweis, eine Verbesserung ist aber in Aussicht. Ich schaue zwar mehrmals täglich nach, welche Beiträge moderiert werden müssen, aber in den meisten Fällen dauert es etwas, bis der Beitrag genehmigt wird. Vielen Dank für dein Verständnis, Bego

    Moderator Angelika Reisiger

    (@la-geek)

    Noch 2 Versuche, am besten beides zusammen ausprobieren:

    1.) Trage in die wp-config.php (liegt im WordPress-Stammverzeichnis) folgende 2 Zeilen ein:

    
    define('WP_HOME','http://commpell.com');
    define('WP_SITEURL','http://commpell.com');

    2.) Kopiere die .htaccess sicherheitshalber auf deinen PC. Lösche sie nun auf dem Server. Klick im Dashboard auf Einstellungen -> Permalinks und speicher neu ab. Das generiert eine neue .htaccess Datei.

    Melde dich ab. Lösche Browser-Cache und -Cookies. Schließe Browser. Melde dich neu in WordPress an und „Daumen drücken“.

    Flower33

    (@flower33)

    Um vielleicht dem Mysterium mit der Rechenaufgabe auf die Spur zu kommen:
    Ist das eine Abfrage, die in das „normale“ WordPress-Login integriert ist, also etwa so, wie im nachfolgeden Link gezeigt?
    http://cdn2.wpbeginner.com/wp-content/uploads/2014/11/captcha-user-registration-wordpress.png

    Ob so oder als separate Maske:
    Du könntest mal mit der rechten Maustaste die linke obere Ecke dieser Rechenaufgaben-Maske anklicken und im Kontextmenü „Element untersuchen“ (bzw. „Inspect element“) auswählen.
    Dann öffnet sich das Entwickler-Werkzeug des Browsers und zeigt die HTML- und CSS-Angaben für dieses Element an.

    Screenshot für die im Nachfolgenden genannten Schritte:

    Fahre im linken Fenster so lange über die einzelnen Elemente, bis die fragliche Rechenaufgaben-Maske ausgewählt ist und klicke dann mit der rechten Maustaste auf diese Zeile im linken Fenster.

    Damit werden im rechten Fenster die entsprechenden CSS-Angaben erscheinen und auch (siehe die beiden Pfeile im oben verlinkten Screenshot) die Links zu den CSS-Dateien, aus denen diese Angaben stammen.

    Wenn du mit der Maus über diese (von mir mit Pfeilen markierten) Links fährst, erscheint der komplette Pfad zur fraglichen CSS-Datei.

    Der angezeigte Pfad könnte einen Hinweis darauf geben, woher dieses Rechenaufgaben-Captcha kommt.
    Kannst du den mal angeben?

    • Diese Antwort wurde geändert vor 4 Jahre von Flower33. Grund: Schreibung
    Moderator Bego Mario Garde

    (@pixolin)

    @dagobert48

    „Ab und zu muß das Passwort sogar zwei Mal hintereinander neu eingeben und eine Rechenaufgabe gelöst werden …“

    Darf ich mal fragen, wie du WordPress installiert hast?
    Mein Gedanke dabei: Wenn du zur Installation ein Installations-Skript des Webhoster verwendet hast, kann es sein, dass der Webhoster eine nach seinen eigenen Vorstellungen angepasste Version von WordPress installiert hat (so macht es zumindest nach meinen Informationen Strato). Das würde auch die „Rechenaufgabe“ erklären.
    Hast du mal die Verzeichnisse wp-admin und wp-includes gelöscht und anschließend aus einem frisch heruntergeladenen Dateisatz hochgeladen? Das würde auch helfen, wenn bei einem Update Dateien unvollständig übertragen wurden.

    Ich hab den Thread jetzt nochmal kurz überflogen, aber nichts zur Fehlerausgabe gelesen. Hast du den DEBUG-Modus aktiviert? ( define( 'WP_DEBUG', true ); in der wp-config.php). Gibt die Console der Entwickler-Werkzeuge deines Browsers Fehler aus? (Wenn das Login-Modal erscheint, Rechtsklick > Element Untersuchen > Tab Console).

    Nachtrag: Noch ein Gedanke zu „Passwort zweimal eingeben“ – du hast deine Website auch mal auf möglichen Malware-Befall getestet? (z.B. mit Sucuri Security – Auditing, Malware Scanner and Security Hardening)

    Dagobert48

    (@dagobert48)

    Jetzt kommt’s ja knüppeldick 🙂 !

    Also zunächst mal: kurze Antwort vom Webhoster: er will mehr Infos, will wissen, ob andere Nutzer dasselbe Problem haben, will Infos, um testen zu können (…Kennwort, Passwort?)…
    Habe noch nicht geantwortet.

    @flower33: erstens ist die Rechenaufgabe bei den letzten Logins nicht mehr erschienen, zweitens kann ich den Screenshot nicht sehen, da legt sich eine Werbung für ein Scheiß-Kriegsspiel drüber, das partout nicht wegzuklicken ist…

    @angelika: Mach ich alles gleich mal, bin jetzt in Kamikazestimmung.

    @bego: WP hatte ich tatsächlich als Webhoster-Skript installiert. Aber nochmals: die Rechenaufgaben-Geschichte ist gemeinsam mit dem Login-Problem und nicht regelmäßig erschienen (zur Frage von Flower33: die Rechenaufgabe war in der Login-Maske integriert) und zwar lange nach der Installation von WP vor geschätzten 3 Jahren.
    – Die Verzeichnisse in wp-admin und wp-includeswürde ich ja gerne löschen, wenn ich wüsste, wo man den „frisch heruntergeladenen Dateisatz“ kaufen kann :-).
    – Der DEBUG-Modus steht auf false, das hatte mir flower33 so empfohlen. Wieder zurückrudern?

    Geb ich dem Webmaster die Login-Daten zum testen?

    • Diese Antwort wurde geändert vor 4 Jahre von Dagobert48.
    Moderator Bego Mario Garde

    (@pixolin)

    Der Webhoster braucht deine Zugangsdaten nicht. Der hat ganz andere Möglichkeiten, sich Datenbank und Dateien anzuschauen. (Leider machen es sich einige Webhoster gerne einfach und verweisen dann gerne wieder auf WordPress.)

    WordPress kannst du hier herunterladen: https://wordpress.org/latest.zip

    Die .zip-Datei kannst du auf deinem Computer entpacken, dann die Verzeichnisse wp-admin und wp-includes per FTP hochladen. (Bitte aber zuerst auf dem Server die beiden Verzeichnisse auch tatsächlich löschen – manche FTP-Clients überspringen schon mal gerne vorhandene Dateien, statt sie wirklich zu überschreiben.)

    Vor solchen Aktionen ist es übrigens nicht verkehrt, mal ein Backup zu machen. 😉

    Flower33

    (@flower33)

    – Der DEBUG-Modus steht auf false, das hatte mir flower33 so empfohlen. Wieder zurückrudern?

    Den DEBUG-Modus schaltet man immer nur kurz zum Debuggen ein, danach wieder aus.
    Da bei dir am Seitenende die Meldung mit der output_compression permanent angezeigt wurde, war das ein Zeichen dafür, dass bei dir der DEBUG-Modus permannt eingeschaltet war, was ja nicht der Fall sein soll. Daher riet ich dir, ihn wieder abzuschalten (und diesen Punkt mal beim Webhoster anzusprechen). Bego wollte darüber mal noch schauen, ob irgendwelche Fehler angezeigt werden, falls das noch nicht geprüft worden sein sollte.

    • Diese Antwort wurde geändert vor 4 Jahre von Flower33.
    Moderator Bego Mario Garde

    (@pixolin)

    Genau.

    1. mögliche Fehlerquellen eingrenzen: Plugins deaktivieren, Standard-Theme verwenden
    2. Fehlermeldungen auswerten (WP_DEBUG, Apache Error-Log, Browser-Console).

    Wenn gar nichts geht, würde ich ein Backup von Datenbank und wp-content machen, alles runter schmeißen, WordPress frisch installieren, in der neuen Installation prüfen, ob das Problem weiterhin besteht (dann ist eine fehlerhafte Serverkonfiguration möglich, ich glaube, darüber haben wir hier noch gar nicht gesprochen?) und erst nach dieser Abklärung Datenbank und wp-content wiederherstellen.

    Der Thread ist mittlerweile etwas lang geworden – das ist bisher völlig OK, aber vielleicht sollte jetzt etwas systematischer vorgegangen werden?

    Flower33

    (@flower33)

    zweitens kann ich den Screenshot nicht sehen, da legt sich eine Werbung für ein Scheiß-Kriegsspiel drüber, das partout nicht wegzuklicken ist…

    Das klingt aber gar nicht gut, ist aber andererseits nicht verwunderlich, falls du dort das kostenlose Hosting-Paket nutzen solltest, das die im Angebot haben, wie ich heute gesehen habe.

    Das wäre mir nicht geheuer, schon gar nicht für eine Unternehmensseite, in die ja auch Kunden involviert sind. Bego hat kürzlich hier im Forum spottbillige, aber überzeugende Hosting-Angbote mit Servern in Deutschland aufgezählt. Da würde ich mal drüber nachdenken, unabhängig davon, wie diese Story jetzt ausgeht.

    • Diese Antwort wurde geändert vor 4 Jahre von Flower33. Grund: Schreibung
    Flower33

    (@flower33)

    vielleicht sollte jetzt etwas systematischer vorgegangen werden?

    Bis auf Apache Error-Log und Browser-Console wurden bereits alle üblichen Punkte im bisherigen Thread angesprochen 🙂

    1. mögliche Fehlerquellen eingrenzen: Plugins deaktivieren, Standard-Theme verwenden

    Plugins wurden bereits alle deaktiviert, Thema wurde bereits gewechselt 🙂
    Habe also doch alle Plugins mal abgeschaltet und bin eine Weile durch die Webseite gewandert. War tatsächlich ein bißchen flotter, das Login-Problem bestand aber nach wie vor

    Dann habe ich das Theme gewechselt (Twenty Sixteen).
    Nach jeder Maßnahme ausgiebigst an der Site rumgefummelt (Texte geändert und hochgeladen) und feststellen müssen, daß das Login-Problem immer noch nicht tot ist.

    2. Fehlermeldungen auswerten (WP_DEBUG, Apache Error-Log, Browser-Console).

    DEBUG-Modus wurde schon ganz am Anfang auf dein Anraten hin eingeschaltet und dann vergessen auszuschalten.
    Bleiben also noch Apache Error-Log und die Browser-Console übrig.

    Flower33

    (@flower33)

    zweitens kann ich den Screenshot nicht sehen, da legt sich eine Werbung für ein Scheiß-Kriegsspiel drüber, das partout nicht wegzuklicken ist…

    Merke gerade, dass ich das missverstanden und auf deinen Webhoster bezogen habe! 🙂
    Tut mir Leid, ich nutze diesen Upload-Service, weil man sich da nicht zu registrieren braucht, und weil ich das Noscript-Addon nutze, ist mir noch gar nicht aufgefallen, dass da so blöde Werbung kommt. Da muss ich mir wohl eine andere Lösung suchen bzw. die foreneigene nutzen.

    Flower33

    (@flower33)

    Bleiben also noch Apache Error-Log und die Browser-Console übrig.

    Von den in 1. und 2. genannten Maßnahmen zur Eingrenzung der Fehlerquellen wohlgemerkt, damit da keine Missverständnisse aufkommen.
    Die weiteren genannten Punkte natürlich nicht vergessen! 🙂

    Dagobert48

    (@dagobert48)

    Jetzt fang ich an, den Überblick zu verlieren…

    Was ich gemacht habe:
    – DEBUG wieder auf „true“ gesetzt
    – Login-Modal > Tab Console : keine error-Meldung
    define('WP_HOME','http://commpell.com'); define('WP_SITEURL','http://commpell.com'); in die wp-config.phpeingegeben (Kopfzeile): hat die Webseite vollkommen durcheinandergebracht (Code oben sichtbar), die zwei Zeilen wieder gelöscht.
    – neue .htaccess Datei generiert (Gebrauchsanweisung Angelika),
    – dann Seite getestet: nichts geändert, alle zwei Seiten Neuanmeldung erforderlich.
    – Dem Hoster geantwortet.

    Was ich nicht machen kann (überfordert meine Fähigkeiten):
    – die Verzeichnisse wp-admin und wp-includes bzw. wp-content löschen und neu hochladen bzw. WP neu installieren.

    Was ich noch nicht gemacht habe, weil ich es nicht verstehe:
    – „Bleiben also noch Apache Error-Log und die Browser-Console“
    – einen Malware-Test gemacht

    Was das Web-Hosting betrifft, habe ich das Premium-Paket. Der Support ist relativ ok, das dauert immer ein bisschen und die Hilfe reduziert sich auf’s Nötigste, bisher aber sind alle Probleme irgend wie irgend wann gelöst worden. Das ist das erste Mal, daß es klemmt…

    Ein Umzug zu einem dt Hoster wäre mir ganz lieb, ich scheue aber Komplikationen beim Transfer. Vielleicht zu Unrecht.

    • Diese Antwort wurde geändert vor 4 Jahre von Dagobert48.
    • Diese Antwort wurde geändert vor 4 Jahre von Dagobert48.
    • Diese Antwort wurde geändert vor 4 Jahre von Dagobert48.
    Moderator Bego Mario Garde

    (@pixolin)

    – define(‚WP_HOME‘,’http://commpell.com‘); define(‚WP_SITEURL‘,’http://commpell.com‘); in die wp-config.phpeingegeben (Kopfzeile): hat die Webseite vollkommen durcheinandergebracht (Code oben sichtbar), die zwei Zeilen wieder gelöscht.

    Dann hast du es wahrscheinlich an der falschen Stelle eingetragen. Die beiden Zeilen gehören direkt über die Zeile /* That's all, stop editing! Happy blogging. */.

    Was ich nicht machen kann (überfordert meine Fähigkeiten):
    – die Verzeichnisse wp-admin und wp-includes bzw. wp-content löschen und neu hochladen bzw. WP neu installieren.

    Das Verzeichnis wp-content darfst du nicht!!!1! löschen, sonst gehen alle Uploads (Mediendateien, Plugins, Themes, Sprachdateien) verloren.
    Hast du mal versucht, über Dashboard > Aktualisierungen die WordPress-Version erneut zu installieren?
    Kommst du mit einem FTP-Programm zurecht? Welches nutzt du?

    Was ich noch nicht gemacht habe, weil ich es nicht verstehe:
    – „Bleiben also noch Apache Error-Log und die Browser-Console“

    Zum Apache Error Log könntest du den Support deines Webhoster ansprechen. Die Fehlermeldungen in der Browser-Console siehst du, wenn du im Browser einen Rechtsklick machst, auf „Element untersuchen“ klickst und dann im Tab „Console“ nachschaust, ob es rot hinterlegte Fehlermeldungen gibt.

    Moderator Bego Mario Garde

    (@pixolin)

    Ich war gerade mal so frei und habe mich auf deiner Website angemeldet. Meine (erdachten) „Zugangsdaten“ User: test und Passwort: test wurden natürlich abgelehnt, soweit ist das nicht ungewöhnlich. Ich werde dann aber auf eine verschlüsselte Verbindung https://commpell.com weitergeleitet – und da scheint das Problem zu liegen.

    Mach doch bitte mal einen Screenshot von Einstellungen > Allgemein, lad ihn bei imgur.com hoch und gib uns hier den Link.

    Meine Vermutung: du hast
    Website-URL: http://commpell.com
    WordPress-URL: https://commpell.com eingetragen.

Ansicht von 15 Antworten - 46 bis 60 (von insgesamt 85)
  • Das Thema „Login ohne Unterlass“ ist für neue Antworten geschlossen.