Support » Allgemeine Fragen » Login Redirektion bei Netzwerk Login

  • Gelöst richard71

    (@richard71)


    Hallo zusammen,
    ich helfe einer Schülerfirma bei der Betreuung einer WordPress Installation, die aus 2 vernetzten Webseiten besteht. Bis jetzt hat auch alles soweit funktioniert, aber als ich heute ein neues Plug-In installieren wollte, musste ich leider feststellen, dass das Login für den Super Administrator offensichtlich in eine Endlosschleife läuft. UID und Passwort sind richtig und werden akzeptiert, aber danach erscheint dann wieder der Login Screen. Dasselbe passiert auch, wenn ich z.B. einen manuellen Update starten möchte oder wenn ich andere Aktivitäten durchführen möchte, die Super Administrator Rechte erfordern. Hat jemand eine Idee, wie sich das lösen lässt? Wir haben eine Abmahnung bezgl. der Google Fonts erhalten und ich möchte das mit der schon in anderen Fragen erwähnten Plug-Ins beheben.
    Vielen Dank für eure Hilfe Richard

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 39)
  • Thread-Starter richard71

    (@richard71)

    Hallo Michi91,

    hab ich gerade probiert. Der Aufruf der Plug-Ins zeigt auch einen Fehler, aber das Netzwerk Login des Super Administrators bleibt weiterhin in der Endlosschleife hängen. Das normale Login zur Administration der Web-Seite funktioniert. Das Problem taucht nur beim Netzwerk Login auf.

    Danke für Deine Hilfe
    Richard

    Ist das eine Multisite mit 2 verschiedenen Domains?
    Irgendwas klappte bei mir mit dem Anmelden damals auch nicht, ich weiß aber nicht mehr genau was.
    Bei mir steht jedenfalls im wp-config.php:

    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST'] );
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */

    Poste bitte mal den Inhalt der .htaccess.

    Thread-Starter richard71

    (@richard71)

    Hallo Bego,

    ich habe 2 davon. Die erste befindet sich im Ordner www und die zweite eine Ebene tiefer in www/wordpress. Hier ist die erste:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
     
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
     
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^(.*\.php)$ wp/$2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    und das ist die zweite:

    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    
    # END WordPress

    Ich hoffe, Du findest hier etwas.
    Vielen Dank
    Richard

    Thread-Starter richard71

    (@richard71)

    @hupe13

    Sorry, aber das hat auch nichts gebracht. Ich drehe mich weiter in der Endlosschleife.

    Danke für Deine Mühe
    Richard

    Du kannst versuchen, die .htaccess in www/wordpress in no.htaccess umzubenennen, obwohl das wahrscheinlich nicht viel bringen wird.

    Postest du bitte noch den Inhalt der wp-config.php (die Zeilen mit den Datenbank-Zugangsdaten und SALT-Keys bitte vor dem Absenden aus der Antwort löschen).

    Thread-Starter richard71

    (@richard71)

    Hallo Bego,

    Sorry, das ich erst so spät reagiere, aber heute waren die Priortäten erst mal anders gesetzt.
    Das Umbenennen der .htaccess hat tatsächlich nichts gebracht. Und wp-config dateien habe ich wieder 2, eine unter www und die andere unter www/wordpress.

    Hier ist die aus dem Ordner www:

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    
    define('WP_HOME','http://oeko-e.de');
    define('WP_SITEURL','http://oeko-e.de');
    define('DB_NAME', 'xa2302_db1');
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define('DB_USER', 'xa2302_1');
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define('DB_PASSWORD', 'gelöscht');
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define('DB_HOST', 'localhost');
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define('DB_CHARSET', 'utf8');
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'gelöscht');
    define('SECURE_AUTH_KEY',  'gelöscht');
    define('LOGGED_IN_KEY',    'gelöscht');
    define('NONCE_KEY',        'gelöscht');
    define('AUTH_SALT',        'gelöscht');
    define('SECURE_AUTH_SALT', 'gelöscht');
    define('LOGGED_IN_SALT',   'gelöscht');
    define('NONCE_SALT',       'gelöscht');
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix  = 'wp_';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define('WP_DEBUG', false);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'oeko-e.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    	
    define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST'] );
    
    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST'] );
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    
    require_once(ABSPATH . 'wp-settings.php');

    und das ist die aus www/worpress:

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /** 
    *   define('WP_HOME','http://oeko-e.de');
    *   define('WP_SITEURL','http://oeko-e.de');    **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define( 'DB_NAME', 'xa2302_db1' );
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define( 'DB_USER', 'xa2302_1' );
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define( 'DB_PASSWORD', 'gelöscht' );
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define( 'DB_HOST', '127.0.0.1' );
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define( 'DB_CHARSET', 'utf8mb4' );
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    define( 'AUTH_KEY',         'gelöscht' );
    define( 'SECURE_AUTH_KEY',  'gelöscht' );
    define( 'LOGGED_IN_KEY',    'gelöscht' );
    define( 'NONCE_KEY',        'gelöscht' );
    define( 'AUTH_SALT',        'gelöscht' );
    define( 'SECURE_AUTH_SALT', 'gelöscht' );
    define( 'LOGGED_IN_SALT',   'gelöscht' );
    define( 'NONCE_SALT',       'gelöscht' );
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix = 'wp_';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define( 'WP_DEBUG', false );
    
    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST'] );
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß. */
    /* That's all, stop editing! Happy publishing. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once( ABSPATH . 'wp-settings.php' );
    
    /** Auto Update WordPress Core */
    define( 'WP_AUTO_UPDATE_CORE', true );

    In der ersten wp-config.php hast du

    define('WP_HOME','http://o***e.de');
    define('WP_SITEURL','http://o***e.de');

    eingetragen. Damit wird eigentlich der Datenbankeintrag überschrieben. Kurioserweise werde ich aber bei Aufruf dieser URL auf die URL mit https://www… weitergeleitet. Vermutlich verwendest du dafür ein Plugin, von dem wir nichts wissen? (z.B. Really Simple SSL?)

    Bei define('DOMAIN_CURRENT_SITE', 'oeko-e.de'); fehlt auch das www, was erklären könnte, wieso das Cookie falsch gesetzt wird.

    Nachtrag: Zwei Konfigurationsdateien wp-config.php sorgen bestenfalls für Verwirrung. Du solltest nur eine Datei behalten (die mit den Einträgen für dein WordPress-Netzwerk).

    Thread-Starter richard71

    (@richard71)

    Hallo Bego,

    Also die Configurations-Einträge hat jemand lange vor meiner Zeit gemacht und den kann ich auch nicht mehr fragen. Die Web-Seite hat ja so auch lange Jahre funktioniert und auch als ich die zweite Seite hinzugefügt habe (und damit die WordPress Netzwerkstruktur), hat es ja erst keine Probleme gegeben. Dies ganze Konfiguration mit den doppelten Strukturen hat WordPress alleine angelegt. Ich hab da eigentlich nichts dran gemacht. Ich vermute, es hat etwas mit einem der WordPress Updates zu tun, die in letzter Zeit automatisch eingefügt wurden. Kann es sein, das das Login Script beim Netzwerk Login falsch reagiert?

    Ach ja, diese Umleitungen auf https://www. werden wahrscheinlich durch unseren Hoster erzeugt. Ich habe kein derartiges Plugin installiert. Das hier sind die aktuell vorhandenen Plugins:

    Gallery - Video Gallery
    
    Video Gallery plugin was created and specifically designed to show your video files in unusual splendid ways.
    Version 2.2.0 | Von Huge-IT | Plugin-Seite aufrufen
    NextGEN Gallery auswählen
    	
    NextGEN Gallery
    
    The most popular gallery plugin for WordPress and one of the most popular plugins of all time with over 24 million downloads.
    Version 3.1.6 | Von Imagely | Details ansehen | Hilfe | Mithelfen
    WordPress Importer auswählen
    	
    WordPress Importer
    
    Importiere Beiträge, Seiten, Kommentare, benutzerdefinierte Felder, Kategorien, Schlagwörter und mehr aus einer WordPress-Exportdatei.
    Version 0.7 | Von wordpressdotorg | Details ansehen
    WordPress MU Domain Mapping auswählen
    	
    WordPress MU Domain Mapping
    	
    
    Map any blog on a WordPress website to another domain.
    Version 0.5.5.1 | Von Donncha O Caoimh | Details ansehen

    Wenn ich in der übergeordneten Config Datei das „www.“ einfüge, wie Du vorgeschlagen hast, kommt die folgende Fehlermeldung (Cookies und Cache habe ich vorher gelöscht und mich auch komplett neu angemeldet):

    Fehler: Umleitungsfehler

    Beim Verbinden mit http://www.oeko-e.de trat ein Fehler auf.

    Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden.

    Dank für Deine Hilfe
    Richard

    Die Web-Seite hat ja so auch lange Jahre funktioniert und auch als ich die zweite Seite hinzugefügt habe (und damit die WordPress Netzwerkstruktur), hat es ja erst keine Probleme gegeben. Dies ganze Konfiguration mit den doppelten Strukturen hat WordPress alleine angelegt.

    Ist das eine WordPress-Installation, konfiguriert als Multisite oder sind das mehrere WordPress-Installationen?
    Wieviele Verzeichnisse wp-content gibt es?
    Wie lauten die Start-URLs der beiden Seiten?

    Thread-Starter richard71

    (@richard71)

    Das ist eine WordPress Installation, konfiguriert als Multi-Site und so sieht die Struktur aus:
    home
    www
    brindando-esperanza
    wordpress
    wp-admin
    wp-content
    wp-includes
    wp-admin
    wp-content
    wp-includes

    Die URLs sind http://www.oeko-e.de und brindando-esperenza.com.
    Ein Login auf beide Seiten funktioniert und ich kann auch als Admin auf oeko-e.de (die Hauptseite) zugreifen.

    Danke für Deine Hilfe
    Richard

    Thread-Starter richard71

    (@richard71)

    Sorry, ich hatte da eine schöne Struktur mit Leerzeichen gebaut und die ist beim Senden komplett verändert worden (Offensichtlich mag dieses Forum keine mehrfach Leerzeichen). Deshalb hier nochmal, diesmal mit Punkten:
    home
    ..www
    –brindando-esperanza
    ..wordpress
    ….wp-admin
    ….wp-content
    ….wp-includes
    ..wp-admin
    ..wp-content
    ..wp-includes`

    Um Himmelswillen! Benenne bitte sofort!!! das Verzeichnis wordpress um!

    Thread-Starter richard71

    (@richard71)

    Hi hupe13,

    Das war es. Jetzt funktioniert das Login wieder. Ich frage mich jetzt nur, woher dieser Eintrag gekommen ist. Wie schon gesagt, ich habe das Ganze vor ca. einem Jahr nur mit den WordPress Bordmitteln eingerichtet und es lief ja auch, bis ich diese Woche noch mal daran musste.

    Super und vielen vielen Dank für Deine Hilfe
    Richard

    Thread-Starter richard71

    (@richard71)

    Sorry, es hat leider nur einmal funktioniert, jetzt tritt der gleiche Fehler wieder auf.
    PS: KAnn man den Status „gelöst“ wieder zurücksetzen?

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 39)
  • Das Thema „Login Redirektion bei Netzwerk Login“ ist für neue Antworten geschlossen.