Support » Allgemeine Fragen » Mails werden nicht versendet

  • Gelöst alfonso55

    (@alfonso55)


    Seit einiger Zeit können über das Kontaktformular auf http://www.jgv56-60.ch keine Mails mehr verschickt werden. Es wird ein Fehler ausgegeben.

    Im WP-Dateimanager unter www/jgv56-60.ch/wp-includes/PHPMailer) sehe ich bei PHPMailer.php, dass ich keinen Zugriff auf diese Datei habe.

    Liegt hier das Problem? Wie kann ich es lösen?

    Bei einer anderen Website kann ich unter PHPMailer.php „lesen und schreiben“, und die Mails werden verschickt.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • bscu

    (@bscu)

    Es wird ein Fehler ausgegeben.

    Der wie lautet?

    Moderator Hans-Gerd Gerhards

    (@hage)

    … und welches Plugin setzt du ein?
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Thread-Starter alfonso55

    (@alfonso55)

    Vielen Dank für eure Rückmeldungen!
    Entschuldigt bitte meine Anfängerfehler.
    Unten der Bericht.

    Ich benutze Elementor pro und das Widget „Formular“.

    Wenn ich auf der Homepage versuche, eine Kontaktmail zu senden, erfolgt die Meldung „error“.

    Wenn ich mit dem Plugin „Check & Log Email“ versuche, ein Mail zu senden, kommt die Meldung „Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.“

    
    ### wp-core ###
    
    version: 5.9
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Zurich
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/orifucup/www/jgv56-60.ch
    wordpress_size: 51,56 MB (54067631 bytes)
    uploads_path: /home/orifucup/www/jgv56-60.ch/wp-content/uploads
    uploads_size: 187,30 MB (196398084 bytes)
    themes_path: /home/orifucup/www/jgv56-60.ch/wp-content/themes
    themes_size: 4,17 MB (4373065 bytes)
    plugins_path: /home/orifucup/www/jgv56-60.ch/wp-content/plugins
    plugins_size: 97,08 MB (101791441 bytes)
    database_size: 154,45 MB (161947592 bytes)
    total_size: 494,55 MB (518577813 bytes)
    
    ### wp-active-theme ###
    
    name: Hello Elementor (hello-elementor)
    version: 2.5.0
    author: Elementor Team
    author_website: https://elementor.com/?utm_source=wp-themes&utm_campaign=author-uri&utm_medium=wp-dash
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, widgets-block-editor, menus, automatic-feed-links, title-tag, html5, custom-logo, editor-style, align-wide, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider
    theme_path: /home/orifucup/www/jgv56-60.ch/wp-content/themes/hello-elementor
    auto_update: Aktiviert
    
    ### wp-themes-inactive (2) ###
    
    Twenty Twenty-One: version: 1.5, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (6) ###
    
    Check & Log Email: version: 1.0.4, author: WPChill, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.5.5, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Elementor Pro: version: 3.6.2, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Quick Event Manager: version: 9.2.15, author: Fullworks, Automatische Aktualisierungen deaktiviert
    WP File Manager: version: 7.1.4, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 18.1, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (4) ###
    
    Akismet Anti-Spam: version: 4.2.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    BackWPup Pro: version: 3.9.0, author: Inpsyde GmbH, Automatische Aktualisierungen deaktiviert
    Happyforms (free): version: 1.14.1, author: Happyforms, Automatische Aktualisierungen deaktiviert
    Post SMTP: version: 2.0.24, author: Yehuda Hassine, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-34 Q16 amd64 2021-12-22 https://imagemagick.org
    imagick_version: 3.5.1
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 512 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 1536
    	imagick::RESOURCETYPE_MAP: 512 GB
    	imagick::RESOURCETYPE_MEMORY: 256 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, YCbCr, YCbCrA, YUV
    gd_version: 2.3.1
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: 9.52
    
    ### wp-server ###
    
    server_architecture: FreeBSD 12.3-RELEASE-p1 amd64
    httpd_software: Apache
    php_version: 7.4.27 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.80.0 OpenSSL/1.1.1m
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.34-MariaDB-log
    client_version: mysqlnd 7.4.27
    max_allowed_packet: 16777216
    max_connections: 400
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/orifucup/www/jgv56-60.ch/wp-content
    WP_PLUGIN_DIR: /home/orifucup/www/jgv56-60.ch/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    sorry, aber wir können dir bei gekauften Themes oder Plugins (hier Elementor Pro) so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das entsprechende Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an die Entwickler wenden.
    Viele Grüße
    Hans-Gerd

    Thread-Starter alfonso55

    (@alfonso55)

    Hallo
    Ich denke, das Problem ist generell und hat gar nichts mit Elementor zu tun. Im WP-Dateimanager habe ich ja keinen Zugang zu PHPMailer.php, und ich denke dort liegt der Fehler. WordPress lässt überhaupt keinen Mailausgang zu, egal von wo das Mail geschickt wird.
    Viele Grüsse
    Alfons

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme Hello Elementor und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und Plugins sieht, während nur für dich alle Plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße
    Hans-Gerd

    Thread-Starter alfonso55

    (@alfonso55)

    Herzlichen Dank für deinen Rat.
    Ich werde das so probieren.
    Viele Grüsse
    Alfons

    Thread-Starter alfonso55

    (@alfonso55)

    Hallo
    Das Problem ist gelöst. Mein Provider hat beim zweiten Nachfragen den Fehler herausgefunden. Er hat die Datei PHPMailer.php vorübergehend blockiert, weil das Kontaktformular für Spamversand missbraucht worden sei. Komischerweise hat er sie erst blockiert, nachdem ich das Formular mit einem Captcha-Code gesichert hatte.
    Vielen Dank für eure Mithilfe.
    Beste Grüsse
    Alfons

    bscu

    (@bscu)

    Er hat die Datei PHPMailer.php vorübergehend blockiert

    Ohne dich zu informieren? Starkes Stück 🙁

    Moderator Hans-Gerd Gerhards

    (@hage)

    Danke für die Rückmeldung. 👍

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Mails werden nicht versendet“ ist für neue Antworten geschlossen.