Support » Plugins » Matomo sorgt für kritischen WordPress-Fehler

  • Gelöst moonier

    (@moonier)


    Hey,

    ich habe gerade Matomo bei mir als Plugin installiert und aktiviert. Gleich nach der Aktivierung erhielt ich einen Whitescreen mit der Info „Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.“.

    Tritt dies bei Matomo auch bei euch auf? Was kann ich tun, um Matomo zum laufen zu bringen?

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Thread-Starter moonier

    (@moonier)

    Ich habe gerade das Forum zu Matomo gefunden. Dort habe ich jetzt einen neuen Post erstellt.

    ich habe gerade Matomo bei mir als Plugin installiert und aktiviert.

    Da gibt es zwei verschiedene Plugins. Welches verwendest du?

    Wir wissen so gut wie nichts über die Website. Ein Website-Bericht wäre hilfreich. (→ Bevor du ein neues Thema (Thread) erstellst)

    Thread-Starter moonier

    (@moonier)

    Hey Bego,

    ich meine dieses: https://de.wordpress.org/plugins/matomo/

    Meine Website befindet sich im Aufbau und ist daher noch im Wartungsmodus. Daher bringt es nichts, wenn ich diese hier teile.

    Ich habe mittlerweile das Matomo Plugin wieder über den FTP-Server gelöscht. Sonst hätte ich bis jetzt keinen Zugriff auf mein Admin-Bereich.

    Hier ist der Website-Bericht:

    
    ### wp-core ###
    
    version: 5.9.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/webpages/lima-city/shield/theWebdeveloper
    wordpress_size: 53,04 MB (55617681 bytes)
    uploads_path: /home/webpages/lima-city/shield/theWebdeveloper/wp-content/uploads
    uploads_size: 97,56 MB (102298316 bytes)
    themes_path: /home/webpages/lima-city/shield/theWebdeveloper/wp-content/themes
    themes_size: 20,99 MB (22004892 bytes)
    plugins_path: /home/webpages/lima-city/shield/theWebdeveloper/wp-content/plugins
    plugins_size: 117,16 MB (122855850 bytes)
    database_size: 13,17 MB (13811712 bytes)
    total_size: 301,92 MB (316588451 bytes)
    
    ### wp-active-theme ###
    
    name: Astra (astra)
    version: 3.7.9
    author: Brainstorm Force
    author_website: https://wpastra.com/about/?utm_source=theme_preview&utm_medium=author_link&utm_campaign=astra_theme
    parent_theme: none
    theme_features: core-block-patterns, astra_hooks, widgets-block-editor, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, rank-math-breadcrumbs, amp, widgets, menus
    theme_path: /home/webpages/lima-city/shield/theWebdeveloper/wp-content/themes/astra
    auto_update: Deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    Elementor Safe Mode: version: 1.0.0, author: Elementor.com
    
    ### wp-plugins-active (14) ###
    
    Code Snippets: version: 2.14.3, author: Code Snippets Pro, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.6.1, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Elementor Pro: version: 3.6.4, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Google Analytics for WordPress by MonsterInsights: version: 8.4.0, author: MonsterInsights, Automatische Aktualisierungen aktiviert
    Maintenance: version: 4.05, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    Redirection: version: 5.2.3, author: John Godley, Automatische Aktualisierungen deaktiviert
    Remove IP: version: 0.1, author: guido, Automatische Aktualisierungen deaktiviert
    Shariff Wrapper: version: 4.6.7, author: Jan-Peter Lambeck & 3UU, Automatische Aktualisierungen deaktiviert
    Sticky Menu (or Anything!) on Scroll: version: 2.31, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    TaxoPress: version: 3.5.3, author: TaxoPress, Automatische Aktualisierungen deaktiviert
    WordPress Editorial Calendar: version: 3.7.11, author: Colin Vernon, Justin Evans, Joachim Kudish, Mary Vogt, and Zack Grossbart, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.7.3, author: WPForms, Automatische Aktualisierungen deaktiviert
    WPFront Scroll Top: version: 2.0.7.08086, author: Syam Mohan, Automatische Aktualisierungen deaktiviert
    Yoast Duplicate Post: version: 4.4, author: Enrico Battocchi & Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (5) ###
    
    Antispam Bee: version: 2.11.0, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    Autoptimize: version: 2.9.5.1, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.1.2, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Temporary Login Without Password: version: 1.7.2, author: StoreApps, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 18.4.1, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 500M
    upload_max_filesize: 500M
    max_effective_size: 500 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 5.4.0-100-generic x86_64
    httpd_software: Apache/2.4
    php_version: 8.0.16 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 3000
    time_limit: 300
    memory_limit: 256M
    max_input_time: 120
    upload_max_filesize: 500M
    php_post_max_size: 500M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.25-15
    client_version: mysqlnd 8.0.16
    max_allowed_packet: 67108864
    max_connections: 1001
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/webpages/lima-city/shield/theWebdeveloper/wp-content
    WP_PLUGIN_DIR: /home/webpages/lima-city/shield/theWebdeveloper/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### wpforms ###
    
    version: 1.7.3
    lite: Mrz 21, 2022 @ 6:40pm
    upload_dir: Beschreibbar
    db_tables: pAKR_wpforms_tasks_meta
    total_forms: 1
    total_submissions: undefined
    
    
    • Diese Antwort wurde geändert vor 6 Monaten, 1 Woche von moonier.
    • Diese Antwort wurde geändert vor 6 Monaten, 1 Woche von Bego Mario Garde.

    Wenn ich es richtig verstehe, liefert das Plugin gleich eine Matomo-Installation mit. Mir ist persönlich lieber, Matomo separat zu installieren und dann das Plugin WP-Matomo Integration (WP-Piwik) zur Integration zu verwenden. Allerdings ist es dann sinnvoll, WordPress in einem eigenen Verzeichnis zu installieren.

    Es laufen noch nicht alle Plugins mit PHP 8.0 – gut möglich, dass das den „kritischen Fehler“ verursacht hat.

    Thread-Starter moonier

    (@moonier)

    Ich gehe davon aus. Ja.

    Dies hat früher für mich immer super geklappt. Ich habe jetzt die PHP-Version von 8.0 auf 7.4 geändert. Ändert nichts am Error.

    In der Error-Email wird mir auch folgendes gesagt:
    „Seit WordPress 5.2 gibt es eine eingebaute Funktion, die erkennt, wenn ein Plugin oder ein Theme einen fatalen Fehler auf deiner Website verursacht, und dich deswegen mit dieser automatisierten E-Mail benachrichtigt.

    In diesem Fall hat WordPress einen Fehler in einem deiner Plugins, Matomo Analytics – Ethical Stats. Powerful Insights., abgefangen.

    Danke für den Vorschlag Matomo separat zu installieren und dann über das von dir genannte Plugin zu integrieren. Dies werde ich jetzt auch machen.

    EDIT: Ich sehe gerade, dass bei der Plugininstallation was fehlgeschlagen ist. Siehe Bild: https://ibb.co/qJzBnfr

    • Diese Antwort wurde geändert vor 6 Monaten, 1 Woche von moonier.
    • Diese Antwort wurde geändert vor 6 Monaten, 1 Woche von moonier.

    Da scheint es ein Problem mit dem Benutzerrechte für die MySQL-Datenbank zu geben.

    Thread-Starter moonier

    (@moonier)

    Hi Bego,

    danke dir.

    Ich habe gestern Abend mir nochmal die Fehlermeldung angeschaut. Dabei ist mir der Username des DB-Nutzers aufgefallen. Daraufhin habe ich auch die Rechte überprüft und gesehen, dass er nicht die notwendigen Rechte dafür besitzt.

    Nachdem ich nun die notwendigen Rechte hinzugefügt habe, funktioniert es.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Matomo sorgt für kritischen WordPress-Fehler“ ist für neue Antworten geschlossen.