Support » Allgemeine Fragen » Mediathek funktioniert nicht

  • Hallo Gemeinde,

    seit dem Umzug einer WordPress-Site vom localhost auf one.com funktioniert die Mediathek nicht mehr.

    Die Site funktioniert und alle Bilder sind online.

    Die Mediathek im WP-Admin ist allerdings leer und wenn ich versuche, eine Datei hochzuladen, erscheint die Meldung „Bei dem Upload ist ein Fehler aufgetreten. Bitte versuche es später nochmal.“

    Ich habe mich schon um eine Lösung bemüht und habe die Berechtigungen 755 (Verzeichnisse) und 644 (Dateien) mit Filezilla für die entsprechenden Dateien in WP-Content vergeben.
    Außerdem habe ich die php-Memory heraufgesetzt.

    Bisher leider ohne Erfolg.

    Der one.com Support meldet sich leider nicht zurück.

    Ich danke euch für eure Hilfe!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Geh mal bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis alles geladen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Den kannst du dann bitte hier als neue Antwort unverändert (also mit den Akzentzeichen am Anfang und Ende) einfügen. So erfahren wir ein bisschen mehr über deine Website und können den Fehler besser einschätzen.

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    PS: Auch die Deaktivierung der Plugins war ohne Erfolg!

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: de_DE
    user_language: de_DE
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /customers/2/4/d/td-bw.de/httpd.www
    wordpress_size: 296,09 MB (310467814 bytes)
    uploads_path: /customers/2/4/d/td-bw.de/httpd.www/wp-content/uploads
    uploads_size: 83,96 MB (88043292 bytes)
    themes_path: /customers/2/4/d/td-bw.de/httpd.www/wp-content/themes
    themes_size: 1,98 MB (2081033 bytes)
    plugins_path: /customers/2/4/d/td-bw.de/httpd.www/wp-content/plugins
    plugins_size: 38,36 MB (40227185 bytes)
    database_size: 5,03 MB (5275648 bytes)
    total_size: 425,43 MB (446094972 bytes)
    
    ### wp-active-theme ###
    
    name: GeneratePress (generatepress)
    version: 2.4.2
    author: Tom Usborne
    author_website: https://tomusborne.com
    parent_theme: none
    theme_features: automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, custom-logo, menus, editor-style, widgets
    theme_path: /customers/2/4/d/td-bw.de/httpd.www/wp-content/themes/generatepress
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.1
    
    ### wp-plugins-active (6) ###
    
    Elementor: version: 2.9.8, author: Elementor.com
    Email Encoder - Protect Email Addresses: version: 2.0.7, author: Ironikus
    Gutenberg: version: 8.1.0, author: Gutenberg Team
    Health Check & Troubleshooting: version: 1.4.4, author: The WordPress.org community
    Really Simple SSL: version: 3.3.3, author: Rogier Lankhorst, Mark Wolters
    WP Visitor Statistics: version: 3.2, author: osamaesh
    
    ### wp-plugins-inactive (2) ###
    
    Blog Designer Pack: version: 2.0, author: InfornWeb
    MetaSlider: version: 3.16.4, author: Team Updraft
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 377 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 377 GB
    	imagick::RESOURCETYPE_MEMORY: 189 GB
    	imagick::RESOURCETYPE_THREAD: 48
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: Linux 5.3.0-26-generic x86_64
    httpd_software: Apache
    php_version: 7.4.6 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50
    memory_limit: 1073741824
    max_input_time: 60
    upload_max_size: 256M
    php_post_max_size: 256M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    server-headers: 
    	date: Mon, 18 May 2020 13:58:13 GMT
    	server: Apache
    	x-powered-by: PHP/7.4.6
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	x-ua-compatible: IE=edge
    	x-pingback: https://www.td-bw.de/xmlrpc.php
    	link: <https://www.td-bw.de/wp-json/>; rel="https://api.w.org/", <https://www.td-bw.de/>; rel=shortlink
    	vary: Accept-Encoding
    	content-encoding: gzip
    	content-length: 13141
    	content-type: text/html; charset=UTF-8
    	x-varnish: 644565234
    	age: 0
    	via: 1.1 varnish (Varnish/6.4)
    	accept-ranges: bytes
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.21-MariaDB-1:10.3.21+maria~bionic
    client_version: mysqlnd 7.4.6
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /customers/2/4/d/td-bw.de/httpd.www/wp-content
    WP_PLUGIN_DIR: /customers/2/4/d/td-bw.de/httpd.www/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 1073741824
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Du hast ein recht großes WordPress-Verzeichnis. Kann es sein, dass du da mehrere Installationen ineinander kopiert hast?

    Schau mal bitte unter Einstellungen > Allgemein, ob du (theoretisch!) die Sprache auf z.B. Französisch ändern könntest. (Es geht nur um den Test der Benutzerrechte – hast du die Dateien dem falschen Benutzer zugewiesen, wäre ein Sprachwechsel nicht möglich. Bitte ansonsten hier keine Änderung durchführen!)

    Was ich nicht verstehe: Wenn du die Plugins deaktiviert hast, aktivieren sie sich anschließend nicht wieder von selbst – oder hast du das bereits vorgenommen?

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    Hallo!

    Im File Manager von one.com lag unter anderem noch die gezipte Version der WP-Dateien sowie die Daten der alten Website (in einem separaten Ordner) – dies war keine WordPress-Site, sondern eine mit dem one.com Homepage-Baukasten erstellte Site.

    Zu den Spracheinstellungen: ja, die lassen sich theoretisch ändern (es öffnet sich ein dropdownmenü zur Auswahl).

    Die Plugins hatte ich vorhin bereits wieder selbst aktiviert um die Website wieder „geradezurücken“.

    Ich werde nochmal einen Bericht erstellen und gleich posten ..

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: de_DE
    user_language: de_DE
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /customers/2/4/d/td-bw.de/httpd.www
    wordpress_size: 54,88 MB (57550904 bytes)
    uploads_path: /customers/2/4/d/td-bw.de/httpd.www/wp-content/uploads
    uploads_size: 90,43 MB (94819079 bytes)
    themes_path: /customers/2/4/d/td-bw.de/httpd.www/wp-content/themes
    themes_size: 1,98 MB (2081033 bytes)
    plugins_path: /customers/2/4/d/td-bw.de/httpd.www/wp-content/plugins
    plugins_size: 38,36 MB (40227185 bytes)
    database_size: 6,03 MB (6324224 bytes)
    total_size: 191,69 MB (201002425 bytes)
    
    ### wp-active-theme ###
    
    name: GeneratePress (generatepress)
    version: 2.4.2
    author: Tom Usborne
    author_website: https://tomusborne.com
    parent_theme: none
    theme_features: automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, custom-logo, menus, editor-style, widgets
    theme_path: /customers/2/4/d/td-bw.de/httpd.www/wp-content/themes/generatepress
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.1
    
    ### wp-plugins-active (6) ###
    
    Elementor: version: 2.9.8, author: Elementor.com
    Email Encoder - Protect Email Addresses: version: 2.0.7, author: Ironikus
    Gutenberg: version: 8.1.0, author: Gutenberg Team
    Health Check & Troubleshooting: version: 1.4.4, author: The WordPress.org community
    Really Simple SSL: version: 3.3.3, author: Rogier Lankhorst, Mark Wolters
    WP Visitor Statistics: version: 3.2, author: osamaesh
    
    ### wp-plugins-inactive (2) ###
    
    Blog Designer Pack: version: 2.0, author: InfornWeb
    MetaSlider: version: 3.16.4, author: Team Updraft
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 377 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 377 GB
    	imagick::RESOURCETYPE_MEMORY: 189 GB
    	imagick::RESOURCETYPE_THREAD: 48
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: Linux 5.3.0-26-generic x86_64
    httpd_software: Apache
    php_version: 7.4.6 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50
    memory_limit: 1073741824
    max_input_time: 60
    upload_max_size: 256M
    php_post_max_size: 256M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    server-headers: 
    	date: Mon, 18 May 2020 19:00:53 GMT
    	server: Apache
    	x-powered-by: PHP/7.4.6
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	x-ua-compatible: IE=edge
    	x-pingback: https://www.td-bw.de/xmlrpc.php
    	link: <https://www.td-bw.de/wp-json/>; rel="https://api.w.org/", <https://www.td-bw.de/>; rel=shortlink
    	vary: Accept-Encoding
    	content-encoding: gzip
    	content-length: 13195
    	content-type: text/html; charset=UTF-8
    	x-varnish: 936352952
    	age: 0
    	via: 1.1 varnish (Varnish/6.4)
    	accept-ranges: bytes
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.21-MariaDB-1:10.3.21+maria~bionic
    client_version: mysqlnd 7.4.6
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /customers/2/4/d/td-bw.de/httpd.www/wp-content
    WP_PLUGIN_DIR: /customers/2/4/d/td-bw.de/httpd.www/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 1073741824
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    Mir ist noch etwas aufgefallen ..

    ich habe jetzt noch einmal versucht, Dateien hochzuladen und es erscheint wieder der besagt Fehler. Die Dateien liegen nun aber überraschenderweise im /wp-content/uploads. (Die übrigen dateien liegen in weiteren Unterordnern, wie zum Beispiel /wp-content/uploads/elementor)
    Es werden aber nach wie vor keine Bilder in der Mediathek angezeigt..

    Gruß

    Hallo,
    nur eine Idee: schau doch mal unter Einstellungen > Mediathek und entferne da das Häkchen bei „Meine Uploads in monats- und jahresbasierten Ordnern organisieren“.
    Übernehme danach die Änderung und überprüfe nochmal die Mediathek.
    Sollte das dann funktionieren, setzt du wieder das Häkchen bei der o. g. Option.
    Möglicherweise hilft dir auch das folgende Plugin. Interessant ist in dem Zusammenhang der folgende Beitrag im englischprachigen Forum.
    Nachfolgend noch ein paar Ideen:
    Es gibt mehrere Dinge, die du versuchen kannst, um das Problem zu lösen (manche davon hast du ja bereits getestet):

    • überprüfe sicherheitshalber, ob sich die Dateien im Ordner uploads befinden (hast du aber schon gemacht, wenn ich das richtig sehe)
    • überprüfe die Fehlerprotokolle auf dem Server.
    • nenne die .htaccess um und prüfe dann, ob das Problem behoben ist (die Datei bitte vorher sichern).
    • starte z. B. Chrome im Inkognito Modus und prüfe dann, ob das Problem behoben ist.
    • versuche, die Bildgröße (hier geht es um die Anzahl der Pixel, nicht die Dateigröße) zu verringern,
    • überprüfe, ob die wp-config.php einen benutzerdefinierten Upload-Pfad enthält( wie define('UPLOADS', '/some/custom/path'); )

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    Guten Morgen,

    die Dateien befinden sich im Ordner Uploads bzw. in den Unterordnern 2020 oder Elementor. Nehme ich das besagte Häkchen raus, landen die Bilder beim Hochladen direkt im Ordner „Uploads“.

    Die .htaccess habe ich aus dem one.com File Manager entfernt (und gesichert) – dies hat auch nichts gebracht.

    In der wp-config gibt es leider keinen benutzerdefinierten Upload-Pfad.

    Den Inkognito-Modus sowie die Verringerung der Bildgröße bringen keinen Erfolg. Die Dateien landen immernoch im „Uploads“ aber leider nicht in der Mediathek.

    Wie kann ich die Fehlerprotokolle auf dem Server überprüfen? Indem ich den WP_DEBUG_LOG auf true setze und dann die Seite aufrufe?

    Guten Morgen,
    in die error log kannst du über den Kundenaccount bei deinem Hoster reinschauen, siehe z. B. hier.
    Eine weitere Möglichkeit wäre, in den Error-Logs des Webservers nach Fehler suchen.
    Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Um das zu ermöglichen, müssen folgenden Zeilen in die wp-config.php geschrieben werden:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du das bisherige define(‚WP_DEBUG‘, false);überschreibst, denn wenn versucht wird, diese Konstante ein zweites mal zu definieren, dann wirft PHP auch einen Fehler, was deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen sagen wir WordPress, dass der Debug-Modus aktiviert werden soll. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden.
    Denke aber bitte daran, vorher die Datei wp-config.php zu sichern. Wenn der Fehler gefunden wurde bzw. wenn die Fehler nicht mehr in die debug.log geschrieben werden sollen, dann musst du daran denken, die Variable
    define( 'WP_DEBUG_LOG', true );
    wieder auf false zu setzen:
    define( 'WP_DEBUG_LOG', false);

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    Hallo Hans-Gerd,

    so habe ich es gemacht und ein Logfile wurde erzeugt.

    Im Logfile befinden sich jeweils 40 mal folgende Zeilen:

    [19-May-2020 06:17:03 UTC] PHP Notice: Trying to get property ‚ID‘ of non-object in /customers/2/4/d/td-bw.de/httpd.www/wp-includes/post.php on line 6581
    [19-May-2020 06:17:03 UTC] PHP Notice: Trying to get property ‚ID‘ of non-object in /customers/2/4/d/td-bw.de/httpd.www/wp-includes/post.php on line 6665

    Frage: Wann wird dieses Logfile aktualisiert? Bzw. wie kann man eine Aktualisierung anstoßen?

    Hallo,
    „Notice“ bedeutet ja an sich nur Notiz. Ich gehe nicht davon aus, dass dies für das Problem relevant ist.
    Wenn du dann bereits alle Plugins im Problembehandlungsmodus bei aktiviertem Standardtheme deaktiviert hattest, fällt mir dazu momentan mal nichts ein.
    Du könntest höchstens noch versuchen, ob über Dashboard > Aktualisierungen und Klick auf den Button „Erneut installieren“ das Update durch eine manuelle Installation etwas bewirkt. Glaube ich aber eher nicht.

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    Okay. Das versuche ich.

    Könnte es sein, dass mit der Datenbank etwas nicht stimmt?
    Ich hatte beim Import in phpMyAdmin Probleme – es gab Fehlermeldungen bezüglich Berechtignungen usw. Ich musste die entsprechenden Änderungen über SQL ausführen da ich die Tabelle nicht direkt bearbeiten konnte (wie in den How-Tos beschrieben).

    Gibts dafür Diagnosemöglichkeiten bzw. Stellen, wo man nachsehen kann ob alles stimmt?

    Zu Beginn hat (ich bin mir zumindest ziemlich sicher) nach dem Transfer zu one.com noch alles funktioniert. Ich habe dann auf HTTPS umgestellt und später irgendwann dann gemerkt, dass das Problem vorliegt. Könnte es vielleicht auch damit zusammenhängen?

    Danke und Gruß,
    Alex

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    Und noch ein Hinweis: Veröffentlichungen der Website funktionieren ebenfalls nicht. Es erscheint die Meldung: „Etwas scheint schiefgelaufen zu sein. Warte einige Sekunden und versuche es dann erneut.“

    Thread-Ersteller tdbwadmin

    (@tdbwadmin)

    Der letzte Ausweg wäre, die Webiste nochmal vom localhost auf den Server zu transferieren ..

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Das Thema „Mediathek funktioniert nicht“ ist für neue Antworten geschlossen.