Support » Allgemeine Fragen » Medien nicht mehr sichtbar

  • Bluelle

    (@bluelle)


    Hallo,
    ich verzweifel langsam, kaum ist das eine Problem gelöst, kommt das nächste.

    Nach einem Update sowohl WordPress, wie auch Theme Avada + MySQL zeigen sich im Frontend keine Bilder mehr. Ich habe die gesamte Entwicklung auf eine neue Datenbank gelegt, da der Provider kein SQL Update macht, sondern man eine neue DB einrichten muss.

    Die Berechtigungen sind alle auf 755 eingestellt.

    Kann mir jemand helfen?

    Vielen Dank

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Moderator Bego Mario Garde

    (@pixolin)

    Sorry, aber das ist kaum nachvollziehbar.

    Welche Probleme hast du gelöst?
    Spielt das für das aktuelle Problem eine Rolle?

    Welche WordPress-Versiob verwendest du?
    Wie hast du das Update durchgeführt?

    Welche Version von Avada verwendest du?
    Wie hast du das Update durchgeführt?

    Wieso hast du ein Update von MySQL durchgeführt?
    Mit welchem Ziel?

    Wie hast du den Übertrag der Datenbank vorgenommen?
    Hat sich sonst etwas an der Website geändert? (Domain?)
    Hast du in der wp-config.php die neuen Datenbankdaten eingegeben?

    Können wir uns das irgendwo ansehen (URL)?

    Wieso hast du „die Berechtigung alle auf 755 eingestellt“?

    Thread-Ersteller Bluelle

    (@bluelle)

    Welche Probleme hast du gelöst?
    Meine DB hatte MySQL 5.5. für Woocommerce und German Market brauchte ich 5.6. Der Provider updated keine Datenbank (:() , sondern man muss eine neue anlegen (die war dann schon auf 5.7. eingestellt)
    Spielt das für das aktuelle Problem eine Rolle?
    Ich denke schon.
    Welche WordPress-Versiob verwendest du? 4.9.
    Wie hast du das Update durchgeführt?
    Das lief danach automatisch, sowie auch für das Theme.

    Welche Version von Avada verwendest du? 5.3.
    Wie hast du das Update durchgeführt? Automatisches Update.

    Wieso hast du ein Update von MySQL durchgeführt? Oben aufgeführt, ich war das nicht selbst, sondern man muss eine neue DB anlegen, durch eine WordPressneuinstallation entsteht die DB.
    Mit welchem Ziel? Damit ich ein höheres MySQL hatte.
    War sozusagen ein Umzug von DB3 zu DB4

    Wie hast du den Übertrag der Datenbank vorgenommen? über FTP – FileZilla
    Hat sich sonst etwas an der Website geändert? (Domain?) Nein
    Hast du in der wp-config.php die neuen Datenbankdaten eingegeben? Ja

    Können wir uns das irgendwo ansehen (URL)? Man sieht nichts, da das ganze Theme neu eingestellt werden muss, wie ich gerade fest stellte (Themeoptions sind nicht mit rüberkopiert worden) Seiteninhalte sind alle vorhanden, nur Schriften, Farben usw. muss ich neu einstellen. Ich würde Dir einen Link oder Zugang schicken, aber nicht öffentlich.

    Wieso hast du „die Berechtigung alle auf 755 eingestellt“?
    Ich habe das nicht eingestellt, sondern eben nachgeschaut mit rechter Maustaste, dort stand überall „Owner“ auf 755 mit lesen, schreiben und ausführen.

    Bis dahin erst einmal…dies ist mein 6. Webauftritt, den ich erstelle, noch nie solche Probleme gehabt. Provider ist in Ö (world4you).
    Danke Dir.

    Apermo

    (@apermo)

    Wie hast du den Übertrag der Datenbank vorgenommen? über FTP – FileZilla

    Das kommt nicht hin.
    Du musst die Daten von der alten DB in die neue übertragen haben. Das meinte Bego.
    Es geht also nicht darum wie du die Daten in der wp-config geändert hast, sondern wie du den Datenbank Inhalt übertragen hast.

    Dafür gibt es mehrere Möglichkeiten.

    Die üblichste ist einen Datenbank Dump in phpMyAdmin erstellen und ihn auf der neuen DB in phpMyAdmin wieder einlesen.
    Und hier kann verdammt viel schief gehen.

    2 Sachen fallen mir ein die du spontan versuchen kannst:

    1. nochmal neu die Daten aus der alten DB exportieren und in die Neue importieren
    oder
    2. nochmal die alte DB in deiner wp-config hinterlegen und gucken ob jetzt zumindest der Rest wieder funktioniert.

    Moderator Bego Mario Garde

    (@pixolin)

    Damit ist schon einiges besser verständlich – vielen Dank dafür.
    Was ich allerdings nicht verstehe ist, wieso du die Datenbank per FTP übertragen hast. Normalerweise würde ich annehmen, dass du per phpMyAdmin einen Export/Import vornimmst?

    Die Theme-Einstellungen sind in der Datenbank mit dem Theme verknüpft. Einfach ausgdedrückt: Wenn ich unter Twenty Seventeen eine Einstellung für das Hintergrundbild vornehme und anschließend zum Theme Twenty Sixteen wechsle, ist die Einstellung „weg“, sobald ich aber wieder zu Twenty Seventeen wechsle auch wieder „da“. Wenn du also wirklich das vorher verwendete Theme wieder aktiviert hast und trotzdem die Einstellungen weg sind, stimmt wahrscheinlich mit der Datenbank etwas nicht.

    Die Berechtigungen für Verzeichnisse sollen 755 sein,
    für Dateien hingegen 644. Prüf das bitte nochmal.

    Wieso wir keine Zugangs-Links haben wollen, haben wir hier beschrieben:
    https://de.wordpress.org/support/topic/kannst-du-mich-nicht-anrufen-oder-mal-schnell-bei-mir-einloggen/

    Thread-Ersteller Bluelle

    (@bluelle)

    Ok, vielen Dank erst mal. Ich habe das als erstes natürlich gemacht, also per export und import direkt im PhpMyAdmin.
    Da war nichts mehr da bzw. wurde rein gar nicht übertragen, also völlig leerer WordPress Blog und er hat eine Fehlermeldung nach der anderen erzeugt (habe natürlich beim dortigen Support angefragt aber sehr stupide Antwort bekommen, die nichts geholfen haben).
    Fehlermeldung z.b. Crypto File already excist.

    Danach habe ich das mit FileZilla gemacht, also übertragen und die wp-config dementsprechend geändert.
    Die alte DB existiert ja noch, es ist also nichts verloren, nur eben brauche ich eine höhere MySQL Version und dazu eine neue DB, seufz.
    Ich denke ich komme nicht umhin, die gesamte neue DB zu löschen und nochmals neu aufzusetzen.
    Auf jeden Fall erst mal vielen Dank für die schnelle Hilfe.

    Birgit

    Thread-Ersteller Bluelle

    (@bluelle)

    Kurze Rückmeldung:
    Endlich hatte ich den Support vom Provider am Telefon.
    Es lag wohl an der Datenbank, ein 0 Eintrag bei Options, soweit ich das verstanden habe.
    Der Techniker meinte es läge nicht an WordPress sondern am Fusion Builder, werde mich also an Avada wenden.
    Nochmals danke.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „Medien nicht mehr sichtbar“ ist für neue Antworten geschlossen.