Support » Installation » Medienimport klappt nicht

  • Hallo liebes Forum!

    Ich versuche derzeit von wordpress.com zu einer eigenen Installation von wordpress zu wechseln. Leider habe ich massive Probleme mit den Medien. Ein Import der Bilder gleich mit der XML-Datei klappt nicht. Die Bilder die dann von wp.com auf meine neue WordPress-Installation rübergeschaufelt werden sind alle komplett verzerrt. Nach zehnmaligem Resetten und neu Beginnen habe ich nun den Content ohne Medien importiert, und die Medien extra in die Mediathek hochgeladen, damit ich die extern von wp.com eingebundenen Bilder einzeln ersetzen kann.

    ABER: auch diese Vorgangsweise klappt nicht immer. Einige Fotos sind weiterhin zu klein, sowohl in den Beiträgen als auch in der Vorschau. Das schaut besonders bei den Vorschaubildern extrem komisch aus. Obwohl die Fotos auch alle groß genug sind, werden manche auf Textbreite angezeigt, und manche eben nicht. Aber es ist vollkommen unklar woran das liegt. Jedenfalls nicht an den Bildformaten, das habe ich mehrfach kontrolliert.

    Die Installation ist die Version 5.7.1, und ich habe eigentlich quasi noch keine Plugins installiert. Auch mein Serveradmin hat sich schon ein paar Stunden gespielt, z.B. mit „Regenerate Thumbnails“ und keine Ideen mehr. Das Theme ist 1:1 das Selbe, …

    Es ist deshalb so komisch, weil eben manche Bilder richtig breit angezeigt werden, und andere nicht, obwohl sie groß genug wären. Auch sind die „zu kleinen Bilder“ dann immer gleich groß und halt nur ca. 10% schmäler als der Text, also quasi „eingerückt“. Wohingegen viele Bilder auch korrekt sind. Mehrfaches Sichern der Bilder in/aus der eigenen Mediathek hilft nichts. Es ist mir total schleierhaft warum die Bilder unterschiedlich groß dargestellt werden. Die Einstellungen sind in meinem neuen wordpress und auf wp.com, genau gleich. Auch den Haken bei „Das Vorschaubild auf die exakte Größe beschneiden“ hat überhaupt keine Auswirkungen, … ?

    Irgendwelche Idee irgendwer? Ich habe nichts dazu gefunden, und bin nach 4 Tagen am verzweifeln, …

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Eine URL zu deiner Website wäre schön.

    Warum ein Link zu deiner Website wichtig ist

    Thread-Ersteller newwpnooby

    (@newwpnooby)

    Nein, möchte ich aus Datenschutzgründen nicht hergeben.

    Wir wissen so gut wie nichts über deine Website, welches Theme du verwendest, wie die Bilder eingebunden sind. Ich respektiere den Wunsch, die URL hier (auch nicht mit einem Tool wie bitly.com gekürzt) zu teilen, kann dir dann aber auch nicht weiterhelfen. Vielleicht suchst du dir einen Dienstleister, der sich das anschaut?

    Thread-Ersteller newwpnooby

    (@newwpnooby)

    Das Theme ist „DePo Masthead“ genauso wie auf wp.com. Die Bilder sind einfach mit den Standardfunktionen eingebunden. Die Installation ist komplett neu, hat wie gesagt fast keine Plugins und ist sehr einfach gehalten. Die Tatsache, daß auf wp.com alles klappt, und mit einer leeren WordPress-Installation manche Bilder die richtige Größe haben, und andere 10% verkleinert werden, ohne daß ich das ändern kann, braucht keine öffentliche Kontrolle, die mich eindeutig identifizieren würde 😉

    Moderator Bego Mario Garde

    (@pixolin)

    Die Tatsache, daß auf wp.com alles klappt, und mit einer leeren WordPress-Installation manche Bilder die richtige Größe haben, und andere 10% verkleinert werden, …

    … ist sicher auch nicht der Normalfall. Nach welchen Kriterien soll ich das jetzt prüfen, wenn ich keinen Zugriff auf die Webseiten habe?

    Ich drücke die Daumen, dass du noch eine Lösung findest, kann dir aber nicht helfen.

    Thread-Ersteller newwpnooby

    (@newwpnooby)

    Also, ein erster skurriler Workaround klappt so: Die Bilder die ich als kompletten Ordner in die Mediathek geladen habe, entsprechen anscheinend nicht den in der Mediathek angezeigten Bildgrößen. Wenn ich jetzt unter „Einstellungen“ -> „Medien“ -> „Groß“ die Bildgröße auf größer als das größte Foto stelle (z.B. 2048) und dann die Fotos einzeln in die Mediathek neu hochlade, dann klappt wieder alles, und die Fotos werden so breit wie der Text angezeigt. Eigentlich sollte diese Angabe aber nichts mit den Originalen zu tun haben, die ja auch gespeichert werden, …

    Das ist natürlich sehr unbefriedigend, weil ich nicht in ein paar hundert Artikel doppelt so viele Fotos händisch neu laden und neu in den Artikeln positionieren möchte.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)