Support » Allgemeine Fragen » Meine Domain zeigt einen ungewollten Zusatz an.

  • Guten Tag liebe Forumteilnehmer,

    ich habe ein Problem und weiß nicht, wie ich es lösen kann.
    Ich habe eine Internetseite mit WP und Elementor Pro erstellt. Wenn ich nun die obige Doamin im Browser eingebe, duert es nur kurz, dann wird hinter der Domain
    https://weidenkopf-immobilien.de/#/home für einen Bruchteil einer Sekunde angezeigt und direkt im Anschluss https://weidenkopf-immobilien.de/#/list1
    Ich kann mir das nicht erkläeren. Ich möchte dieses /#/list1 nicht hinter der Domain haben. Wo kann das herstammen? Ich habe auf der Startseite ein html-Code eingepflegt, der von immmowelt Objekte nachlädt. Daran kann es aber nicht liegen, denn, wenn ich beispielsweise das Impressum als Startseite einstelle, tritt gleicher Effekt auf.
    Ich würde mich riesig freuen, wenn jemand von euch Abhilfe kennt. Vielen Dank. Grüße!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Hallo Thomas,

    doch, das wird durch den immowelt-iframe erzeugt. Das dient dazu, dass in dem Skript die richtige Seite angezeigt wird, also beispielsweise die 1. Seite der Übersicht oder ein Objekt in der Einzelansicht.

    Die Nutzung ist so allerdings nicht datenschutzkonform, d. h. du müsstest den Frame mit zum Beispiel Borlabs Cookie einbinden, was du ja sowieso bereits nutzt und dann es so lange blockiert, bis eine Einwilligung vorliegt. Dann würden auch beim ersten Aufrufen der Seite die entsprechenden Zusätze in der URL nicht erscheinen.

    Das ist unabhängig davon, ob die Seite als Startseite in WordPress definiert ist oder nicht, sondern hängt davon ab, auf welcher Seite das Skript eingebunden ist.

    Viele Grüße
    Jan

    Thread-Starter DerBrauser

    (@thomassasse)

    Hallo Jan,

    oh, vielen Dank, Jan für den tollen Support. Ich hätte schören können, dass die Erweiterung auch beim Impressum als Startseite erschien.
    Ich habe jetzt den Code einmal entfernt und die Seite neu gestartet. Dieses hat dir recht gegeben.
    Ohne diese immowelt-Einbindung verschwindet auch die Endung.

    Jetzt habe ich den Code unter Borlabs Cookie als Cookie aktiviert.
    Wenn ich alle Cookies annehme erscheint aber doch wieder diese Erweiterung /#/list1.
    Wenn ich nicht alle Cookies akzeptiere, lädt er die Immobilien-Liste nicht, es erscheint aber auch kein Text, wie bei Google-Maps, damit der spätentschlossene Interessent die Objektliste dann doch nachladen kann.

    Ich mache hier offenbar noch einen Fehler. Kannst du mir helfen oder soll ich hier lieber einmal Borlabs dazu befragen?

    Vielen Dank und viele Grüße, Thomas

    https://weidenkopf-immobilien.de/

    Der html-Code von immowelt lautet:

    <div id=’iwModule‘>
    <script language=’javascript‘ type=’text/javascript‘> var guid = ‚c8e66b862de14462a0cf1d3abbb0ac8a‘;
    </script>
    <script language=’javascript‘ type=’text/javascript‘ src=’https://homepagemodul.immowelt.de/_scripts/iwag/homepagemodul/homepagemodul.pack.js&#8216; ></script> <div id=’iwWidget‘ class=’iwWidget‘></div> <noscript>Bitte aktivieren Sie Javascript.</noscript> <div id=’iwdigetinfo‘>powered by immowelt GmbH</div> </div>

    Hallo Thomas,

    sehr gut, dann ist ja zumindest schonmal die Ursache identifiziert.

    Vielleicht ist das in meiner Nachricht nicht ganz klar geworden:
    Die Zusätze in der URL sind immer da, wenn das immowelt-iframe geladen wird. Das heißt, dass die Einbindung mit Borlabs lediglich zur Folge hat, dass es nicht direkt in der URL steht sondern erst nach Einwilligung.

    Da i. d. R. für Crawler in Borlabs alle Cookies akzeptiert werden (kannst du einstellen) wird es für Suchmaschinen etc auch in der URL stehen.

    Die einzige Lösung die es da gibt um den Zusatz trotz Immobilienobjekte zu entfernen wäre den immowelt iframe nicht zu nutzen. Es gibt Drittanbieterplugins, die im Hintergrund synchronisieren und dann die Objekte als Custom Post Type in WordPress anlegen. Da wäre das dann nicht mehr der Fall. Oder du kannst natürlich auch selbst etwas entwickeln (lassen), dass es dann im Hintergrund abruft.

    Viele Grüße
    Jan

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Meine Domain zeigt einen ungewollten Zusatz an.“ ist für neue Antworten geschlossen.