Support » Allgemeine Fragen » Meine Seite ist weg

  • Hallo. Ich gebe die normale Adresse ein, um auf meine Homepage zu kommen und scheinbar macht der Browser auch etwas, aber es erscheint …NICHTS. Es bleibt weiss. Kennt das jemand oder kann mir weiter helfen? Ich habe auf verschiednen Geräten und Browserfenstern probiert. Vielen Dank schon Mal – liebe Grüsse , Ria

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)
  • Ändere mal in der wp-config.php die Zeile

    define('WP_DEBUG', false);

    in

    define('WP_DEBUG', true);

    und sieh‘ mal in die Logfiles von PHP, ob dort eventuell was zu finden ist.

    • Diese Antwort wurde geändert vor 6 Tagen, 18 Stunden von  Torsten Landsiedel. Grund: Code immer als Code auszeichnen!

    Vielen Dank für deine Nachricht.
    Ich verstehe sie einfach nicht. Ich weiss nicht, wo ich diese Angaben finde. Gibt es da irgendwo eine Schritt für Schritt Anleitung? Kannst du mir da weiter helfen? Da bin ich absoluter Laie;-(

    Die wp-config.php ist eine Datei, die im Hauptverzeichnis deiner WordPress-Installation liegt. Diese musst du ändern.

    Die Logfiles müsstest du auf dem Webserver, auf dem deine Domain liegt, ansehen können. Da wir deinen Webspace nict kennen, und nicht wissen, wo die Logfiles zu finden sind, kann dir dabei eventuell dein Webhoster behilflich sein.

    das müsste in dem Fall Cyon sein. Ich werde das mal abklären.

    Wie kann es denn passieren, dass eine Homepage einfach nicht mehr erscheint? Wenn man praktisch nichts an den Einstellungen ändert?

    Moderator Bego Mario Garde

    (@pixolin)

    Um das etwas mehr zu erläutern:

    Wenn der Webserver PHP-Skripte (z.B. in Plugins, Theme-Templates oder WordPress selbst) ausführt und dabei ein erheblicher („fataler“) Fehler auftritt, kann das System eine Fehlermeldung ausgeben, um den Fehler zu analysieren und beseitigen. Problematisch ist, dass Angreifer durch die Fehlermeldungen auf mögliche Schwachstellen des Systems hingewiesen werden. Als Standard-Einstellung gibt dein Server dann lieber gar nichts aus, als munter Sicherheitslücken auszuplaudern.

    Da du nur mit einer weißen Seite selber auch nicht weiterkommst, macht es Sinn, die Fehlermeldungen (möglichst nur für eine kurze Zeit) trotzdem einzublenden. Dazu gibt es die Möglichkeit in der WordPress-Konfigurationsdatei wp-config.php eine Konstante vorzugeben, die WordPress mitteilt, dass Fehlermeldungen erwünscht sind:

    define( 'WP_DEBUG', true );

    Die Zeile sollte in deiner Konfigurationsdatei bereits vorhanden sein, allerdings mit dem Wert false, den du auf true ändern solltest.

    Um die Änderung vorzunehmen, musst du die Datei erst mit einem FTP-Programm wie z.B. Filezilla herunterladen, dann in einem geeigneten Editor (z.B. Notepad++ oder Atom Editor; verwende bitte nicht den Windows-Editor Notepad, weil der die Datei in einer falschen Zeichencodierung speichert und damit für weitere Fehler sorgt.) bearbeiten und anschließend wieder hochladen. Zur Nutzung des FTP-Programms stellt dir dein Webhoster eine eigene Anleitung zur Verfügung: https://www.cyon.ch/support/a/website-mit-dem-ftp-programm-filezilla-veroffentlichen

    Die Wahrscheinlichkeit, dass das Problem in WordPress selbst auftritt, ist bei einer aktuellen Version (sprich: wenn du regelmäßig Aktualisierungen durchgeführt hast) eher gering. Die Software ist sehr weit verbreitet, gravierende Fehler werden sehr schnell gemeldet und genauso schnell behoben. Es ist wesentlich wahrscheinlicher, dass eines deiner verwendeten Plugins den Fehler verursacht. Plugins werden teilweise nur von einzelnen Entwicklern geschrieben und bei Updates nicht zusätzlich geprüft.

    Um die Plugins deiner WordPress-Installation ohne Zugriff aufs Backend zu deaktivieren, kannst du vorübergehend das Verzeichnis wp-content/plugins auf deinem Server in z.B. wp-content/no-plugins umbenennen. Vielleicht ist die Website dann schon wieder erreichbar? Dann reicht es, wenn du das Verzeichnis wieder in wp-content/plugins umbenennst und die Plugins im Backend einzeln wieder aktivierst. Falls das nicht reicht, wären die Fehlermeldungen zur weiteren Analyse interessant.

    Sobald die Fehler ausgelesen sind, kannst du die Konstante in der wp-config.php dann wieder auf define( 'WP_DEBUG', false ); setzen.

    Ist es jetzt ein bisschen verständlicher geworden?

    Wir haben jetzt diese Vorschläge ausprobiert, die Webseite ist nach wie vor nicht erreichbar gewesen. Das letzt Plugin, welches ich installiert habe, wurde nun gelöscht. Die Frage ist, wo wir die Fehlermeldungen finden, wenn die Seite nicht aufgeht?

    Moderator Bego Mario Garde

    (@pixolin)

    Im Moment wird keine leere Seite angezeigt, sondern ein „Internal Server Error“. Detailliertere Fehlermeldungen dazu stehen im Error-Log des Servers.

    wenn wir das so einrichten zeigt es nur Errors aus dem 2017 an, nichts aktuelles

    Moderator Bego Mario Garde

    (@pixolin)

    Beschreibungen mit „das“ und „es“ sind meistens etwas schwierig nachzuvollziehen.

    Wenn es einen „Internal Server Error“ gibt, sollte es auch aktuelle Fehlermeldungen geben. Im Zweifelsfall würde ich nochmal beim Support des Webhoster nachfragen.

    Vielleicht zum besseren Verständnis: Ich kein Mitarbeiter einer Support-Firma WordPress, sondern Anwender wie du auch, nur „sehe“ ich keine Einstellungen, habe keine Zugriff auf Dateien und kann mich nur auf möglichst präzise Angaben verlassen. Wenn weder die Aktivierung des Debug-Modus in der Konfigurationsdatei wp-config.php noch die Auswertung der Error-Logs irgendwelche Anhaltspunkte liefern, ist es schwierig, aus der Ferne irgendeine Unterstützung zu liefern. Ein Dienstleister mit Zugriff auf die Zugangsdaten hätte da wahrscheinlich bessere Möglichkeiten.

    Die „klassische“ Vorgehensweise zur Behebung von solchen Fehlern (500 – Internal Server Error) ist

    1. Servereinstellungen prüfen: Wurde eine aktuelle PHP-Version (7.2) aktiviert? Lassen sich Einstellungen wie z.B. memory_limit vornehmen und wie sind sie eingestellt? Eventuell auch den Support des Webhoster ansprechen, ob serverseitig Änderungen vorgenommen wurden, z.B. zwangsweise Umstellung auf eine neuere PHP-Version.
    2. Datei .htaccess umbenennen, um eine Fehlkonfiguration durch diese Datei auszuschließen.
    3. Per FTP Plugin-Verzeichnis umbenennen (was ihr ja wohl schon gemacht habt?)
    4. Per FTP Theme-Verzeichnis des zuletzt aktivierten Themes umbenennen. Dadurch fällt WordPress auf ein Standard-Theme („Twenty …“) zurück, das allerdings installiert sein muss.
    5. WordPress manuell aktualisieren – dabei werden die Dateien in den Verzeichnissen wp-admin und wp-includes durch einen frisch von WordPress.org heruntergeladenen Datensatz ausgetauscht.
    6. Zugangsdaten zur Datenbank prüfen und nachsehen, ob die Datenbank weiterhin Datenbank-Tabellen mit dem in der wp-config.ph angegebenen Präfix enthält.

    Ich habe mich einfach auf den letzten Post bezogen. Ja, ich glaube dass es gut wäre, wenn sich jemand das genau anschauen kann, auf Ferndiagnose ist das nicht so einfach.
    Wir werden mal Kontakt mit dem Host aufnehmen. Vielen Dank schon mal für all dein Bemühen.
    Ich melde mich, wenn ich mehr weiss.

    Jetzt melde ich mich doch noch mal, die Seite ist nun wieder da und alle Plugins sind deaktiviert. Ich nehme an, weil wir die Zeile in no Plugins geändert haben?
    Wie kann ich jetzt weiter vorgehen?

    das steht hinter jedem Plugin:….wurde in Folge eines Fehlers deaktiviert: Die Plugindatei existiert nicht.

    Moderator Bego Mario Garde

    (@pixolin)

    Wie bereits beschrieben:

    Dann reicht es, wenn du das Verzeichnis wieder in wp-content/plugins umbenennst und die Plugins im Backend einzeln wieder aktivierst.

    Sobald deine Website wieder „weg ist“, weißt du, welches Plugin das Problem verursacht. Es reicht dann, wenn du das Verzeichnis dieses Plugins umbenennst. Danach musst du schauen, ob es für das Problem dieses Plugins bereits eine Lösung gibt.

    Regelmäßige Updates von WordPress, Theme und Plugins sind natürlich sowieso immer sinnvoll.

    Jetzt sind alle Plugins wieder da und aktiviert, es gibt ein paar Sachen, die jetzt plötzlich da sind und eigentlich nicht hingehören.
    Ich hänge nun noch an den automatischen updates, soll ich diese Zeile einfach entfernen, also die untere? War das gemeint?

    Turn off automatic updates since these are managed upstream.
    */
    define(‚AUTOMATIC_UPDATER_DISABLED‘, true);

    Moderator Bego Mario Garde

    (@pixolin)

    Gerade eben ist die neue WordPress-Version erschienen. Vielleicht wartest du noch ein paar Tage mit dem Update, wenn du vorher auf 4.9.8 aktualisiert hattest. Ansonsten ist es sinnvoll, möglichst früh Aktualisierungen vorzunehmen, weil sonst Sicherheitslücken nicht geschlossen und bekanntgewordene Problem nicht behoben werden können. Ich würde die Zeile rausnehmen.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)