Support » Installation » Meldung aus dem header: //Add the blog ….

  • Gelöst hgv40

    (@hgv40)


    Hallo,

    ich bin neu in dieser Runde und habe nur bislang wenig Erfahrung. Ich habe mit Twenty Ten eine einfache Hompage erzeugt. 5 Seiten, eine statische Startseite ist definiert, einige Änderungen sind ins child gelegt. Der Aufruf der Seite funktioniert (hans-gerrit.de), liefert aber zu Beginn den folgenden Text, der wohl aus dem header stammt. Leider habe ich zu wenig Kenntnisse, um hier weiter zu kommen. Der Fehler ist wohl erst aufgetreten, nachdem unterschiedliche SEOs aktiviert und wieder deaktiviert wurden. Hat jemand eine Lösung?

    Vielen Dank

    Hans-Gerrit

    // Add the blog description for the home/front page. $site_description = get_bloginfo( 'description', 'display' ); if ( $site_description && ( is_home() || is_front_page() ) ) echo " | $site_description";
    // Add a page number if necessary: if ( ( $paged >= 2 || $page >= 2 ) && ! is_404() ) echo esc_html( ' | ' . sprintf( __( 'Page %s', 'twentyten' ), max( $paged, $page ) ) ); ?>

    Der Text ergibt sich aus dem header:

    */
    ?><!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <title><?php
    	/*
    	 * Print the <title> tag based on what is being viewed.
    	 */
    	global $page, $paged;
    	wp_title( '|', true, 'right' );
    	// Add the blog name.
    	bloginfo( 'name' );

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Edi

    (@psychosopher)

    Ja, da scheint es sich um ein Relikt eines Codes eines SEO-Plugins zu handeln (der Anfang der PHP-Anweisung „<?php“ fehlt, deshalb wird der Code angezeigt). Vielleicht lässt sich das aus der Datei header.php löschen.

    Relikt eines Codes eines SEO-Plugins zu handeln

    Plugins hinterlassen eigentlich keine Relikte beim Deaktivieren, bis auf in der Datenbank. Deaktiviere mal dein Squirrly SEO Plugin und versuch es mal mit Yoast SEO.

    Kann sein, dass es am Plugin liegt. Falls der Fehler immer noch Auftritt, auch wenn alle Plugins deaktiviert sind, dann hast du vielleicht in deinem Child Theme einen Fehler gemacht. Solange du nicht an deinem Theme selbst was geändert hast, sollte es immer noch im Grundzustand sein.

    Thread-Ersteller hgv40

    (@hgv40)

    Hallo Edi, Pascal,

    das Problem ist gelöst:
    1. Squirrly deaktiviert, Yoast SEO aktiviert: es wird noch ärger: zusätzlich werden die Seitentexte doppelt im Hintergrund angezeigt.
    2. Plugin Post Snippet gelöscht: wieder der bekannte Fehler ohne doppelten Text
    3. Neuer header installiert: alles ok

    Vielen Dank

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Meldung aus dem header: //Add the blog ….“ ist für neue Antworten geschlossen.