Support » WooCommerce » Menü im Shop (für die Seite) bringt 404

  • Gelöst jogika

    (@jogika)


    Hallo zusammen,

    ich habe mir heute für meine Testseite mal Woocommerce installiert und nun einen eigenartigen Fehler…
    Als Theme nutze ich Onepress also aktuell als OnePager.
    Nachdem ich Woocommerce eingerichtet habe, kann ich es über das Menü aufrufen und „bedienen“.
    Will ich nun aber über das Menü meine Seite aufrufen, komme ich zu einer 404 Fehlerseite, obwohl der aufgerufene Link der gleiche ist (mit dem gleichen Link im Status) als wenn ich auf meiner Seite bin?!

    Es gibt im Shop noch keine weitere Navigation zu Warenkorb und Co das ist mir bewusst, nur bevor ich dort weiter experimentiere wüsste ich gerne warum die Menuaufrufe von der Shopseite nicht funktionieren…

    Was habe ich vergessen?

    Danke und Gruß
    JogiKa

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Der Link ist zwar nett, aber im Wartungsmodus kann sich das keiner ansehen 😉

    Moin Jostu,
    Danke für den Hinweis, ich dachte den hätte ich bereits wieder deaktiviert…
    Ist somit jetzt geändert 😉

    Vielleicht noch als Nachtrag, die „Shopseite“ ist im Menu als „Seite“ angegeben, nicht als „individueller Link“ wie die sonstigen Aufrufe der #Lesezeichen auf der Webseite.

    Nach Aufruf des Shops mit den beiden Testartikeln schaut es soweit noch ok aus, nur funktionieren die „individuellen Links“ nicht mehr.

    Bei -PROFIL- habe ich im Link mal das www ergänzt, macht aber keinen Unterschied und läuft auch in eine 404…

    Lösche mal in einem Menüspunkt das „/onepress“ und versuche es dann! 😉

    jostu Du bist ein Schatz!

    Warum auch immer, dies löst das Problem ohne wenn und aber, VIELEN DANK!

    Ich würde mich mit dem ganzen näher auseinander setzen, frage mich nur wo ich da anfangen soll 🙁
    Die Anleitung zum Theme ist eher rudimentär anzusehen und zeigt nur auf was eigentlich eh intuitiv geändert wird.
    Grundlegende WP Tutorials finde ich auch nicht wirklich in einer Form, die mir die zum Beispiel bei solchen Sachen wie der Menuproblematik helfen…

    Also erst mal weiter Try and Error…

    Gruß Joe

    Ja, oft sind die „richtigen“ Suchbegriffe hilfreich. Diesmal mit „wp anker im menü“!
    Die richtige Spur fand ich über Go..le auf dieser Seite LINK!
    Diese Seite war schon mal hilfreich bei den Sprungmarken – „Anker“
    …. und Go..le ist dein/mein Freund 😉
    Seit ich eine WordPress-Seite aufbaute, lese ich nahezu alles in 2 WP-de-Foren ….., wobei in dem hier bin ich noch nicht soo lange.

    ja spannend, wobei auf der verlinkten Seite ja witzigerweise /seiten-oder-beitragsname/ dazwischen gesetzt wird…
    Aber wie zum Geier hätte ich nun auf „Anker“ kommen sollen…? 🙂

    Werde mal schauen was ich sonst noch an Foren zum Thema finden kann.

    Dir auf jeden Fall noch mal danke, so langsam wird es rund. Wobei natürlich noch Inhalt und ein gescheites Logo fehlt, aber das Gerüst gefällt mir schon ganz gut.

    witzigerweise /seiten-oder-beitragsname/ dazwischen gesetzt

    ja da ist der Anker aber nicht auf einer speziellen Startseite, wie bei deinem Theme.
    Wenns geholfen hat, dann passt es! Das Weitere wird auch noch, aber mit dem Projekt wachsen auch die Ansprüche 😉
    Bitte den Thread-Status auf „gelöst“ setzen.

    Erledigt!

    Ja grundsätzlich kenne ich die Situation, wobei ich immer noch hoffe mich nicht „vollzeitmäßig“ mit der Seite beschäftigen zu müssen.
    Aber, das sehen wir dann zu gegebener Zeit, momentan ist es erst mal ein Test aus… technischer Neugierde 😉

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „Menü im Shop (für die Seite) bringt 404“ ist für neue Antworten geschlossen.