Support » Allgemeine Fragen » Menü nicht änderbar

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Moderator Bego Mario Garde

    (@pixolin)

    Sieht nach einem JavaScript-Fehler aus.

    Seit Update auf WordPress 5.5 werden einige veraltete JavaScript-Bibliotheken nicht mehr unterstützt. Wenn du ein älteres Theme oder Plugin verwendest, kann das Ursache für die genannten Probleme sein. Bis der Theme-/Plugin-Entwickler ein Update liefert kannst du als Übergangslösung (!) das Plugin Enable jQuery Migrate Helper nutzen. (Unter Werkzeuge > jQuery Migrate musst du dann noch im Pulldown-Menü die jQuery-Version „Legacy“ auswählen.)

    Probier mal, ob damit die Probleme verschwinden.

    Thread-Starter webby0815

    (@webby0815)

    Nein ,das habe ich gerade ausprobiert .das war es leider nicht 🙁

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du die Plugins mal deaktiviert und getestet?

    Thread-Starter webby0815

    (@webby0815)

    ja….

    Hallo,
    du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme z. B. Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme von dir und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und Plugins sieht, während nur für dich alle Plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn er doch schon die Plugins vorübergehend deaktiviert hat und als Fehlerquelle ausschließen kann, wird es wohl eher am Theme liegen? Lässt sich leicht überprüfen, indem kurz ein Standard-Theme aktiviert wird.

    Vielleicht passt das Theme auch noch nicht zur eingesetzten PHP-Version?

    Wobei das ohne Website-Bericht alles Kaffeesatzleserei ist. Wie du an den Website-Bericht kommst, hat Hans-Gerd bereits beschrieben.

    @pixolin

    Wenn er doch schon die Plugins vorübergehend deaktiviert hat und als Fehlerquelle ausschließen kann, wird es wohl eher am Theme liegen?

    mir ist nicht klar, ob @webby0815 mit der doch sehr knappen Antwort „ja….“ das auch alles umgesetzt hat, daher auch mein Hinweis 😉

    Thread-Starter webby0815

    (@webby0815)

    Ich habe die Plugins deaktiviert und auch das Standard Theme genutzt .leider ohne erfolgt . Ich habe den Verdacht ,das es am Datenbank import liegen könnte ….

    Moderator Bego Mario Garde

    (@pixolin)

    Den Website-Bericht bekommen wir trotzdem nicht? ¯\_(ツ)_/¯

    Thread-Starter webby0815

    (@webby0815)

    Den muss ich erstmal schaue wo und wie .habe nur gerade mit dem Handy geantwortet….

    Thread-Starter webby0815

    (@webby0815)

    Das wäre der bericht , mfg

    ### wp-core ###
    
    version: 5.9
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/clients/client0/web1/web
    wordpress_size: 916,61 MB (961137142 bytes)
    uploads_path: /var/www/clients/client0/web1/web/wp-content/uploads
    uploads_size: 2,06 GB (2215164490 bytes)
    themes_path: /var/www/clients/client0/web1/web/wp-content/themes
    themes_size: 6,67 MB (6992044 bytes)
    plugins_path: /var/www/clients/client0/web1/web/wp-content/plugins
    plugins_size: 27,72 MB (29062148 bytes)
    database_size: 6,33 MB (6635520 bytes)
    total_size: 3,00 GB (3218991344 bytes)
    
    ### wp-active-theme ###
    
    name: Gameplay (gameplay)
    version: 2.5
    author: The Smart Magazine Themes
    author_website: http://smthemes.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets, woocommerce, automatic-feed-links, menus, post-thumbnails, editor-style, widgets-block-editor
    theme_path: /var/www/clients/client0/web1/web/wp-content/themes/gameplay
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.5, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (5) ###
    
    Akismet Anti-Spam: version: 4.2.2, author: Automattic, Automatische Aktualisierungen aktiviert
    NextGEN Gallery: version: 3.23, author: Imagely, Automatische Aktualisierungen aktiviert
    PHP Everywhere: version: 3.0.0, author: Alexander Fuchs, Automatische Aktualisierungen aktiviert
    RSS Feed Widget: version: 2.9.0, author: Fahad Mahmood, Automatische Aktualisierungen aktiviert
    SEOPress: version: 5.4.4, author: SEOPress, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 aarch64 20190101 https://imagemagick.org
    imagick_version: 3.4.3
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 200M
    max_effective_size: 8 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 6
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 4.9.241-arm64 aarch64
    httpd_software: Apache
    php_version: 7.3.31-1~deb10u1 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 8M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.31-MariaDB-0+deb10u1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    max_allowed_packet: 16777216
    max_connections: 151
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/clients/client0/web1/web/wp-content
    WP_PLUGIN_DIR: /var/www/clients/client0/web1/web/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    • Diese Antwort wurde geändert vor 6 Monaten von Hans-Gerd Gerhards. Grund: Bitte den Code immer als "Code" formatieren

    Hallo,
    du verwendest PHP 7.3.x. Stelle bitte die PHP-Version auf 7.4.x um. Deaktiviere bitte auch Akismet. Das Plugin wird in der Regel nicht datenschutzkonform eingesetzt.

    Wir können dir bei gekauften Themes (hier Gameplay) oder Plugins so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das entsprechende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an den Entwickler wenden. Lies bitte auch mal in der FAQ II, 1b zu diesem Thema.

    Ich habe den Verdacht ,das es am Datenbank import liegen könnte

    Mögliche Lösungen für eine Reparatur der Datenbank – aber bitte auf jeden Fall erst mal zumindest die DB sichern:

    Viele Grüße
    Hans-Gerd

    Thread-Starter webby0815

    (@webby0815)

    Nu so nebenbei , es liegt nicht am Template , da es der Standard Editor vom WordPress im Admin Panel ist . Auch liegt es nicht an der PHP version.

    es geht ja nur darum ,das ich das Menü nicht editieren kann , angezeigt wird es mir auf der HP ….

    Das reparieren hat nichts gebracht.

    Anbei habe ich eine neuinstallation auf dem selben server gemacht , da funktioniert das menü editieren ….

    • Diese Antwort wurde geändert vor 6 Monaten von webby0815.

    Nu so nebenbei , es liegt nicht am Template , da es der Standard Editor vom WordPress im Admin Panel ist .

    Also: Du meinst wahrscheinlich ein Standardtheme (in deinem Fall Twenty Twenty-One) von WordPress. Das Theme hat erst mal nichts mit dem Editor zu tun. Die Bearbeitung von Beiträgen und Seiten erfolgt in der Regel über den Block-Editor, es sei denn du würdest einen Page Builder oder den Classic Editor verwenden. Das ist aber lt. Bericht nicht der Fall.

    Wenn aber die Neuinstallation funktioniert hat, dann könnte das auch mit defekten Dateien zusammenhängen. Hast du schon mal über Dashboard > Aktualisierungen die Option „Version 5-9-de.DE erneut installieren“ (Button) getestet?

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „Menü nicht änderbar“ ist für neue Antworten geschlossen.