Support » Allgemeine Fragen » Menü wird nicht angezeigt

  • Hallo liebe Freunde,
    Ich arbeite gerade an einer Website. Diese ist jedoch nicht veröffentlicht, sondern läuft durch Docker.
    Nun will ich auf meiner Landingpage ein Navigationsmenü erstellen. Dabei gehe ich wie folgt vor :
    Designs, dann Menü und dann setze ich alle Richtlinien. am ende drücke ich natürlich Menü speichern. Leider wird es mir nicht auf der Homepage angezeigt, obwohl es eigentlich freigeschaltet ist.
    Wenn ich bei Elementor, in der Bearbeitungsseite das „WordPress Navigationsmenü“ einfüge, dann wird es mir nur vertikal angezeigt und man kann es nicht bearbeiten.

    Bin ziemlich verzweifelt.. Liegt es daran, dass die Website nicht veröffentlicht ist ?
    Verstehe aber den Zusammenhang nicht, warum das Menü nicht angezeigt werden kann.
    Wenn jemand ein Plugin kennt, welches auch Menüs erstellt, dann auch immer her damit.

    Wäre super glücklich für eine Antwort!!

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo,

    Liegt es daran, dass die Website nicht veröffentlicht ist ?

    ich habe einige WordPress-Instanzen auf einer lokalen Entwicklungsumgebung (Laragon) eingerichtet. Das ist sicher nicht das Problem.
    Ein zusätzliches Plugin zu diesem Zweck ist auf keinen Fall die Lösung.
    Vermutlich hast du das Menü noch nicht und/oder falsch zugewiesen. Schau doch mal unter Design > Menüs auf das Register „Positionen verwalten“, ob da das Menü zugewiesen ist („Position im Theme“ > „Zugewiesenes Menü“). Evtl. hast du die Bearbeitung bis dato nur unter „Menüs bearbeiten“ vorgenommen.
    Bezogen auf Elementor kann ich dir leider nicht helfen.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller valeriewanda

    (@valeriewanda)

    Leider kann es auch nicht daran liegen. Habe nachgeschaut und dort scheint auch alles richtig eingestellt zu sein 🙁

    Das mit den hellseherischen Fähigkeiten ist so eine Sache, aber kann es sein, dass du für die Landing-Page ein Canvas-Template verwendest? Das ist hübsch, um alle möglichen Elementor-Widgets anzuzeigen, deaktviert aber auch das Theme-Menü.

    Thread-Ersteller valeriewanda

    (@valeriewanda)

    Oh ja danke. Das war das Problem. Kann ich im Nachhinein ein Template hinzufügen?
    Wenn ja, Wie und Wo?

    Danke für die Antwort 🙂

    Wenn du die Seite im WordPress-Editor bearbeitest (nicht in Elementor) kannst du über die Sidebar der Seite ein Template zuweisen.
    Die Elementor-Widgets kannst du auch auf Seiten mit einem Standard-Template verwenden, nur wird dann Header und Footer des Themes angezeigt (was in diesem Fall ja erwünscht ist).

    Der Begriff Landing Page ist übrigens in diesem Kontext verwirrend, weil damit eine dedizierte Webseite für eine Marketing-Aktion gemeint ist, während du vermutlich die Startseite (engl. Front Page) meinst.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Menü wird nicht angezeigt“ ist für neue Antworten geschlossen.