Support » Allgemeine Fragen » Menüeintrag lässt sich nicht löschen

  • Hallo,

    ich habe vor einigen Monaten einen Menüeintrag auf der Homepage im Mitgliederbereich gemacht, den ich jetzt wieder löschen will, weil er nicht (mehr) gebraucht wird.
    Nur bekomme ich das jetzt nicht hin.

    Wenn ich den entsprechenden Menüeintrag ausklappe und auf „Entfernen“ klicke, wird der Eintrag ausgeblendet. Wenn ich dann rechts unten auf „Menü speichern“ klicke, wird einfach nur ein weißes Fenster angezeigt. Klicke ich auf den „Zurück“-Pfeil des Browsers, ist der Menüeintrag wieder da und ein Refresh im Browser bringt auch nichts. Und auch auf der Homepage ist der Menüeintrag weiterhin zu sehen.
    Ich habe jetzt erstmal die zugehörige Seite in den Papierkorb verschoben, was dazu führt, dass der Menüeintrag auf der Homepage nicht mehr angezeigt wird. Aber im Backend wird der Menüeintrag rot angezeigt, weil die Seite ja quasi nicht mehr da ist.

    Meine WP-Version ist 6.1.1, die php-Version ist 8.0, beides erst seit einigen Tagen.

    Wie kann ich den Menüeintrag löschen?

    Gruß
    Rolf

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 19)
  • Thread-Starter Rolf

    (@rolinux)

    Hmmm… Merkwürdig…
    Jetzt habe ich die Inhaltsseite ganz gelöscht und nach einigen Minuten wieder ins Menü geschaut, und der Eintrag ist jetzt weg. Muss ich das verstehen?
    Muss die entsprechende Seite ganz gelöscht werden, damit so ein Menüeintrag verschwindet?

    Gruß
    Rolf

    Kannst du mal testweise auf PHP 7.4 umstellen?

    Ansonsten: Bevor du ein neues Thema/Thread erstellst

    Muss die entsprechende Seite ganz gelöscht werden, damit so ein Menüeintrag verschwindet?

    Definitiv nein.

    • Diese Antwort wurde geändert vor 1 Woche, 2 Tage von bscu.
    Thread-Starter Rolf

    (@rolinux)

    Hallo,
    nachdem ich jetzt festgestellt habe, dass der gleiche Effekt beim Speichern eines geänderten Termins auftritt, habe ich auf php 7.4 umgestellt und da klappts.
    Das nützt mir nur nicht viel, weil mein Hoster udmedia am 28. November php 7.4 abschaltet und ich dann nur noch php 8.0 oder neuer verwenden kann.

    Gruß
    Rolf

    Nochmal: Bevor du ein neues Thema/Thread erstellst

    Und jetzt bitte auch lesen und beachten, ansonsten kommen wir hier nicht weiter.

    Alle Plugins und Themes auf dem aktuellsten Stand?

    • Diese Antwort wurde geändert vor 1 Woche, 2 Tage von bscu.

    Hallo,
    in der Tat ist das ohne Bericht schwierig.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Du hast offensichtlich das Plugin Jetpack installiert. Jetpack ist übrigens unter datenschutzrechtlichen Gesichtspunkten problematisch. Das Plugin solltest du löschen (auch wenn es vermutlich nichts mit deinem Problem zu tun hat).

    Evtl. gibt es auch noch ein anderes Plugin, das Probleme macht. Das können wir allerdings erst mit dem Bericht beurteilen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Rolf

    (@rolinux)

    Hier der Zustandabericht von meiner Homepage:

    
    ### wp-core ###
    
    version: 6.1.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 34
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /…/gamwp
    wordpress_size: 526,23 MB (551787541 bytes)
    uploads_path: /…/gamwp/wp-content/uploads
    uploads_size: 98,34 MB (103118147 bytes)
    themes_path: /…/gamwp/wp-content/themes
    themes_size: 5,30 MB (5558325 bytes)
    plugins_path: /…/gamwp/wp-content/plugins
    plugins_size: 110,03 MB (115378666 bytes)
    database_size: 9,10 MB (9543427 bytes)
    total_size: 749,00 MB (785386106 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Twenty Fifteen (twentyfifteen)
    version: 3.3
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, custom-background, editor-style, editor-styles, wp-block-styles, responsive-embeds, editor-color-palette, editor-gradient-presets, customize-selective-refresh-widgets, custom-header, jetpack-responsive-videos, jetpack-geo-location, widgets
    theme_path: /…/gamwp/wp-content/themes/twentyfifteen
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Two: version: 1.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (21) ###
    
    All-in-One Event Calendar by Time.ly: version: 3.0.0, author: Time.ly Network Inc., Automatische Aktualisierungen aktiviert
    Contact Form 7: version: 5.6.4, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    CookieYes | GDPR Cookie Consent: version: 3.0.5, author: CookieYes, Automatische Aktualisierungen aktiviert
    Display Posts: version: 3.0.2, author: Bill Erickson, Automatische Aktualisierungen aktiviert
    Jetpack: version: 11.5.1, author: Automattic, Automatische Aktualisierungen aktiviert
    Mmm Simple File List: version: 2.3, author: Adam Bissonnette, Automatische Aktualisierungen aktiviert
    Newsletter: version: 7.5.6, author: Stefano Lissa & The Newsletter Team, Automatische Aktualisierungen aktiviert
    NextGEN Gallery: version: 3.30, author: Imagely, Automatische Aktualisierungen aktiviert
    Plugin Report: version: 2.1.1, author: Roy Tanck, Automatische Aktualisierungen aktiviert
    PublishPress Future: version: 2.8.0, author: PublishPress, Automatische Aktualisierungen aktiviert
    Simple History: version: 3.3.1, author: Pär Thernström, Automatische Aktualisierungen aktiviert
    Timed Content: version: 2.72, author: K. Tough, Arno Welzel, Enrico Bacis, Automatische Aktualisierungen aktiviert
    Title Remover: version: 1.2.1, author: WPGurus, Automatische Aktualisierungen aktiviert
    Two Factor: version: 0.7.3, author: Plugin Contributors, Automatische Aktualisierungen aktiviert
    Ultimate Member: version: 2.5.1, author: Ultimate Member, Automatische Aktualisierungen aktiviert
    Ultimate Member - reCAPTCHA: version: 2.3.1, author: Ultimate Member, Automatische Aktualisierungen aktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.23, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen aktiviert
    User Role Editor: version: 4.63.1, author: Vladimir Garagulya, Automatische Aktualisierungen aktiviert
    WP File Manager: version: 7.1.6, author: mndpsingh287, Automatische Aktualisierungen aktiviert
    WPS Hide Login: version: 1.9.6, author: WPServeur, NicolasKulka, wpformation, Automatische Aktualisierungen aktiviert
    WP Super Cache: version: 1.9.1, author: Automattic, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 30M
    upload_max_filesize: 30M
    max_effective_size: 30 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 5.15.75-gentoo-ud59 x86_64
    httpd_software: Apache
    php_version: 8.0.25-udmedia 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 180
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 30M
    php_post_max_size: 30M
    curl_version: 7.85.0 OpenSSL/1.1.1q
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.28-19
    client_version: mysqlnd 8.0.25-udmedia
    max_allowed_packet: 4194304
    max_connections: 500
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /…/gamwp/wp-content
    WP_PLUGIN_DIR: /…/gamwp/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### jetpack ###
    
    site_id: 157169703
    ssl_cert: No
    time_diff: undefined
    version_option: 11.5.1:1668364787
    old_version: 11.4:1664940943
    public: Public
    master_user: #46 xxx
    current_user: #46 xxx
    tokens_set: Blog User
    blog_token: l*3iAK#Fw^js9LmJ$fwhw7$8ouT6TyI9
    user_token: )yMAtgTg)&jogX3u0(!m^sgsQfhq9(Ej
    version: 11.5.1
    jp_plugin_dir: /…/gamwp/wp-content/plugins/jetpack/
    plan: free
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Thu, 01 Jan 1970 00:00:00 +0000","finished":"Thu, 01 Jan 1970 00:00:00 +0000","progress":[],"config":[]}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"https:\/\/www.gospel-and-more-birkenfeld.de","siteurl":"https:\/\/www.gospel-and-more-birkenfeld.de","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: All Pass.

    Könnt Ihr damit was anfangen?

    Gruß
    Rolf

    • Diese Antwort wurde geändert vor 1 Woche, 1 Tag von Rolf.
    • Diese Antwort wurde geändert vor 1 Woche, 1 Tag von Hans-Gerd Gerhards. Grund: Korrektur Code

    Hallo,
    Jetpack ist unter datenschutzrechtlichen Gesichtspunkten problematisch. Das Plugin solltest du löschen. Allerdings ist eher unwahrscheinlich, dass das Problem damit zusammenhängt.

    Teste bitte auch mal, ob das Problem auftaucht, wenn du ein aktuelles (klassisches) Theme wie z. B. TWenty Twenty installierst und aktivierst. Vorher bitte eine Sicherung erstellen.

    Du kannst ja auch mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme z. B. Twenty Twenty-Two aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme von dir und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass Besucher deine Website weiter mit allen Infos und Plugins sehen, während nur für dich alle Plugins deaktiviert sind.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Rolf

    (@rolinux)

    Ok. Jetpack habe ich deinstalliert und das Health-Plugin installiert und durchgearbeitet.
    Bei normalen Beiträgen oder Seiten keine Probleme.
    Beim Bearbeiten von Veranstaltungen, die ich ja mit dem Plugin „All-in-One Event Calendar von Time.ly“ überhaupt erst bearbeiten kann (WP selber bringt ja nichts dafür mit), kommt der beschriebene Fehler und die Änderung ist weg. Auch wenn nur das Kalender-Plugin aktiviert ist.
    Gibts gute Alternativen zum All in one Calendar? Vlt. hilft es ja, den zu ersetzen.

    Gruß
    Rolf

    Hallo,
    dann gibt es m. E. zwei Möglichkeiten:

    Ich verwende bei einigen Projekten das Plugin The Events Calendar. Das letzte große Update des Plugins ist allerdings zumindest bezogen auf die kostenpflichtige Pro-Version ein Desaster. Die freie Version funktioniert allerdings.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Rolf

    (@rolinux)

    Hallo Hans-Gerd,

    ich habe jetzt mal The Event Calendar installiert (in der kostenlosen Variante), aber auch hier kann ich keine Termine speichern. Auf jeden Fall scheint das Problem nicht auf das Plugin All-in-One Event Calendar beschränkt zu sein. Zumindest der Event Calendar hat das gleiche Problem. Das Problem ist, dass die Seite im Browserfenster einfach leer ist, es wird gar nichts mehr angezeigt, nur der Browser-Rahmen, wenn ich auf „Veröffentlichen“ klicke. Allerdings hats die Kategorien, die ich bei der erfolglosen Terminerstellung erstellt habe, gespeichert.

    Bei normalen Beiträgen und Inhaltsseiten habe ich keine Problem. Dafür verwende ich den WP-Standard Gutenberg-Editor. Den habe ich allerdings schon in der Version 5 verwendet, also vor dem Update auf 6.1.1 und der Änderung der php-Version.

    Kann es sein, dass diese Plugins in WP 6.1.1 und/oder php 8.0 damit ein Problem haben, weil die den Gutenberg nicht verwenden?

    Gruß
    Rolf

    • Diese Antwort wurde geändert vor 2 Tage, 17 Stunden von Rolf.

    Hallo,

    Kann es sein, dass diese Plugins in WP 6.1.1 und/oder php 8.0 damit ein Problem haben, weil die den Gutenberg nicht verwenden?

    sicher nicht: Ich verwende das Plugin The Events Calendar (TEC) unter WordPress 6.1.1 und PHP version 8.0.25. Da leider TEC noch nicht optimal für den Block Editor eingerichtet ist, verwende ich bei den Veranstaltungen die folgende Einstellung (im Prinzip der Classic Editor) unter Veranstaltungen > Einstellungen > Allgemein.

    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):
    Screenshot Einstellungen.

    Hilfreich könnte auch die Aktivierung des Debug-Modus sein. Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.
    Gib dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) in der wp-config.php oberhalb von /* That’s all, stop editing! Happy blogging. */ folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du define('WP_DEBUG', false); überschreibst, falls die Zeile bereits in der wp-config.php steht. Wenn versucht wird, diese Konstante ein zweites mal zu definieren, gibt es einen Fehler, was deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen sagen wir WordPress, dass der Debug-Modus aktiviert werden soll. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden.
    Wenn der Fehler gefunden wurde bzw. wenn die Fehler nicht mehr in die debug.log geschrieben werden sollen, dann musst du daran denken, die Variable
    define( 'WP_DEBUG_LOG', true );
    wieder auf false zu setzen:
    define( 'WP_DEBUG_LOG', false);

    Einen entsprechenden Beitrag, wie man das auch mit Verwendung eines Plugins macht, findest du hier.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Rolf

    (@rolinux)

    Nachtrag:
    Normalerweise habe ich Firefox als Browser. Ich habe das jetzt aber auch mal mit Edge probiert, auch da funktionierts nicht. Nur das da das Browserfenster nicht leer ist, sondern Fehler 500 anzeigt und dass gospel-and-more-birkenfeld.de die Anfrage nicht bearbeiten kann.
    Ich weiß, Fehler 500 ist so gut wie keine Fehlermeldung. Aber es liegt also auch nicht am Browser oder dessen Einstellungen, weil Edge bei mir mit den Standard-Einstellungen läuft, weil ich ihn nur in absoluten Ausnahmen wie sowas z.B. verwende.

    Gruß
    Rolf

    Hallo,
    schau mal bitte in die error.log beim Hoster, ob da Einträge sind und ob das Problem zu einem bestimmten Zeitpunkt entstanden ist. Prüfe doch dann bitte, was du davor gemacht hast (Plugin, Theme aktualisiert, etc.).

    Viele Grüße
    Hans-Gerd

    Thread-Starter Rolf

    (@rolinux)

    Das Problem habe ich bemerkt, nachdem ich WP auf 6.1.1 aktualisiert hatte und php 8.0 aktiviert habe. Vorher konnte ich auf jeden Fall noch Termine normal bearbeiten. Ich kann also nicht sagen, ob es nach dem Update auf WP 6.1.1 war oder nach der Aktivierung von php 8.0.

    Die Einstellung mit dem Gutenberg-Editor, die Du oben zeigst, war bei mir schon als Default eingestellt.

    Ich habe mal in das Error-Log im WP-Installationsverzeichnis geschaut. Da steht von heute nur diese Fehlermeldung drin:

    [27-Nov-2022 14:22:06 UTC] All-in-One Event Calendar: Required parameter $public follows optional parameter $output @ /…/gamwp/wp-content/plugins/all-in-one-event-calendar/lib/robots/helper.php:135 #8192

    Ist das die Erro-Log-Datei beim Hoster, die Du meinst?

    Ich habe den All-in-One Calendar nicht deaktiviert, weil der ja auf der Homepage aktuell noch gebraucht wird.

    Ich habe die Homepage auch mal in den Problembehandlungsmodus geschickt und alle Plugins wieder aktiviert außer dem AIO-Calendar. Aber da hat sich keine Besserung ergeben.

    Den Debug-Modus in der config.php muss ich mal noch ausprobieren.

    Gruß
    Rolf

    Ist das die Erro-Log-Datei beim Hoster, die Du meinst?

    das scheint die Datei zu sein.

    Den Debug-Modus in der config.php muss ich mal noch ausprobieren.

    Dann melde dich danach bitte noch mal hier.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 19)