Support » Allgemeine Fragen » Mesmerize Beitragsbilder werden auch im Header angezeigt

  • Gelöst strumi

    (@strumi)


    Hallo, ich bin Neuling und benötige etwas Unterstützung. Die Suche brachte keine hilfreichen Ergebnisse. Ich habe die Mesmerize Theme in Benutzung und finde die auch ganz Chick.
    Ich möchte gerne Blockbeiträge mit Beitragsbilder erstellen. Prinzipiell funktioniert das auch. Das Beitragsbild wird auch direkt ganz oben im Beitrag angezeigt.
    Bild zum Beitrag
    Leider werden diese Bilder un d die Überschrift auch im Header angezeigt. Das möchte ich nicht. Kann ich das irgendwie einstellen.

    Beitragsbild mit Überschrift im Header

    hier noch ein Screanshoot mit Überschrift im Header ohne Beitragsbild.

    Wie gesagt, ich möchte weder Überschrift noch das Beitragsbild im Header.
    Was muss ich tun?

    • Dieses Thema wurde geändert vor 6 Monaten, 4 Wochen von strumi. Grund: Liks wurden abgeändert

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Hallo,
    teste mal unter Design > Customizer > Zusätzliches CSS:

    img.space-bottom-small.space-bottom-xs.wp-post-image.lazyloaded {
        display: none;
    }
    h2.h1 {
        display: none;
    }
    

    Allerdings finde ich zumindest die fehlende Überschrift dann nicht mehr so schön. Aber das ist nur meine persönliche Meinung.
    Viele Grüße
    Hans-Gerd

    Moin Hans-Gerd,

    unter Design > Customizer gibt es bei mir den Eintrag Zusätzliches CSS nicht.
    Aber unter Design > Customizer > Allgemeine Einstellunmgen konnte ich die Option finden. Allerdings passiert nichts, wenn ich deinen Code dort hinterlege.

    Gruß Mike

    Hallo,
    ich habe gerade mal das theme lokal installiert.
    Das müsstest du hier eingeben:
    Deine Anpassungen für ▸ Allgemeine Einstellungen > Zusätzliches CSS
    Viele Grüße
    Hans-Gerd

    Habe ich gemacht.
    Beitragsbild und Überschrift werden trotzdem weiterhin angezeigt.

    Bei mir nicht.
    Lade die Seite mal in einem anderen Browser oder im Inkognito-Modus z. B. von Chrome (Stichwort: Browsercaching). Zusätzlich solltest du das Caching löschen, falls du irgendwelche Plugins dafür einsetzt.

    Cache mit Autoptimize gelöscht. Seite mit Chrome im Inkognito geladen,
    Bild und Überschrift werden ebenfalls weiterhin angezeigt.

    Nimm doch mal einen komplett anderen Browser, den du lange nicht mehr eingesetzt hast.
    Notfalls solltest mal autoptimize einfach mal deaktivieren, obwohl das eigentlich nicht daran liegen kann, weil es sonst bei mir ja nicht korrekt angezeigt würde.

    (EN, sorry) pro-tip; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there are troubleshooting tips and info on how to exclude in the AO FAQ.

    hope this helps debugging,
    frank

    @optimizingmatters Once more, thank you Frank for your immediate help regarding your plugin. To keep the threads accessible to non-english speaking users, I may jump in with a little translation:

    Deutsche Übersetzung:

    Pro-Tip: Du kannst Autoptimize für jede einzelne Anfrage deaktivieren, indem du ?ao_noptimize=1 an die URL anhängst.

    Wenn das Problem dann nicht mehr besteht, ist möglicherweise eine (Neu-)Konfiguration von Autoptimize erforderlich, um das Problem zu beheben. Tipps zur Fehlerbehebung und Informationen zum Ausschluß findest du in der AO-FAQ.

    Ich hoffe, dies hilft bei der Fehlersuche,
    Frank

    Ich habe Chrome soeben erst installiert, also vorher noch nie benutzt.
    Kann es vielleicht daran liegen, dass ich nur die gratis Version des Theme benutze?

    Ist der Code korrekt?

    img.space-bottom-small.space-bottom-xs.wp-post-image.lazyloaded {
    display: none;
    }
    h2.h1 {
    display: none;
    }

    Für die Überschrift versuche mal:

    h1.hero-title {
    display: none;
    }

    Hier noch mal ein screenshot:
    Haibike-SDURO-LT-Fullseven-7-0-strumi-de-Googl

    h1.hero-title {
    display: none;
    }

    hat funktioniertt.
    Überfschrift ist weg. Jetzt muss nur noch das Bild verschwinden.

    Versuche für das Bild folgendes:

    /*Beitrags Headerbild ausblenden*/
    .header.custom-mobile-image{
    	background-image: url("https://strumi.eu/wordpress/wp-content/uploads/2020/03/space-1.jpeg") !important;
    }
    • Diese Antwort wurde geändert vor 6 Monaten, 4 Wochen von jostu55.
    • Diese Antwort wurde geändert vor 6 Monaten, 4 Wochen von jostu55.

    @jostu55

    Mit diesem String wird nichts mehr angezeigt, auch das Themenbild nicht.

    Ist das überhaupt möglich, das Beitragsbild im Header auszublenden, aber das Themenbild anzeigen zu lassen?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Das Thema „Mesmerize Beitragsbilder werden auch im Header angezeigt“ ist für neue Antworten geschlossen.