Support » Allgemeine Fragen » Mir werden in Beiträgen keine Bilder mehr angezeigt

  • Hallo zusammen, ich arbeite momentan an unserer neuen Intranetseite. Am Montag installierte ich ein Plug-in, um damit Bilder und Videos in Ordnern zu sortieren. Allerdings war das Plug-in nichts und ich habe es darauf hin deinstalliert. Jetzt habe ich das Problem, dass mir die Profilbilder auf den jeweiligen Seiten nicht mehr angezeigt werden. Bilder in Beiträgen werden mir aber angezeigt wie auch Bilder, wenn ich sie über den Bild-Block (Gutenberg) hinzufüge. Verwende ich aber den Medien und Text-Block, wird mir nichts angezeigt.

    Ich habe Folgendes versucht:
    – Den Pfad mit define(‚UPLOADS‘, ‚wp-content/uploads‘); geändert.
    – Die Bilder gelöscht und neu hochgeladen.
    – Permalinks aktualisiert.
    – Die Berechtigungen kontrolliert.
    Gebe ich die URL-Adresse vom Bild in den Browser ein, erscheint eine leere Seite wo steht „Es sieht so aus, als ob an dieser Stelle nichts gefunden wurde. Wie wäre es mit einer Suche?“
    Kann mir bitte jemand weiterhelfen.

    • Dieses Thema wurde geändert vor 3 Monaten, 1 Woche von michaelbrilz89.
    • Dieses Thema wurde geändert vor 3 Monaten, 1 Woche von michaelbrilz89.
Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Ohne Informationen zur Website lässt sich das kaum beantworten. Wir wissen nicht einmal, welches Plugin du zur Sortierung der Mediendateien du verwendet hast. Kein Website-Bericht, keine URL zur Website (klar, Intranet), keine Glaskugel …

    Den Pfad mit define(‚UPLOADS‘, ‚wp-content/uploads‘); geändert.

    … solltest du lassen.

    Hast du dir mal den Quellcode der Webseiten angesehen und geprüft, welche src-URL für die Bilddateien angegeben wird? Hast du unter dieser URL Bilder gespeichert?

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Hallo Bego Mario Garde 🙂
    Unser Intranet ist von außen nicht erreichbar. Der Website-Bericht liefert:

    
    ### wp-core ###
    
    version: 6.0.1
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/intranet
    wordpress_size: 47,30 MB (49592533 bytes)
    uploads_path: /var/www/intranet/wp-content/uploads
    uploads_size: 0,00 B (0 bytes)
    themes_path: /var/www/intranet/wp-content/themes
    themes_size: 11,53 MB (12089471 bytes)
    plugins_path: /var/www/intranet/wp-content/plugins
    plugins_size: 256,74 kB (262903 bytes)
    database_size: 640,00 kB (655360 bytes)
    total_size: 59,70 MB (62600267 bytes)
    
    ### wp-active-theme ###
    
    name: GeneratePress Child (generatepress_child)
    version: 0.1
    author: Tom Usborne
    author_website: https://tomusborne.com
    parent_theme: GeneratePress (generatepress)
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, editor-color-palette, custom-logo, menus, editor-styles, editor-style, widgets
    theme_path: /var/www/intranet/wp-content/themes/generatepress_child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: GeneratePress (generatepress)
    version: 3.1.3
    author: Tom Usborne
    author_website: https://tomusborne.com
    theme_path: /var/www/intranet/wp-content/themes/generatepress
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (3) ###
    
    Active Directory Integration for Intranet Sites: version: 4.0.1, author: miniOrange, Automatische Aktualisierungen deaktiviert
    Formality: version: 1.5.5, author: Michele Giorgi, Automatische Aktualisierungen deaktiviert
    Securepoint custom carousel: version: 1.0, author: Michael Brilz, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 256M
    upload_max_filesize: 256M
    max_effective_size: 256 MB
    max_file_uploads: 20
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.53.3
    
    ### wp-server ###
    
    server_architecture: Linux 5.10.0-16-amd64 x86_64
    httpd_software: nginx/1.21.4
    php_version: 8.0.21 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: 300
    upload_max_filesize: 256M
    php_post_max_size: 256M
    curl_version: not available
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.6.5-MariaDB-1:10.6.5+maria~bullseye-log
    client_version: mysqlnd 8.0.21
    max_allowed_packet: 16777216
    max_connections: 400
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/intranet/wp-content
    WP_PLUGIN_DIR: /var/www/intranet/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: true
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    

    Als Plugin wurde Media Library Organizer verwendet. Die src-URL stimmt, sprich wenn ich die Adresse in den Browser eingebe, wird mir das Bild angezeigt. /wp-content/uploads/2022/08/lutz_mustermann-819×1024-3.jpg

    Unser Intranet ist von außen nicht erreichbar.

    Deswegen hatte ich ja auch geschrieben keine URL zur Website (klar, Intranet). Das ändert aber nichts daran, dass ich mir die Webseiten nicht ansehen kann und es deshalb schwieriger ist, sie zu beurteilen.

    Der Website-Bericht …

    Warum müssen wir hier immer wieder nachfragen, ob wir einen Website-Bericht bekommen? Trotz angeheftetem Beitrag Bevor du ein neues Thema (Thread) erstellst? Grummel …

    Zum Website-Bericht:

    timezone: +00:00 – Umstellen auf Berlin, dann klappt auch die Zeitumstellung
    wp-active-theme: GeneratePress Child – Child-Themes sind schwer zu beurteilen, weil wir nicht wissen, was du im Child Theme angepasst hast.
    wp-themes-inactive (3) – es reicht, ein Standard-Theme („Twenty …“) beizubehalten. Du solltest den Hinweisen unter Werkzeuge > Website-Zustand folgen und nicht benötigte Themes bis auf ein Standard-Theme löschen.
    Ansonsten gibt der Website-Berichts nichts auffälliges her, was ein Verschwinden der Bilder erklären würde.

    Das Plugin Media Library Organizer habe ich in einer Testinstallation installiert und anschließend wieder gelöscht. Das hatte bei meiner Installation keinen Einfluss auf die Darstellung der Bilder.

    Die Aussage

    Gebe ich die URL-Adresse vom Bild in den Browser ein, erscheint eine leere Seite wo steht „Es sieht so aus, als ob an dieser Stelle nichts gefunden wurde. Wie wäre es mit einer Suche?“

    widerspricht nach meinem Verständnis der Angabe

    Die src-URL stimmt, sprich wenn ich die Adresse in den Browser eingebe, wird mir das Bild angezeigt. /wp-content/uploads/2022/08/lutz_mustermann-819×1024-3.jpg

    Möglich ist, dass eines der drei Plugins Probleme bereitet. Hast du mal versucht, die Plugins zu deaktivieren? Taucht der Fehler auch in einem Standard-Theme auf? Hast du den Browser-Cache geleert?

    Vielleicht magst du auch mal im Supportforum des Plugins nachfragen?
    https://wordpress.org/support/plugin/media-library-organizer/

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    „Warum müssen wir hier immer wieder nachfragen, ob wir einen Website-Bericht bekommen?“ Tut mit leid diesbezüglich:/

    „Möglich ist, dass eines der drei Plug-ins Probleme bereitet. Hast du mal versucht, die Plug-ins zu deaktivieren? Taucht der Fehler auch in einem Standard-Theme auf? Hast du den Browser-Cache geleert?“
    Hab ich gerade versucht und es hat nichts gebracht.
    Ich wende mich dann an das Forum vom Plug-in Hersteller.

    Ich danke dir für deine Hilfe 😀

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)