Support » Themes » Mobile Version zeigt nicht die komplette Startseite

  • Gelöst frasel

    (@frasel)


    Hallo zusammen,
    ich betreibe die Internetseite unseres Tennisvereins und bin durch Zufall über einen möglichen Bug bzw. eine fehlerhafte Konfiguration gestolpert, für die ich auch nach intensiver Suche keine Lösung gefunden habe.
    Das verwendete Theme ist „Smartline lite“!
    Der URL-Aufruf startet die Seite immer mit der als statisch eingestellten Startseite „Aktuelles“ (Template: „Magazin Startseite“).
    Diesem Template sind zwei Widgets zugeordnet, damit sowohl die neuesten Beiträge wie auch die neuesten Spielberichte prominent angezeigt werden (Kategorie Beiträge: Box / Kategorie Beiträge: Raster).
    Wird unsere Seite nun über die Desktop-Ansicht (PC, Notebook) aufgerufen, dann ist alles okay.
    Kommt ein Besucher jedoch über sein Smartphone (Android & IPhone!), dann werden die Widgets nicht angezeigt, er erhält also eine Seite „Aktuelles“ auf der nichts zu sehen ist. Das ist natürlich nicht sinnvoll. Erst wenn der Besucher am unteren Rand im dortigen „WordPress“-Menü „Ganze Seite ansehen“ aktiviert, erhält er die gewünschte Ansicht. Beides sind alternative „Mobile“-Ansichten.
    Die meisten Besucher sehen dies aber nicht und verlassen unsere Seite wieder, „es gibt ja nichts aktuelles…“!
    Ich habe keinen Weg gefunden, die mobile Ansicht der ganzen Seite zu erzwingen. Wenn ich mir im Theme-Editor die jeweiligen Vorschauen (Desktop, Tablet, Mobile) anschaue, dann tritt dieses Phänomen nicht auf.
    Ich hoffe die Beschreibung ist verständlich und jemand hat eine Idee? Zu mir: ich bin nicht IT-negativ, allerdings auch kein gelernter Entwickler/Programmierer.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hast du vielleicht ein Plugin wie ‚Widget Options‘ installiert? Da kann man Einstellungen tätigen die dazu führen, dass ein Widget Mobil nicht angezeigt wird.

    Ich hab das Theme mal auf meiner Testumgebung installiert. Die Funktion gefällt mir. Zeigt mir auch auf dem Handy alles korrekt an, das wo bei Deiner Seite auch bei mir alles leer bleibt.

    In den Standardeinstellungen konnte ich jetzt auch keine Stolperfalle entdecken.

    Und noch die Standardfrage: was passiert wenn du die Plugins deaktivierst?

    Gruß René

    • Diese Antwort wurde geändert vor 5 Jahren, 4 Monaten von radarin.
    • Diese Antwort wurde geändert vor 5 Jahren, 4 Monaten von radarin.
    Thread-Starter frasel

    (@frasel)

    Hallo radarin,

    ich habe kein derartiges Plugin installiert. Witzigerweise sind die benannten Widgets ja auch Bestandteil des Themes!

    Deine erste Idee („Test“) habe ich ausprobiert und „Test“ wird sofort angezeigt, d.h. die Widgets werden nur angezeigt in der „Ganze Seite ansehen“-Option.

    Zu den Plugins: welche meinst Du jetzt eins speziell oder grundsätzlich einmal alle deaktivieren und dann Stück für Stück prüfen?

    Das klingt zunächst ja schlüssig, aber mir würde es ja reichen, wenn die Option am unteren Rand im dortigen „WordPress“-Menü („Ganze Seite ansehen“) dauerhaft aktiviert werden kann, dann erhalte ich ja die gewünschte Ansicht. Beides sind (s.o.) alternative „Mobile“-Ansichten.

    Danke schon einmal für Deine Ideen

    Wenn ich das Theme bei mir teste funktioniert es einwandfrei, auch auf dem Handy.

    Ja, mal alle Plugins die nicht explizit zum Theme gehören ausschalten. Wenn es dann immer noch nicht funktioniert, muss der Fehler wo anders liegen. Wobei mir dann langsam die Ideen ausgehen. Vielleicht noch das CSS, aber das ist eher unwahrscheinlich.

    Wenn ich das Browserfenster verkleinere passt bei deiner Seite alles. Am responsive Design kann es nicht liegen.

    Wenn ich in Safari den User Agenten auf iPad ändere bleibt die Anzeige, ändere ich auf iPhone verschwinden die Inhalte auf der Startseite.

    Man muss in diesem Fall den Cache löschen (bzw. per Developer-Tools deaktivieren), wenn man das responsive Verhalten im Desktop-Browser testen will. So hat es bei mir dann funktioniert, die mobile Ansicht richtig anzuzeigen.

    @frasel:
    Was ich herausfinden konnte: Jetpack läuft und es wird vermutlich am mobile Theme „minileven“ liegen, das definitiv auf eurer Website vorhanden ist.
    https://de.jetpack.com/support/mobile/

    Widgets werden im Minleven Theme nur im Primary Widget Area angezeigt:
    https://en.forums.wordpress.com/topic/widgets-not-appearing-in-mobile-minileven-theme/

    Aber mehr lässt sich von außen da nicht sagen. Vielleicht weisen die Hinweise ja auch so in die richige Richtung.

    Thread-Starter frasel

    (@frasel)

    Wow, Angelika!!!

    Das scheint es gewesen zu sein! Also, die gesamte Homepage habe ich eingerichtet. JetPack läuft von Beginn an und dem Eintrag „Das Jetpack Mobile-Theme aktivieren“ habe ich überhaupt keine Beachtung geschenkt!
    Nach Deinem Hinweis habe ich eben diesen Hinweis deaktiviert, mit dem Smartphone die Seite gestartet… und siehe da: es gibt am unteren Rand im dortigen „WordPress“-Menü „Ganze Seite ansehen“ keine Option mehr und es werden alle Widgets / alle Inhalte standardmäßig angezeigt…
    Ich bin schwer begeistert, das hätte ich nicht gefunden! Danke!

    Sehr gerne 🙂

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Mobile Version zeigt nicht die komplette Startseite“ ist für neue Antworten geschlossen.