Support » Allgemeine Fragen » Multidomain Hauptseite https ausgegraut

  • Gelöst melonos

    (@melonos)


    Moin, ich wollte meine Multisite auf https umstellen. Es gibt die domain legato7. de und die Subdomain intern.legato7.de
    Bei der Subdomain liess sich die Adresse unter Netzwerverwaltung/Websites–> bearbeiten problemlos von http auf https umstellen. Bei der Hauptseite ist dieses Feld jedoch ausgegraut. Und in den Einstellungen der Seite selber gibt es den Punkt nicht. Wat nu? Übersehe ich etwas?

    Bin für jede Hilfe dankbar

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Ich habe jetzt nur eine Vermutung, aber es könnte am Facebook-Link liegen.
    Da dieses Bild mittels http eingebunden ist, also ein Mix aus http und https auf der Seite herrscht.

    L.g. Gerry

    Danke für die Antwort. Habs geändert, hat aber keine Auswirkungen, es bleibt ausgegraut

    Also bei mir wird es nicht ausgegraut dargestellt wenn ich die Seite https://legato7.de/ aufrufe, sondern weiß sowie auch hier im Forum angezeigt.
    Lösche alternativ einmal deinen Browsercatch

    Ich habe es mit verschiedenen Browsern ausprobiert. Nebenbei: wo siehst du das? Ich meine die Option in den Einstellungen im Dashboard, bzw in der Netzwerkverwaltung.

    Nebenbei: wo siehst du das? Ich meine die Option in den Einstellungen im Dashboard, bzw in der Netzwerkverwaltung.
    Was meinst du damit genau?
    Wo ich sah das du das Bild von FB mittels http anstelle https eingebunden hattest?
    Das habe ich ganz einfach mit dem DevTool von Google Chrome gesehen (einfach Rechtsklick -> Untersuchen)

    Also wie gesagt bei mir wird es normal angezeigt, auch wenn man auf das Symbol (Vorhängeschloss) klickt wird mir angezeigt das die Webseite sicher sei.

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn du eine Multisite aufsetzt, kannst du die URL der Hauptsite nicht nachträglich im WordPress-Backend ändern. Die Adressen für Website-URL und WordPress-URL erscheinen ausgegraut:

    Screenshot WordPress-Backend

    Um die Änderung trotzdem durchzuführen, musst die die beiden URLs in der Datenbank-Tabelle wp_options anpassen. Dein Webhost stellt dafür normalerweise ein Datenbank-Verwaltungs-Programm zur Verfügung, meistens phpMyAdmin. Es ist immer eine gute Idee, vorher ein Backup der Datenbank anzulegen.

    Wenn du bereits Medien eingebunden hast, solltest du mit einem Plugin wie Better Search Replace die URL von http://example.com auf https://example.com ändern. (Installieren und Netzwerkweit aktivieren, zum Hauptblog wechseln, unter Werkzeuge auf Better Search and Replace gehen, URLs eintragen, Häkchen bei Testlauf entfernen, Ersetzung ausführen.) Es ist wirklich eine gute Idee, vorher ein Backup der Datenbank anzulegen.

    ah, ich hatte dich falsch verstanden. Dachte du siehst dass das Eingabefeld in den Settings nicht ausgegraut wäre.

    Dass die Seite sicher ist, steht bei mir auch, allerdings bewirkt die Einstellung in den Settings ja, dass immer die https Seite aufgerufen wird. du kannst die Seite auch mit http aufrufen. bei der Subdomain intern.legato7.de konnte ich ja umstellen.

    Kann es sein dass ich falsch suche und das in der htaccess umstellen muss?

    *falsch – gelöscht*

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von melonos.
    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von melonos.

    @pixolin : klingt logisch…

    Werde ich dann mal angehen, danke

    Sorry 🙂
    Hab es total falsch verstanden, liegt wohl daran das ich selbst seit Stunden an einem Problem hänge wo ich einfach nicht weiter komme. Das ganze in Kombination mit Schlafmangel ergibt keine gute Mischung.
    Sorry nochmals

    Kein Problem. Danke für die Hilfe

    @pixolin : hat wunderbar und problemlos funktioniert, danke

    Moderator Bego Mario Garde

    (@pixolin)

    Danke für die Rückmeldung. Dann markiere ich den Thread mal als gelöst. 🙂

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Multidomain Hauptseite https ausgegraut“ ist für neue Antworten geschlossen.