Support » Allgemeine Fragen » Multisite eingerichtet – Unterseiten von Webseite nicht erreichbar

  • Hallo
    ich habe auf meinem Server eine WordPress Installation (v6.0.2 derzeit), schon eine Weile, zum Üben.
    Die habe ich nach Anleitung (oder auch nach dieser Anleitung) jetzt zur Multisite umgewandelt.
    Jetzt will ich die Seite einer Kundin (bisher auch eine Multisite einer Uni) per Export und Import auf meine WP-Multisite umziehen, das ging auch einigermaßen (Menüs musste ich händisch erstellen) aber als ich dann die Domain registriert hatte und in WP von meiner Unterseite auf die neue Domain eingestellt hatte, gingen die Unterseiten nicht mehr, nur noch die Startseite.
    Im Apache2 hab ich als DocumentRoot den Pfad der bisherigen WordPress Installation stehen (zB /var/www/example.org/wp), als ServerName die neue Domain.
    Die Unterseiten, zB:
    https://example.org/wp/dedenbachsalazar/libro-nuevo-sept-de-2013-entrelazando-dos-mundos/
    hatten (bevor ich auf die neue Domain umgestellt hatte) noch funktioniert, aber die selbe Seite:
    https://dedenbachsalazar.de/libro-nuevo-sept-de-2013-entrelazando-dos-mundos/
    geht jetzt nicht mehr.
    Ich sitze noch auf dem Schlauch, habe ich da was grob übersehen?
    Hat jemand einen Tipp, wo ich da hingreifen muss?
    Danke.

    Gruß franc

    • Dieses Thema wurde geändert vor 3 Wochen, 6 Tage von francwalter.
    • Dieses Thema wurde geändert vor 3 Wochen, 6 Tage von francwalter.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 16 bis 21 (von insgesamt 21)
  • Thread-Starter francwalter

    (@francwalter)

    So, habe es also neu aufgesetzt:
    1. DB Tabellen in der WP-DB gelöscht
    2. Unterverzeichnis /wp/ in /wp.bak/ umgenannt
    3. Unterverzeichnis /wp/ erstellt und latest_de-DE.zip geladen und ins Verz. entpackt
    4. Meine Hauptseite example.org/wp aufgerufen und WP installiert.
    5. Als Multisite konfiguriert, wie zuvor auch schon. Diesmal las ich:

    Unterverzeichnis-Installation Weil deine Installation in einem Verzeichnis ist, müssen die Websites deines WordPress-Netzwerks Unterverzeichnisse verwenden.

    6. Im Netwerk-Admin eine neue Seite angelegt
    7. Über den Importer die Exporte der Benutzerseite und der Medien importiert (zwei XML-Dateien).
    8. Auf der gerade importierten Webseite die Permalinks auf „Einfach“ gestellt und die Seite geht, aber mit allen anderen Auswahlen geht es immer noch nicht.
    So wie zuvor, hatte also nichts gebracht.

    Ich habe ja noch Zugriff auf die originale Seite (auch in einer Multisite), dort kann ich die Permalinks auf Beitragsname stellen und es geht auch.

    Du könntest versuchen die URL auf https://dedenbachsalazar.de/wp/ zu ändern. Der document root für die Domain im apache muss dann /var/www/example.org/ sein

    Das geht nicht. Mit dem DocumentRoot auf example.org kommt meine Benutzerseite ja gar nicht auf WP, meine Hauptseite (ohne WP) wird gezeigt.
    Die Benutzerseite auf …/wp zu setzen in den Einstellungen der Webseite, bringt auch zusätzlich nichts, weil dann lande ich auf der Hautpseite des WP-Netzwerks.

    …Zu der Zuordnung der Domain habe ich keine Rückmeldung bekommen…

    Was meinst du denn damit genau? Was habe ich da nicht beantwortet?

    Der DocumentRoot der Benutzerseite (dedenbachsalazar.de) steht auf

    /var/www/example.org/wp

    Die WP Seite selbst hat keinen DocumentRoot, weil sie als Unterverzeichnis läuft, also nur meine Hauptseite (example.org) hat einen DocumentRoot im Apache2 nämlich:

    /var/www/example.org

    Rufe ich im Browser example.org auf, komme ich also natürlich nicht auf die WP Seite, sondern auf meine Hauptseite (ich hab noch andere Dienste und Sachen auf der Seite, die ich nicht innerhalb von WP abbilden kann und will).
    Nur mit example.org/wp komme ich auf die WP-Multisite-Hauptseite.

    Was kann das denn noch sein was da verkehrt ist?
    So viel kann man da doch gar nicht einstellen.

    Ich habe da Schwierigkeiten, dir zu folgen.

    Wieso legst du wieder ein Unterverzeichnis an, obwohl ich geschrieben habe „Wenn du eine Multisite aufsetzen möchtest, solltest du WordPress nicht in einem Unterverzeichnis installieren.“?

    Mit „Zu der Zuordnung der Domain habe ich keine Rückmeldung bekommen“ meine ich, dass ich gefragt habe, in welchem Verzeichnis die WordPress-Dateien liegen und welches Verzeichnis du der Domain als Web-Stammverzeichnis zugewiesen hast. Nur kam dazu keine Rückmeldung.

    Die Beschreibung

    Die Benutzerseite auf …/wp zu setzen in den Einstellungen der Webseite, bringt auch zusätzlich nichts, weil dann lande ich auf der Hautpseite des WP-Netzwerks.

    ist mir zu konfus.

    Grundsätzlich läuft es so, dass du WordPress in einem Web-Stammverzeichnis – z.B. /var/www installierst, das einer Domain zugewiesen wurde. Die Installation änderst du in eine Multisite und legst eine oder mehrere weitere Websites an (ob Subdomain oder Unterverzeichnis ist eigentlich egal). Dann musst du beim Webhoster die neue(n) Domain(s) registrieren und eintragen, dass sie das gleiche Web-Stammverzeichnis /var/www verwenden. In der Netzwerk-Verwaltung änderst du dann die Domains der Websited entsprechend ab.

    WordPress macht dann ein so genanntes Domain-Mapping: bei jedem Aufruf einer Webseite wird geprüft, welche Domain angesprochen wurde und der Inhalt der zugehörigen Website wird ausgeliefert. Dazu brauchst du keine zusätzlichen Weiterleitungen – nur den Eintrag in der .htaccess, den du während der Einrichtung der Multisite übernommen hast.

    Thread-Starter francwalter

    (@francwalter)

    Ich habe gelesen, dass es geht: Giving WordPress Its Own Directory
    Ab WP Version 3.5 auch für Multisites.
    Ich habe WP in einem Unterverzeichnis, weil ich keine eigene Domain dafür nehmen will.

    …dass ich gefragt habe, in welchem Verzeichnis die WordPress-Dateien liegen und welches Verzeichnis du der Domain als Web-Stammverzeichnis zugewiesen hast…

    Die WP-Dateien liegen in /var/www/example.org/wp und das Verzeichnis von example.org als Web-Stammverzeichnis ist /var/www/example.org
    Dort ist noch allerhand anderer Kram drauf. Auch andere CMS, alle in Unterverzeichnissen.
    Deinem Vorschlag folgend müsste ich WP in zB /var/www/wordpress installieren, dann zur Multisite machen. Dann würde ich meine Benutzerdomain diesem Stammverzeichnis zuordnen. Dann bräuchte ich allerdings noch eine zweite Domain, die als Haupt-Multi-Site eingetragen ist, also zum verwalten und als Erstseite.
    Die example.org geht ja nicht, die ist ja schon in Verwendung.

    Vielleicht ist es ja auch ein Bug von WP, weil es ja gehen sollte.
    Sollte ich es mal in den Bugtracker schreiben?
    Gibt es eigentlich ein Debug Log in WP?
    Ich habe versucht in die wp-config.php das hinzuzufügen:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    aber es wird keine /wp/wp-content/debug.log angelegt, nachdem ich eine 404 Meldung kriege für eine nicht zu findende Unterseite (bei Permalink nicht auf „einfach“).
    Ein Plugin (zB Error Log Viewer) zeigt auch nichts, ich schätze, es sind auch keine PHP-Fehler, die wohl nur angezeigt würden.

    Dann bräuchte ich allerdings noch eine zweite Domain, die als Haupt-Multi-Site eingetragen ist, also zum verwalten und als Erstseite.

    Nein. Jede weitere Domain bezieht sich auf die Website, die du in deinem Netzwerk eingerichtet und bei der du die Domain angegeben hast.

    Vielleicht ist es ja auch ein Bug von WP, weil es ja gehen sollte.

    Nein, da stimmt was mit der Konfiguration nicht.

    Sollte ich es mal in den Bugtracker schreiben?

    Du kannst neue Bug-Tickets unter https://core.trac.wordpress.org/newticket einreichen – auch wenn es zumindest aus meiner Einschätzung wahrscheinlich kein Bug ist.

    Gibt es eigentlich ein Debug Log in WP?

    Wenn du die Zeilen

    
    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    

    oberhalb von /* That's all, stop editing! Happy publishing. */ in die wp-config.php einträgst, werden PHP-Fehler in den Error-Log wp-content/debug.log geschrieben. Ein 404 ist kein PHP-Fehler.

    Thread-Starter francwalter

    (@francwalter)

    Wie könnte ich denn diesen Fehler debuggen?
    Der Apache übergibt alle Anfragen für die Domain (deden***ar.de) ans Verzeichnis /var/www/example.org/wp weiter, wg. dem DocumentRoot in der config der Domain, den Rest macht ja dann WP.
    Aber wo werden Permalinks bzw. die Seitennamen der Seiten-ID (ID in der DB-Tabelle wp-prefix_posts) zugewiesen?
    Da müsste ich wohl mal rein schauen…

    Thread-Starter francwalter

    (@francwalter)

    Ich habe testweise mal eine andere Webseite in der Netzwerkverwaltung erstellt, dort dann eine Unterseite erstellt, also etwa example.org/neuewebseite/unterseite, das ging ohne eigene Domain noch, klar.
    Dann habe ich eine freie Domain zugewiesen (im Apache selbes DocumentRoot wie die deden***zar.de) und dann gehen die Unterseiten nicht mehr.
    War natürlich klar, ich hatte nur testen wollen, ob es evtl. am Backup (Import) der deden***zar Seite lag.
    Was ich schließlich noch probieren könnte wäre, die freie Domain zu nutzen, mit eigenem Verzeichnis, zB /var/www/example2.org, dort WP installieren, Multisite aktivieren, dann die deden***zar.de dort hin kopieren, DocumentRoot der deden***zar.de auf die example2.org setzen. Das müsste dann aber auf jeden Fall gehen. Gefällt mir nicht so gut, der Plan, ich hätte gerne alles unter meiner example.org, unter einem Dach.

    Du kannst neue Bug-Tickets unter https://core.trac.wordpress.org/newticket einreichen – auch wenn es zumindest aus meiner Einschätzung wahrscheinlich kein Bug ist.

    Ich habe mal ein Ticket erstellt. Es erscheint mir jedenfalls mindestens als in der Dokumentation nicht richtig aufgeführt, es sollte ja funktionieren.

Ansicht von 6 Antworten - 16 bis 21 (von insgesamt 21)