Support » Installation » Multisite-einrichting stockt wegen Netzwerktabellen

  • Hallo, ich versuche eine Multisite anzulegen in meine wordpress.com site. Ich habe die Config.php und .htaccess wie beschrieben geändert. Im Dashboard>werkzeuge>netzwerk-einstellungen kommt nun ganz aben die Warnung, dass bereits ein Netzwerk besteht und ich die Netzwerktabellen entfernen oder leeren sollte.
    Wo finde ich diese Netzwerktabellen? und woran könnte es hapern?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • WordPress.com ist ein kommerzieller Anbieter von Webhosting mit vorkonfigurierten WordPress-Installationen – da wirst du keine Multisite aufsetzen können.

    Ansonsten ist deine Frage schwer einzuschätzen, weil wir keine Informationen zu deiner Website haben. Bitte lies nochmal …

    Warum ein Link zu deiner Website wichtig ist

    Bevor du ein neues Thema (Thread) erstellst

    Thread-Starter geertenverheus

    (@geertenverheus)

    Danke für die Antwort! Der Hinweis auf die Multisite kam aus dem Support-Datenbank meiner .com seite, und auch mein Host meinte, das sollte problemlos gehen. ( Will aber nicht dabei helfen..)

    die webseite ist http://www.verheus.de

    Zustandsbericht:

    
    ### wp-core ###
    
    version: 6.0.1
    site_language: de_DE_formal
    user_language: de_DE_formal
    timezone: Europe/Berlin
    permalink: /blog/%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/sites/site100029006/web/wordpress
    wordpress_size: 169,10 MB (177314716 bytes)
    uploads_path: /home/sites/site100029006/web/wordpress/wp-content/uploads
    uploads_size: 2,30 MB (2414883 bytes)
    themes_path: /home/sites/site100029006/web/wordpress/wp-content/themes
    themes_size: 32,30 MB (33863766 bytes)
    plugins_path: /home/sites/site100029006/web/wordpress/wp-content/plugins
    plugins_size: 64,87 MB (68026081 bytes)
    database_size: 2,56 MB (2684661 bytes)
    total_size: 271,13 MB (284304107 bytes)
    
    ### wp-active-theme ###
    
    name: GeneratePress (generatepress)
    version: 3.1.3
    author: Tom Usborne
    author_website: https://tomusborne.com
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, editor-color-palette, custom-logo, menus, editor-styles, editor-style, widgets
    theme_path: /home/sites/site100029006/web/wordpress/wp-content/themes/generatepress
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (4) ###
    
    Astra: version: 3.9.1, author: Brainstorm Force, Automatische Aktualisierungen deaktiviert
    Blockify: version: 0.0.23, author: Blockify, Automatische Aktualisierungen deaktiviert
    Chaplin: author: (undefined), version: 2.6.7, Automatische Aktualisierungen deaktiviert
    Extendable: version: 1.0.8, author: Extendify, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (11) ###
    
    Akismet Anti-Spam: version: 5.0, author: Automattic, Automatische Aktualisierungen deaktiviert
    Blocksy Companion: version: 1.8.45, author: CreativeThemes, Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.2.4, author: Really Simple Plugins (latest version: 6.3.0), Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.6.1, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Duplicate Page: version: 4.4.9, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    GenerateBlocks: version: 1.5.4, author: Tom Usborne, Automatische Aktualisierungen deaktiviert
    GP Premium: version: 2.1.2, author: Tom Usborne, Automatische Aktualisierungen deaktiviert
    Honeypot for Contact Form 7: version: 2.1.1, author: Nocean, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.14, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen aktiviert
    WP Consent API: version: 1.0.6, author: RogierLankhorst, Automatische Aktualisierungen deaktiviert
    WPGlobus: version: 2.10.2, author: WPGlobus, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1808
    imagemagick_version: ImageMagick 7.1.0-13 Q16 x86_64 2021-10-29 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 500M
    upload_max_filesize: 500M
    max_effective_size: 500 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, ASHLAR, AVI, AVIF, AVS, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUBE, CUR, CUT, DATA, DCM, DCR, DCRAW, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FARBFELD, FAX, FF, FILE, FITS, FL32, FLV, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, HALD, HDR, HEIC, HEIF, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K25, KDC, KERNEL, LABEL, M2V, M4V, MAC, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORA, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PHM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGB565, RGBA, RGBO, RGF, RLA, RLE, RMF, RSVG, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TM2, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, YAML, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: 9.55.0
    
    ### wp-server ###
    
    server_architecture: Linux 5.15.32 x86_64
    httpd_software: Apache
    php_version: 7.4.30 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 5000
    time_limit: 60
    memory_limit: 256M
    max_input_time: 240
    upload_max_filesize: 500M
    php_post_max_size: 500M
    curl_version: 7.79.1 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.10-MariaDB-log
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 67108864
    max_connections: 500
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/sites/site100029006/web/wordpress/wp-content
    WP_PLUGIN_DIR: /home/sites/site100029006/web/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    Vielleicht kommen wir hiermit weiter?

    Im Website-Bericht steht „multisite: false“ – es ist also noch keine Multisite angelegt.

    Poste bitte mal den Inhalt der wp-config.php (in der Antwort bitte die Zeilen mit den Zugangsdaten zur Datenbank und SALT-Keys löschen) und der .htaccess.

    Wie lautet die Fehlermeldung genau?
    Wer ist Webhoster?
    Handelt es sich um ein „Managed WordPress-Hosting“?

    Die Aussage „Der Hinweis auf die Multisite kam aus dem Support-Datenbank meiner .com seite“ verstehe ich noch nicht. WordPress.com ist wie gesagt ein Hosting-Angebot mit vorinstalliertem WordPress – da kannst du keine Multisite anlegen. Was hat das mit deiner Website zu tun?

    Kontrolliere bitte auch mal, ob du den Code für die Multisite (sowas wie …

    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'example.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    

    ) oberhalb der Zeile /* That's all, stop editing! Happy publishing. */ eingefügt hast.

    Thread-Starter geertenverheus

    (@geertenverheus)

    Hi, danke für deine Mühe 🙂

    Das ist die die wpconfig.php, dort ist multisite noch true..

    <?php
    
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';

    und das ist die .htaccess datei:

    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    </IfModule>
    
    # END WordPress

    mein Host is Manitu und ich habe dort ein Paket mit WP-zugang.

    Im Dashboard habe ich schon das Netzwerk einen Namen geben können und es zeigt auch Netzwerk-einrichtung unter den werkzeugen. Etwas ist also angekommen. Bei dem Tab Netzwerkeinrichtung steht dan folgendes:

    Warnung: Ein bestehendes WordPress-Netzwerk wurde gefunden.

    Bitte schließen Sie die Schritte zur Einrichtung ab. Um ein neues Netzwerk anzulegen, müssen Sie die Netzwerk-Datenbanktabellen leeren oder entfernen.

    • Diese Antwort wurde geändert vor 1 Monat, 2 Wochen von geertenverheus.

    @geertenverheus
    Lösche bitte sofort die Zugangsdaten zu der Datenbank in deinem Post. Ändere auch das Passwort, sicher ist sicher. Wie kann man nur so leichtsinnig sein?!

    • Diese Antwort wurde geändert vor 1 Monat, 2 Wochen von bscu.
    Thread-Starter geertenverheus

    (@geertenverheus)

    wie mache ich das? Ich dachte, ich hatte die schon gelöscht… Ich ändere schon mal die Passwörter. Wie löscht man die Posts hier?

    Du kannst dein Post bearbeiten. Wenn du mit der Maus über dem Post bist, erscheint rechts „Bearbeiten“

    Thread-Starter geertenverheus

    (@geertenverheus)

    hmm, sehe ich nicht, bin auf Mac OS firefox

    Thread-Starter geertenverheus

    (@geertenverheus)

    ah habe es gefunden. Danke.
    Wie lösche ich jetzt die Datenbank daten aus der wpconfig.php datei? Wo stehen die überall?

    Jetzt hast du die wp-config.php hier mehr oder weniger komplett gelöscht. Kopiere die Datei in deinen Editor und ändere die Zugangsdaten, bevor du das hier einkopierst, in z.B.
    define( 'DB_PASSWORD', 'xxxxxxxx' );

    define( 'DB_NAME', 'xxxxx' );
    define( 'DB_USER', 'xxxxx' );
    define( 'DB_PASSWORD', 'xxxxx' );
    define( 'DB_HOST', 'xxxxx' );
    $table_prefix = 'xxxxx';
    • Diese Antwort wurde geändert vor 1 Monat, 2 Wochen von bscu.
    Thread-Starter geertenverheus

    (@geertenverheus)

    ich habe das Passwort für die Datenbank geändert, und komme nun selber nicht mehr auf meine wpadmin-seite. Mal schauen wie ich das löse..

    Du musst dann natürlich in der wp-config.php das geänderte Passwort eintragen.

    define( 'DB_PASSWORD', 'xxxxxxxx' );

    Was ich auch etwas bedenklich finde, dass man überhaupt von außen an die Datenbank kommt. Kannst du das eventuell im Control-Panel deines Webspace umstellen?

    • Diese Antwort wurde geändert vor 1 Monat, 2 Wochen von bscu.
    Thread-Starter geertenverheus

    (@geertenverheus)

    Danke, das war ein hilfreicher Tipp.
    Ich weiß nicht, ob man von außerhalb in die Datenbank kommen kann..oder kann mann nicht nur von aussen in einen Datenbank kommen?
    bevor ich die wpconfig.php hier wieder zwecks eigentlichen Problems einstelle, welche Zeilen sollte ich da alles löschen, sadass es safe ist?

    Hallo,
    einfach in etwa in der Form die Daten durch xxx ersetzen, z. B. so:

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', 'xxx' );
    
    /** MySQL database username */
    define( 'DB_USER', 'xxx' );
    
    /** MySQL database password */
    define( 'DB_PASSWORD', 'xxx' );
    
    /** MySQL hostname */
    define( 'DB_HOST', 'xxx' );
    
    ...
    
    /**
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define( 'AUTH_KEY',          'xxx' );
    define( 'SECURE_AUTH_KEY',   'xxx' );
    define( 'LOGGED_IN_KEY',     'xxx' );
    define( 'NONCE_KEY',         'xxx' );
    define( 'AUTH_SALT',         'xxx' );
    define( 'SECURE_AUTH_SALT',  'xxx' );
    define( 'LOGGED_IN_SALT',    'xxx' );
    define( 'NONCE_SALT',        'xxx' );
    define( 'WP_CACHE_KEY_SALT', 'xxx' );
    

    Viele Grüße
    Hans-Gerd

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)