• Gelöst anchovis14

    (@anchovis14)


    Liebe WordPress-Community!

    Ich betreue die Website für ein Kunsthaus, für das wir auch eine englische Version anbieten. Diese hatte ich vor etwa einem Jahr mit WordPress Multisites angelegt und hat auch sehr gut funktioniert mit Hilfe des Multisites Language Switch Pluigns. Seit circa einem Monat wird die englische Seite allerdings deformiert dargestellt und ich habe keine Idee, wo der Fehler liegen könnte. Ich habe alle Plugins einmal de- und wieder aktiviert und es hat sich leider nichts an der Darstellung verändert. Der Fehler scheint an sich bei der englischen Seite zu liegen, weil ich die nicht mal im WordPress-Dashboard bearbeiten kann.

    Hatte vielleicht jemand ein ähnliches Problem und kann mir weiterhelfen? Ich wäre sehr, sehr dankbar!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten – 1 bis 10 (von insgesamt 10)
  • Moderator Bego Mario Garde

    (@pixolin)

    Uns wäre sehr damit geholfen, wenn du dir bitte den angehefteten Beitrag durchliest: Bevor du ein neues Thema (Thread) erstellst

    Dort steht auch, wie du an den Website-Bericht kommst, den wir zur Beurteilung deiner Website benötigen.

    Thread-Starter anchovis14

    (@anchovis14)

    Vielen Dank für den Hinweis. Hier kommt der fehlende Zustandsbericht der Website:

    ` wp-core
    
    version: 6.3
    site_language: de_DE
    user_language: de_DE
    timezone: +02:00
    permalink: /blog/%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: true
    user_registration: false
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    site_count: 2
    network_count: 1
    user_count: 7
    dotorg_communication: true wp-dropins (1) maintenance.php: true wp-active-theme name: Colibri WP (colibri-wp)
    version: 1.0.93
    author: Extend Themes
    author_website: https://colibriwp.com/
    parent_theme: none
    theme_features: core-block-patterns, customize-selective-refresh-widgets, automatic-feed-links, title-tag, post-thumbnails, custom-logo, widgets-block-editor, custom-background, menus, editor-color-palette, widgets
    theme_path: /homepages/15/d863961864/htdocs/Backupwebseite/wp-content/themes/colibri-wp
    auto_update: Deaktiviert wp-themes-inactive (3) Twenty Twenty-One: version: 1.8, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Three: version: 1.2, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.4, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-plugins-active (22) Better Search Replace: version: 1.4.2, author: WP Engine, Automatische Aktualisierungen aktiviert
    CleverReach® WP: version: 1.5.20, author: CleverReach GmbH & Co. KG, Automatische Aktualisierungen aktiviert
    Colibri Page Builder PRO: version: 1.0.278-pro, author: ExtendThemes, Automatische Aktualisierungen aktiviert
    ColibriWP Custom Font: version: 1.0, author: ExtendThemes, Automatische Aktualisierungen aktiviert
    Complianz - Terms and Conditions: version: 1.2.5, author: Really Simple Plugins, Automatische Aktualisierungen aktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.5.3, author: Really Simple Plugins, Automatische Aktualisierungen aktiviert
    Contact Form 7: version: 5.8, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    EventON: version: 4.4.3, author: AshanJay, Automatische Aktualisierungen aktiviert
    EventON Slider Addon: version: 3.0.2, author: Federico Schiocchet - Schiocco, Automatische Aktualisierungen aktiviert
    Forminator: version: 1.25.1, author: WPMU DEV, Automatische Aktualisierungen aktiviert
    Header Footer Code Manager: version: 1.1.35, author: 99robots, Automatische Aktualisierungen aktiviert
    Hummingbird: version: 3.5.0, author: WPMU DEV, Automatische Aktualisierungen deaktiviert
    Hustle: version: 7.8.0, author: WPMU DEV, Automatische Aktualisierungen aktiviert
    Matomo Analytics - Ethical Stats. Powerful Insights.: version: 4.15.0, author: Matomo, Automatische Aktualisierungen deaktiviert
    MetaSlider: version: 3.36.0, author: MetaSlider, Automatische Aktualisierungen deaktiviert
    Multisite Language Switcher: version: 2.5.10, author: Dennis Ploetner, Automatische Aktualisierungen aktiviert
    NS Cloner - Site Copier: version: 4.3.2, author: Never Settle, Automatische Aktualisierungen aktiviert
    Redirection: version: 5.3.10, author: John Godley, Automatische Aktualisierungen aktiviert
    Shortcoder: version: 6.2, author: Aakash Chakravarthy, Automatische Aktualisierungen aktiviert
    Smush: version: 3.14.1, author: WPMU DEV, Automatische Aktualisierungen aktiviert
    Taggbox Widget: version: 2.8, author: Taggbox, Automatische Aktualisierungen deaktiviert
    WordPress Importer: version: 0.8.1, author: wordpressdotorg, Automatische Aktualisierungen aktiviert wp-media image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27 wp-server server_architecture: Linux 4.4.302-icpu-092 x86_64
    httpd_software: Apache
    php_version: 7.4.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: 256M
    admin_memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    current: 2023-08-21T12:53:14+00:00
    utc-time: Monday, 21-Aug-23 12:53:14 UTC
    server-time: 2023-08-21T14:53:11+02:00 wp-database extension: mysqli
    server_version: 5.7.41-log
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 67108864
    max_connections: 3000 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/15/d863961864/htdocs/Backupwebseite/wp-content
    WP_PLUGIN_DIR: /homepages/15/d863961864/htdocs/Backupwebseite/wp-content/plugins
    WP_MEMORY_LIMIT: 64M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    Moderator Bego Mario Garde

    (@pixolin)

    Danke für den Website-Bericht.

    Du schreibst

    Ich habe alle Plugins einmal de- und wieder aktiviert und es hat sich leider nichts an der Darstellung verändert.

    Hast du denn jeweils nach dem Deaktivieren geprüft, wie die Website ohne dieses Plugin läuft?

    Laut Konsole der Entwickler-Tools im Browser werden diverse CSS- und JavaScript-Dateien auch nicht gefunden. Das könnte an fehlerhaften Einstellungen in der .htaccess liegen, einer fehlerhaften Serverkonfiguration oder an einem fehlerhaften Dateiübertrag liegen.

    Irgendwas hast du auch versucht im Header einzutragen. Es gibt im Quellcode z.B. die folgenden Zeilen, die so keinen rechten Sinn ergeben:

    <script id="evo-inlinescripts-header-js-after" type="text/javascript">
    jQuery(document).ready(function($){});
    </script>
    Thread-Starter anchovis14

    (@anchovis14)

    Vielen Dank für deine Antwort! Genau, ich habe nach jeder Deaktivierung und Aktivierung des Plugins gecheckt, ob die Seite funktioniert, aber das tut sie leider nicht.

    Wie kann ich überprüfen, ob es an der .htaccess-Datei, einer fehlerhaften Serverkonfiguration oder an einem fehlerhaften Dateiübertrag liegt?

    Was den Quellcode betrifft, habe ich außer der Änderung für die Multisites nichts angefasst. Wie kann ich die Fehler hier beheben?

    Vielen Dank im Voraus!

    Moderator Bego Mario Garde

    (@pixolin)

    Wie kann ich überprüfen, ob es an der .htaccess-Datei,…

    Du kannst die .htaccess in deinem WordPress-Verzeichnis gerne hier teilen, damit wir einen Blick darauf werfen.

    Interessant wäre auch ein Blick in die wp-config.php, wobei du vor Absenden in der Antwort die Zeilen mit den Zugangsdaten, Sicherheitsschlüsseln und Datenbanktabellen-Präfix löschen solltest – die gehen hier niemand etwas an.

    … einer fehlerhaften Serverkonfiguration … 

    das kannst du prüfen, in dem du eine Datei text.css erstellst und mit einem Programmiereditor html { color: red; } reinschreibst. Die Datei lädst du per FTP-Programm oder über das Dateiverwaltungsmenü deines Webhosters in dein WordPress-Verzeichnis hoch. Danach versuchst du, die Datei im Browser zu öffnen. Dir sollten dann einfach der eingetragene Text html { color: red; } angezeigt werden. Wenn das nicht geht, fragst du den Support deines Webhosters, woran das liegen kann.

    … oder an einem fehlerhaften Dateiübertrag …

    Du kannst unter Dashboard > Aktualisierungen den Button „WordPress erneut aktualisieren“ anklicken, um auszuschließen, dass beim letzten Update eine Datei nicht richtig hochgeladen wurde.

    Was den Quellcode betrifft, habe ich außer der Änderung für die Multisites nichts angefasst. Wie kann ich die Fehler hier beheben?

    Wofür verwendest du dann das Plugin „Header Footer Code Manager“? Das ist ein Plugin, um eigenen Code in die Website einzubauen.

    Thread-Starter anchovis14

    (@anchovis14)

    Erneut: danke für die schnelle Rückmeldung! Ich hab beide Dateiinhalte hier reinkopiert und probiere ansonsten die anderen Vorschläge aus.

    .htaccess-Datei:

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    
    # END WordPress

    wp-config.php (bearbeitet – passt das so?)

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    
    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    define( 'DOMAIN_CURRENT_SITE', 'kunsthaus-goettingen.de' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    #/* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';

    Danke!

    Thread-Starter anchovis14

    (@anchovis14)

    *Und ich verwende dieses Header Footer Code Manager Plugin nicht aktiv. Zu meiner Verteidigung muss ich sagen, dass ich die Seite nicht gebaut habe, sondern von einer Agentur übernommen habe und nur adminstriere. Soll ich dieses Plugin deaktiveren?

    Moderator Bego Mario Garde

    (@pixolin)

    Mach bitte ein Backup der .htaccess und erstelle dann mit einem Programmiereditor eine neue .htaccess mit folgendem Inhalt:

    # BEGIN WordPress Multisite
    # Using subfolder network type: https://wordpress.org/documentation/article/htaccess/#multisite
    
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    # END WordPress Multisite

    Was ändert sich dadurch?

    Die wp-config.php sieht ganz normal aus.

    Und ich verwende dieses Header Footer Code Manager Plugin nicht aktiv.

    Prüf bitte, was in den Einstellungen des Plugins eingetragen wurde. Es ist unwahrscheinlich, dass das Plugin „just for fun“ installiert wurde.

    Thread-Starter anchovis14

    (@anchovis14)

    Mit der neuen .ht-access-Datei läuft es wieder! Allerdings nicht im Firefox-Browser. Es hat ein bisschen gebraucht, bis ich es mit Google Chrome ausprobiert habe, und dort funktioniert die Seite wieder wie zuvor.

    Vielen Dank für die Hilfe!

    Mir wird die Website auch in Firefox richtig angezeigt (soweit ich das beurteilen kann).

Ansicht von 10 Antworten – 1 bis 10 (von insgesamt 10)
  • Das Thema „Multisite falsche Darstellung“ ist für neue Antworten geschlossen.