Support » Installation » Multisite Installation

  • Gelöst 26markus11

    (@26markus11)


    Guten Tag,

    ich bin gerade dabei eine Multisite zu installieren.
    Habe die Anleitung von WordPress Codes benutzt.
    Soweit hat auch alles geklappt.
    Wenn ich jetzt eine Unterseite erstelle und auf den Admin-Bereich zugreifen will erhalte ich einen Error 500.

    Kann mir da jemand helfen ?

    Viele Grüße
    Markus

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Moderator Bego Mario Garde

    (@pixolin)

    Wer oder was ist WordPress Codes?
    Um welche Anleitung geht es?

    26markus11

    (@26markus11)

    26markus11

    (@26markus11)

    Die Startseite inklusive Dashboard und Adminbereich funktioniert.
    Sobald ich eine weitere Seite anleg, kann ich zwar auf die Seite zugreifen komme aber nicht in den Adminbereich. Sobald ich in den Adminbereich will kommt Internal Server Error 500.

    Moderator Bego Mario Garde

    (@pixolin)

    Internal Server Error 500 hat leider nur die Aussagekraft von „ist kaputt“ und das hast du selber schon gemerkt. Interessant wäre, was in den Error-Logs als Fehlermeldung ausgegeben wird. Du kannst auch in der wp-config.php das Debugging einschalten mit define( 'WP_DEBUG', true ); oberhalb der Zeile /* That's all, stop editing! Happy blogging. */.

    Poste mal den Inhalt deiner wp-config.php – Zugangsdaten löschen, Code im Beitragseditor des Forums hier markieren und als [Code] formatieren.

    26markus11

    (@26markus11)

    Wenn ich den WP-Debug auf true setze bleibt alles beim gleichen und bekomme auch keine Fehlermeldungen ausgegeben.
    Jedoch kann ich bei den Logfiles folgenden Fehlercode auslesen:

    20.03.2020 12:55:49 domain.de [client 2a01:598:b100::] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.

    Vielleicht kannst du damit schon mehr anfangen als ich ?

    Meine wp-config:

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'xxxxxxxxxxx');
    
    /** MySQL database username */
    define('DB_USER', 'xxxxxxxxxxxxxxx');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'xxxxxxxxxxxxxxxxxxxxx');
    
    /** MySQL hostname */
    define('DB_HOST', 'rdbms.strato.de');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'FonLg4^(q*8!e%bF40d*OKs5Jc0KsA63N^V^#8&&hnbg!%parHhA)#ofv88KBx28');
    define('SECURE_AUTH_KEY',  'aYDc!^xHSBQJpXCpuxe9*n3)ZzEXI7aA&GXq2)lF54wylW91@paXW)hUEye!MhiP');
    define('LOGGED_IN_KEY',    'r0(q#3ho5kVpps6V^LM5D(RLhlI9qe(HdwPUW#A*!ACWbNQaHKs&*fMwwKDoDepr');
    define('NONCE_KEY',        'D1*gKQmb9PsPTzjF)kv2FrO^cidT#@*sW%@0)r)VKvS#d^QF%DYo(eZQUP^fRE4p');
    define('AUTH_SALT',        'CvCW@EOK#SW93kPJC89TUvrInIiyvKrFwQPC%8&qdb#!a9Mw#sfSL9VT#vur0aOI');
    define('SECURE_AUTH_SALT', 'gC#khoAOdw5lLfnl4&KQpwXaeAnPGfwpMt6tHOw3j)Hgoc2X*Wy(E9%F)*mPG@BU');
    define('LOGGED_IN_SALT',   'c0A#Eb6sTNF%PpC4zZDGlQ@)kqQce!osS7%A5HBl99ZqbuczEUhKk#Fu653GS3Ed');
    define('NONCE_SALT',       'pWpCbA%tVInWocjvouKln6u5hG(68Tc(g!HSz6l#2#G2gMbqNq354!jZlaD6LlZG');
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'domain.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    
    define ('FS_METHOD', 'direct');
    
    add_filter( "auto_update_plugin", "__return_true" );add_filter( "auto_update_theme", "__return_true" );add_filter( "allow_dev_auto_core_updates", "__return_true" ); add_filter( "allow_major_auto_core_updates", "__return_true" );
    • Diese Antwort wurde geändert vor 2 Wochen von 26markus11.
    26markus11

    (@26markus11)

    Ich vermute es liegt an meiner .htaccess Datei.
    Bleibe in irgendeiner Schleife hängen.

    So sieht meine .htaccess Datei aus:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) WordPress_SecureMode_02/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ WordPress_SecureMode_02/$2 [L]
    RewriteRule . index.php [L]
    Moderator Bego Mario Garde

    (@pixolin)

    Hast du das geändert, um deine Zugangsdaten nicht zu verraten oder steht da wirklich domain.de?

    define('DOMAIN_CURRENT_SITE', 'domain.de');

    Übrigens bedeutet /* That's all, stop editing! Happy blogging. */ soviel wie „hier nix mehr reinschreiben“.
    add_filter( "auto_update_plugin", "__return_true" );add_filter( "auto_update_theme", "__return_true" );add_filter( "allow_dev_auto_core_updates", "__return_true" ); add_filter( "allow_major_auto_core_updates", "__return_true" );
    gehört nicht in die wp-config.php (und schon gar nicht an diese Stelle).

    Danke dir für deine Hilfe.
    Hab den Fehler gefunden. Lag an der .htaccess datei.
    Kann geschlossen werden.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)