Support » Allgemeine Fragen » Multisite Installation mit Domain Mapping

  • Hallo,

    ich habe das Problem, dass ich meine WordPress Multisiteinstallation (aktuellste Version) in einem Unterordner eingerichtet habe. Die TLD mapt aber auf DocumentRoot. Die RewriteBase für die Multisiteinstallation lautet also „/unterordner/“ und ich steuer die Multisite Seite nur wie folgt an https://www.test.de/unterordner/

    Nun versuche ich eine neue Domain auf eine der Sites zu mappen und es klappt auch einwandfrei, allerdings verlangt diese logischerweise, dass die RewriteBase auf „/“ gesetzt wird. Die TLD wird einwandfrei aufgerufen. Versuche ich jedoch ein Unterverzeichniss anzusteuern bekomme ich ein „Internal Server Error“. Logisch, RewriteBase steht ja auf „/unterordner/“.

    Gibt es irgendeine Möglichkeit die nicht darin endet, dass ich alles neu aufsetzen muss, sodass die Multisiteinstallation nicht im Unterordner liegt? Ich lasse alles auf einem VServer laufen, habe also einige Möglichkeiten den Server zu verbiegen.

    Ich hatte es mit einer IF ELSE Anweisung in der HTACCESS versucht, sodass ich dort hätte die RewriteBase neu setzen können, doch das schlug fehl. Eine andere Idee wäre seperate HTACCESS Dateien für die jeweils gemapten Domains, aber wo sollte ich diese hinlegen? Mein Latein ist irgendwie am Ende…

    Freue mich auf hilfreiche Ideen.

    • Dieses Thema wurde geändert vor 9 Monate, 2 Wochen von jaroslawvenzke.
    • Dieses Thema wurde geändert vor 9 Monate, 2 Wochen von jaroslawvenzke.
Ansicht von 1 Antwort (von insgesamt 1)
Ansicht von 1 Antwort (von insgesamt 1)
  • Das Thema „Multisite Installation mit Domain Mapping“ ist für neue Antworten geschlossen.