Support » Allgemeine Fragen » Multisite, kein Zugriff auf Dashboard der neuen Seite

  • Guten Tag,

    ich versuche derzeit meine Webseite merhsprachig zu gestalten. Dafür wollte ich die Multisite Funktion von Worpress mit Unterverzeichnissen nutzen. Idealerweise kann ich dann das gleiche Theme und Plugin verwenden, da die Webseite ja nur übersetzt werden soll.

    zb. domain.de/ als Hauptseite
    domain.de/english als übersetze Seite

    Gesagt getan, leider ist das Backend der /english Seite nicht erreichbar.
    „Err_TOO_MANYX_REDIERECTS“
    „Umleitungsfehler“

    Cookies vom Browser habe ich natürlich schon gelöscht, leider ohne Erfolg.

    Diese Codezeile habe ich auch bereits der wpconfig.php hinzugefügt:
    define('COOKIE_DOMAIN', $_SERVER[ 'HTTP_HOST' ] );

    Woran könnte es noch liegen, dass das Backend nicht erreichbar ist ?
    In das Backend der Haupt/Originalseite komme ich nach wie vor problemlos rein.

    Vielen Dank.

    • Dieses Thema wurde geändert vor 1 Monat, 1 Woche von venemous.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Geh mal auf wp-admin/network/site-settings.php?id=1 – beginnen beide URLs der Website einheitlich mit https? Wie ist das mit der URL der anderen Website?

    Thread-Ersteller venemous

    (@venemous)

    @pixolin

    Danke für den Hinweis. Unter wp-admin/network/site-settings.php?id=1 steht nur http nicht https, bei der /english Seite genauso.
    Ist das ein Problem ?

    Es wundert mich ein wenig, da ja der SSL Basisschutz bei meinem Hoster aktiviert ist. (checkdomain)

    Wenn ich im Browser ein https://domain.de oder https://domain.de/english eingebe öffnen sich schon die beiden Seiten von mir aber die /english ist sozusagen nur auf Werkseinstellungen sichtbar.

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.

    Die meisten Betreiber werden ihre Website per https betreiben, weil nur so ein Kontaktformular datenschutzkonform eingebunden werden kann, die Eingabe von Zugangsdaten gesichert ist und Suchmaschinen die Website mit einem besseren Ranking bewerten. Das muss dann aber einheitlich sein, nicht eine URL mit, eine ohne https.

    Hast du nach der Einrichtung der Multisite die Permalinks für die Haup-Website nochmal gespeichert? (Unter Netzwerkvervwaltung die Haupt-Site auswählen, dann unter Einstellungen > Permalinks die gewünschte Permalinkstruktur bestätigen.)

    Wie hast du die Multisite angelegt? Für die neue Site (english) stimmen die Pfade zu WordPress nicht.

    Thread-Ersteller venemous

    (@venemous)

    Irgentwas schein mit dem https nicht zu stimmen, da steht im Browser „unsichere Verbindung“. Hm.

    Leider finde ich im Dashboard der Hauptseite unter „Allgemein“ keine Möglichkeit die URL zu ändern. Soll ich das dann in der wpconfig.php vornehmen ?

    das hier als letzte zeile in der wpconfig einfügen:

    define('WP_SITEURL', 'https://www.neue-domain.de');
    define('WP_HOME', 'https://www.neue- domain.de');

    ?

    Als Permalink habe ich „Beitragsname“ erneut abgespeichert.

    Die Multisites habe ich als Ordnerstruktur statt Subdomains beim Installationsprozess ausgewählt. Ja, da stimmt was nicht, allerdings weiß ich derzeit weder was da schiefgelaufen ist noch wie ich es beheben könnte.

    Der Eintrag einer Site- und Home-URL in der wp-config.php macht eigentlich nur Sinn, wenn du eine Staging-Umgebung verwendest und nicht jedesmal die Datenbank anpassen möchtest. Da der Eintrag die Datenbankeinträge überschreibt, bekommst du damit eher noch mehr Probleme.

    Um https nutzen, müssen mehrere Dinge passen:

    • Du brauchst ein SSL-Zertifikat (hast du)
    • Unter Allgemeine Einstellungen muss die Site-URL und WordPress-URL mit https beginnen. (hast du nicht) Das sollte korrigiert werden bevor du eine Multisite einrichtest.
    • Die URL wird in der Datenbank an verschiedenen Stellen verwendet (Adresse der Mediendateien, interne Links, …) und muss in serialisierten Datenbankfelder ersetzt werden. Klingt komplizierter als es ist, aber du kannst mit dem Plugin Better Search Replace die alte URL mit http eintragen, die neue URL mit https, alle Datenbanktabellen auswählen und die Ersetzung starten. Vorher ein Backup der Datenbank anzulegen kann auch nicht schaden.
    • Wenn das alles erledigt ist, kannst du mit der Einrichtung einer Multisite fortfahren.
    Thread-Ersteller venemous

    (@venemous)

    Was ich getan habe:

    Das Multisite-Problem:

    – beim Hoster Subdomains angelegt mit en.domain.de bzw. es.domain.de
    – Die Subdomains bei der Netzwerkverwaltung in WordPress eingestellt (vorher hatte ich ja domain.de/english bzw. domain.de/espanol als Verzeichnisstruktur beim erstellen der Multisite eingerichtet – wo ich ja keinen Zugriff auf die jeweiligen Dashboards hatte)
    -> Es hat funktioniert. Plötzlich Zugriff auf alle Dashboards mit den Subdomains.

    Das http / https Problem:

    Leider war beim Installieren der WordPress-Installation das SSL Zertifikat nicht aktiv, daher wurde alles auf http installiert.
    – beim Hoster habe ich nun explizit eine Weiterleitung von http auf https eingerichtet
    – mithilfe des Plugin „Better Search Replace“ habe ich (nach dem Backup der Datenbank) eine Ersetzung von http://domain.de auf https://domain.de durchgeführt.
    Leider gab es hierbei folgende Fehlermeldung:

    Ein Fehler ist aufgetreten. Versuche entweder die „Max. Seiten-Anzahl“ zu verringern, oder wende dich an unseren Support.

    (der Testlauf der Plugin funktioneirte reibeunsglos)

    Trotzdem funktioniert jetzt scheinbar alles mit https und auch mit den Unterseiten.

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.
    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von venemous.
Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)