Support » Allgemeine Fragen » Multisite Registrierung deaktiviert

  • Hallo,
    ich habe ein neues WordPress (bei 1und1) aufgezogen und installiert. Ich möchte es als multisite betreiben. Leider unterstützt 1und1 keine wildcard subdomains, so dass ich alles händisch machen müsste (will trotzdem sub1.domain.de haben)
    Habe nach der Installation die wp-config und die .htaccess nach dem tutorial geändert. Wenn ich nun die Seite domain.de aufrufe, so kann ich nur den header sehen und die Seite sagt: „Die Registrierung wurde deaktiviert“
    Ich kann nichts weiter auf der Seite machen. Hat jemand eine Idee, was genau das Problem ist?

    Vielen Dank
    Christian

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo @chris1618 und willkommen im Forum,

    mit den wenigen Angaben müssten wir schon hellseherische Fähigkeiten haben, um nachvollziehen zu können, was du gemacht hast. Nach welchem Tutorial bist du denn vorgegangen? Was hast du geändert? Welchen Editor hast du genutzt? Kannst du dich noch im Backend anmelden?

    Poste doch mal den Inhalt der wp-config.php (Zugangsdaten bitte vorher löschen, hier im Forum [code]-Button zur Formatierung nutzen).

    Hallo und vielen Dank.
    Ich dachte, es wäre eine Standardprocedure. Ich gehe mal meine Schritte durch. Zum Edit der Datein benutze ich den TextEditor mit ASCI.
    Zuerst WordPress neu installiert.
    Dann wp-config define('WP_ALLOW_MULTISITE' true); eingefügt
    Anschließend im Backend die Netzwerkgeschichte nach dem Schema sub.domain.de konfiguriert/gespeichert
    Zu guter Letzt wp-config.php und .htaccess geändert, wie es wordpress sagte.
    wp-config.php

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define('DB_NAME', 'xxxx');
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define('DB_USER', 'xxxx');
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define('DB_PASSWORD', 'xxxx');
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define('DB_HOST', 'xxxx');
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define('DB_CHARSET', 'utf8mb4');
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'xx');
    define('SECURE_AUTH_KEY',  'xx');
    define('LOGGED_IN_KEY',    'xx');
    define('NONCE_KEY',        'xx');
    define('AUTH_SALT',        'xx');
    define('SECURE_AUTH_SALT', 'xx');
    define('LOGGED_IN_SALT',   'xx');
    define('NONCE_SALT',       'xx');
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix  = 'wp_1';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);
    /* Multisite */
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'www.guenther.top');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once(ABSPATH . 'wp-settings.php');
    

    .htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Wenn ich nun auf meine Seite gehe kommt nur die fehlermeldung Die Registrierung wurde deaktiviert; ein Anmelden auf der Seite ist nicht mehr möglich. Dabei bin ich strikt nach Anleitung vorgegangen…… weiss nicht mehr weiter

    Moderator Bego Mario Garde

    (@pixolin)

    Ich dachte, es wäre eine Standardprocedure.
    Wenn ich nicht von meiner „Standardprocedure“ ausgehen will, muss ich nachfragen. Häufig stellt sich heraus, dass dann bei „den üblichen Schritten“ etwas ausgelassen oder falsch verstanden worden ist – das scheint hier aber nicht der Fall zu sein, wp-config.php und .htaccess sehen erst einmal ziemlich normal aus.

    Hast du vor der Umstellung auf Multisite Plugins installiert? Welche?
    Wurden die vor der Umstellung deaktiviert?

    Schau auch mal in der Datenbank

    • in Tabelle wp_1blogs nach den eingetragenen Domains und
    • in Tabelle wp_1options nach siteurl und home
    chris1618

    (@chris1618)

    Ich habe direkt nach der WordPress installation auf Multisite umgestellt. Keine Pugins davor installiert.

    Ein Blick in die Datenbanken:
    wp_1blogs sagt http://www.domain.de

    wp_1options in beiden Einträgen domain.de (ohne www davor)

    Hat niemand mehr eine Idee? Ich kann mir das nicht erklären. Habe nochmal die Datenbank gelöscht und erneut alles installiert. Das Problem besteht wieder genau wie beschrieben…. ich bin mit meinem Latein am Ende

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)