Support » Allgemeine Fragen » Nach Update auf 5.8.2 funktioniert WP Cron nicht mehr

  • Gelöst Chigolo

    (@fitnsexy)


    Ich habe seit dem letzten Update vom 11.11.2021 leider Probleme mit dem WP Cron was dazu führt, dass ich weder Backups, noch geplante Aufgaben vollführen kann.

    Seither wird die Rest API auch als fehlerhaft erkannt. Hat jemand ähnliche Probleme? Habe den Fehler auf all meinen 7 WP-Seiten welche unabhängig voneinander installiert sind.

    Nachtrag:

    Ich habe soeben einmal nachgeforscht und im Healt Status folgende Info gefunden: https://gyazo.com/4c01470f58c18a0b3c916223ea223777.

    Entsprechend werden auch seit nunmehr 2 Tagen die geplanten Aufgaben per WP Cron nicht mehr korrekt durchgeführt, siehe: https://gyazo.com/776c3da170fde0e5f9c37f8609e29a79.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Hallo,
    wenn du dann direkt die URL oben einträgst, dann können wir uns das auch ansehen und dir sicher besser helfen. Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Deaktiviere mal Autoptimize und teste dann, ob das Problem behoben ist.

    Wenn das nicht hilft: Installiere bitte nach einer Sicherung das plugin Health Check & Troubleshooting. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass Besucher deine Webseite mit allen Infos und plugins sehen, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.

    Eine entsprechende Lösung ohne das Plugin Health Check wird hier beschrieben. In dem Fall lag das Problem offensichtlich beim Hoster (IONOS).

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Ergänzend zu den Hinweisen von Hans-Gerd: es gibt ein Plugin, mit dem du die Ausführung vin Cron-Jobs kontrollieren kannst: WP Crontrol

    Ich würde als erstes das Update unter Dashobard > Aktualisierungen nochmal durchlaufen lassen, vermute aber auch eher ein Problem bei der Serverkonfiguration.

    Thread-Starter Chigolo

    (@fitnsexy)

    Hallo @hage,
    hallo @pixolin

    ich habe bereits alle Plugins testweise deaktiviert und auch ein Standard Theme (tweny tweny-one) aktiviet, leider ohne Erfolg, der Fehler blieb bestehen. Auch das beschriebene WP Crontrol Plugin habe ich benutzt, hier werden mir über 20 nicht ausgeführte und geplante Aufgaben angezeigt.

    Es sind all meine WordPress Seiten davon betroffen, hier ein Beisoiel: https://www.bks-braun.de/.

    Zu guter Letzt hier noch der gewünschte Bericht (exakte Webadresse habe ich entsprechend anonymisiert):

    
    ### wp-core ###
    
    version: 5.8.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/xxx/html/bks-braun
    wordpress_size: 46,18 MB (48421169 bytes)
    uploads_path: /var/www/xxx/html/bks-braun/wp-content/uploads
    uploads_size: 0,00 B (0 bytes)
    themes_path: /var/www/xxx/html/bks-braun/wp-content/themes
    themes_size: 6,44 MB (6755643 bytes)
    plugins_path: /var/www/xxx/html/bks-braun/wp-content/plugins
    plugins_size: 239,02 kB (244752 bytes)
    database_size: 5,34 MB (5602785 bytes)
    total_size: 58,20 MB (61024349 bytes)
    
    ### wp-active-theme ###
    
    name: Astra (astra)
    version: 3.7.5
    author: Brainstorm Force
    author_website: https://wpastra.com/about/?utm_source=theme_preview&utm_medium=author_link&utm_campaign=astra_theme
    parent_theme: none
    theme_features: core-block-patterns, astra_hooks, widgets-block-editor, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, rank-math-breadcrumbs, amp, widgets, menus
    theme_path: /var/www/xxx/html/bks-braun/wp-content/themes/astra
    auto_update: Deaktiviert
    
    ### wp-plugins-active (26) ###
    
    All In One WP Security: version: 4.4.9, author: Tips and Tricks HQ, Peter Petreski, Ruhul, Ivy, Automatische Aktualisierungen deaktiviert
    Astra Pro: version: 3.6.3, author: Brainstorm Force, Automatische Aktualisierungen deaktiviert
    Astra Widgets: version: 1.2.9, author: Brainstorm Force, Automatische Aktualisierungen deaktiviert
    Async JavaScript: version: 2.21.08.31, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Autoptimize: version: 2.9.2, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    BackWPup: version: 3.10.0, author: Inpsyde GmbH, Automatische Aktualisierungen deaktiviert
    Cookiebot | GDPR/CCPA Compliant Cookie Consent and Control: version: 3.11.1, author: Cybot A/S, Automatische Aktualisierungen deaktiviert
    Disable Comments: version: 2.2.4, author: WPDeveloper, Automatische Aktualisierungen deaktiviert
    EditorsKit: version: 1.31.9, author: Extendify, Automatische Aktualisierungen deaktiviert
    EWWW Image Optimizer: version: 6.3.0, author: Exactly WWW, Automatische Aktualisierungen deaktiviert
    Koko Analytics: version: 1.0.28, author: ibericode, Automatische Aktualisierungen deaktiviert
    Login Logo: version: 0.10.0, author: Mark Jaquith, Automatische Aktualisierungen deaktiviert
    Maintenance: version: 4.03, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    Mihdan: Index Now: version: 1.2.0.2, author: Mikhail Kobzarev, Automatische Aktualisierungen deaktiviert
    Page scroll to id: version: 1.7.4, author: malihu, Automatische Aktualisierungen deaktiviert
    Rank Math SEO: version: 1.0.76.1, author: Rank Math, Automatische Aktualisierungen deaktiviert
    Scripts-To-Footer: version: 0.6.4.1, author: Joshua David Nelson, Automatische Aktualisierungen deaktiviert
    Server IP & Memory Usage Display: version: 2.1.0, author: Apasionados, Apasionados del Marketing, Automatische Aktualisierungen deaktiviert
    Starter Templates: version: 2.7.5, author: Brainstorm Force, Automatische Aktualisierungen deaktiviert
    Stealth Login Page: version: 4.0.0, author: Jesse Petersen, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.63, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WP-Optimize - Clean, Compress, Cache: version: 3.1.12, author: David Anderson, Ruhani Rabin, Team Updraft, Automatische Aktualisierungen deaktiviert
    WP External Links: version: 2.50, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    WP Fastest Cache: version: 0.9.5, author: Emre Vona, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.7.1.1, author: WPForms, Automatische Aktualisierungen deaktiviert
    Yoast Duplicate Post: version: 4.1.2, author: Enrico Battocchi & Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: EWWWIO_Imagick_Editor
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-12-29 http://www.imagemagick.org
    imagick_version: 3.4.3
    file_uploads: File uploads is turned off
    post_max_size: 152M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.18-30-pve x86_64
    httpd_software: Apache
    php_version: 7.4.3 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 120
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 152M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.25
    client_version: mysqlnd 7.4.3
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/xxx/bks-braun/wp-content
    WP_PLUGIN_DIR: /var/www/xxx/bks-braun/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### wpforms ###
    
    version: 1.7.1.1
    lite: Mai 17, 2021 @ 3:46am
    upload_dir: Beschreibbar
    db_tables: s7iZ_wpforms_tasks_meta
    total_forms: 1
    total_submissions: 3
    
    

    Eine erneute Aktualsiierung auf 5.8.2 habe ich manuell angestoßen, ebenfals ohne Erfolg.
    Danke für eure Hilfe!

    • Diese Antwort wurde geändert vor 10 Monaten, 3 Wochen von Chigolo.

    Hallo,
    Schau mal bitte in die error.log beim Hoster, ob da Einträge sind und ob das Problem zu einem bestimmten Zeitpunkt entstanden ist. Prüfe doch dann bitte, was du davor gemacht hast (Plugin, Theme aktualisiert, etc.).
    Evtl. ist es auch sinnvoll, wenn du debug aktivierst. Wie du das machen kannst, habe ich in meinem Beitrag Debug-Modus auf WordPress-Seiten mit und ohne Plugins erklärt.
    Viele Grüße
    Hans-Gerd

    Auch das beschriebene WP Crontrol Plugin habe ich benutzt, hier werden mir über 20 nicht ausgeführte und geplante Aufgaben angezeigt.

    Damit weißt du zunächst nur, dass etwas nicht stimmt. Du weißt aber noch nicht, wo das Problem liegt.

    Kleiner Exkurs zum Theme Cronjobs in WordPress: Aus Kapazitätsgründen bietet nicht jeder Webhoster seinen Kunden die Einrichtung von Cron-Jobs an. (Teilen sich 200 Nutzer einen Server und richten sich davon 189 Nutzer einen Cronjob ein, der alle 5 Minuten läuft, ist der Server entsprechend hoch ausgelastet und stellt nicht mehr genug Kapazität zur Auslieferung der Webseiten zur Verfügung.) Um trotzdem zeitgesteuert z.B. Backups ausführen zu können, nutzt WordPress eine „Pseudo-Cron“ genannte Routine: Bei jedem Besuch einer Webseite prüft WordPress, ob ein Zeitpunkt bereits überschritten wurde, zu dem eine Aufgabe ausgeführt werden sollte. Gibt es keine Besucher, wird diese Abfrage auch nicht ausgeführt, was begründen könnte, wieso dir nicht ausgeführte Jobs angezeigt werden. Auch ein Cache-Plugin kann hier eine Rolle spielen, weil bei einem Webseitenbesuch nicht die Abfragen erneut ausgeführt werden, sondern auf zwischengespeicherte HTML-Dateien zurückgegriffen wird.

    Da wir wohl eine fehlerhafte Übertragung von WordPress durch ein erneutes Update ausschließen können und Programmierfehler in Themes und Plugins auch unwahrscheinlicher sind, würde ich versuchen, den „Pseudo-Cron“ von WordPress zu deaktivieren und statt dessen einen richtigen Cron-Job einzurichten. Dazu sind folgende Schritte notwendig:

    1. Du fügst in der wp-config.php mit einem geeigneten Code-Editor (oder dem Online-Editor https://vscode.dev/) folgende Zeile ein:

      define('DISABLE_WP_CRON', true);

    2. Du erstellst bei deinem Webhoster einen Cron-Job, der zweimal pro Stunde folgenden Befehl ausführt:

      wget -q -O - https://example.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1
      (natürlich mit deiner Domain).

    Wenn dein Webhoster keine Cron-Jobs erlaubt (die Gründe habe ich weiter oben beschrieben), kannst du dich auch bei einem kostenlosen Anbieter anmelden und dort einen Cron-Job angelegen. Google liefert dir zum Suchbegriff „free cron job“ diverse Treffer.

    Schau mal, ob sich damit die Fehler beheben oder zumindest deutlich reduzieren lassen.

    Thread-Starter Chigolo

    (@fitnsexy)

    Danke für euer Feedback.

    Wie bereits beschrieben denke ich auch, dass der Fehler anderweitig liegen muss, denn Update, Plugins usw. können ausgeschlossen werden. Was mich allerdings stutzig macht ist, dass der Fehler erst seit dem Update auf 5.8.2 aufgetreten ist … Hat sich bei WP hier etwas verändert?

    Derzeitig warte ich noch auf Rückmeldung von meinem Hoster, etwaig ist ja etwas mit der IP geblockt worden oder ähnliches. Cronjobs kann ich übrigens noch zu genüge einrichten, d. h. daran sollte es dann nicht scheitern fals ich auf eine externe Lösung zurückgreifen muss. Extern wäre dann die letzte Möglichkeit quasi.

    Ich habe uner WP Crontrol auch Aufträge die wohl alle paar Minuten ausgeführt werden sollten, würde es dann dennoch genügen diese alle 30 min. ausführen zuz lassen?

    Hat das irgendwelche Auswirkungen auf den Pagespeed oder ist das generell besser als der in WP integriete Cronjob?

    Es ist geringfügig performanter, den Pseudo-Cron zu deaktivieren und stattdessen auf dem Server ein Cron-Job einzurichten. Ob du nun alle paar Minuten Cron-Jobs ausführen musst, hängt wohl auch mit der Intensivität der Nutzung zusammen – bei einem großen Online-Magazin, dass minütlich neu berichtet und tausende Besucher am Tag hat, sieht das anders aus, als bei einer kleinen Unternehmens-Präsenz mit vielleicht 80 Seitenabrufen am Tag.

    Thread-Starter Chigolo

    (@fitnsexy)

    Danke @pixolin für den Link.

    Mal eine Frage: Wie oft führt den WordPress von Haus aus seinen eigenen Cronjob durch?

    Um ein derartiges Magazin handelt es sich bei den Seiten natürlich nicht, ich denke aber es wäre dennoch besser entsprechend nicht alle Seiten gleichzeitig jeweils alle 30 Minunten den Cronjob ausführen zu lassen sondern im Abstand von 3-4 Minuten (insgesamt 7 Webseiten). Oder was meinst du dazu?

    Wenn du einen eigenen Cron-Job anlegst, hat das mit der Anzahl der Seiten und Beiträge nichts zu tun. WordPress prüft zweimal am Tag, ob Updates vorliegen, führt aber ggf. öfter Zeitplöne durch, um z.B. Backups anzulegen oder auch noch nicht veröffentlichte Beiträge und Seiten zu einer bestimmten Uhrzeit zu veröffentlichen. Eigentlich sollte es reichen, wenn du alle halbe Stunde wp-cron.php aufrufst.

    Thread-Starter Chigolo

    (@fitnsexy)

    Verstehe, mir gehts es nur um die Webseiten. Also nicht EINE Webseite hat 7 Unterseiten, sondern es geht um 7 Webseiten mit jeweils eigener Domain. Deshalb meine Frage ob diese alle zur selben Zeit immer abgerufen werden oder ich hier zwischen den unterschiedlichen Domains ein paar Minuten Pause haben sollte um nicht 7 Cronjobs gleichzeitig auführen zu müssen.

    Dachte nur, dass eben auch Cache Plugins usw. öfters Dinge abrufen, da wollte ich lieber auf Nummer sicher gehen. Derzeit warte ich noch auf Rückmneldung vom Hoster und werde dann gerne darüber berichten und gegebenfalls den eigenen Cronjob für die jeweiligen DSomains einrichten.

    … es geht um 7 Webseiten mit jeweils eigener Domain

    Ich habe mir angewöhnt, im Abgrenzung zu Webseiten („Impressum“, „Über mich“, …) Internet-Präsenzen mit eigener Domain als Websites zu bezeichnen.

    ein paar Minuten Pause … um nicht 7 Cronjobs gleichzeitig auführen zu müssen.

    Wenn du überlegst, wieviel Prozesse CPUs parallel verarbeiten, dürfte der Abruf von 7 Cron-Jobs nicht ins Gewicht fallen. Aber es spricht auch nichts dagegen, das zeitlich zu versetzen. Website 1 um :01, Website um :02 usw.

    Thread-Starter Chigolo

    (@fitnsexy)

    Danke dir @pixolin .Werde dich/euch auf dem Laufenden halten.

    Thread-Starter Chigolo

    (@fitnsexy)

    Entwarnung, es geht wieder alles. Hier die Info meines Hosters:

    Zitat: „hre IP wurde serverseitig versehentlich gesperrt, da diese während eines Angriffs ebenfalls dazwischen zugegriffen hat.“

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Nach Update auf 5.8.2 funktioniert WP Cron nicht mehr“ ist für neue Antworten geschlossen.