Support » Allgemeine Fragen » Nach Änderung von Sub auf Haupt Domain Zertifikatsfehler

  • Hallo zusammen,

    ich hoffe hier ein wenig Hilfe für mein Problem mit WordPress zu finden.
    Ich habe eine Webseite aufgebaut auf der aktuellsten WP Version unter einer Subdomain: webseite.holica.de. Dort lief alles gut und konnte mein gekauftes Template aktivieren etc.
    Nach Umzug auf die Hauptdomain: http://www.holica.de war alles in Ordnung bis ich festgestellt hatte, dass mein Template nicht wieder aktivierbar war und wenn ich es probiere dann diese Fehlermeldung erscheint:

    cURL error 60: SSL certificate problem: unable to get local issuer certificate

    Die Subdomain sowie die Hauptdomain haben beide ein SSL Zertifikat, nur leidder trotz recherche kann ich mit dem Fehler nichts anfangen…

    Wäre es möglich hier Hilfe zu erhalten? Und welche Daten soll ich breitstellen? 🙂

    Liebe Grüße,
    Tim

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Wenn du deine Website mit https://sitecheck.sucuri.net/ testest, erhältst du einige Fehler im Zusammenhang mit Mixed Content. Ob das Problem damit behoben ist, kann ich nicht sicher sagen.
    Mixed Content bedeutet, dass eine Website, die verschlüsselt über HTTPS aufgerufen wird, Inhalte teilweise unverschlüsselt über HTTP ausliefert.
    Mixed Content kann mit dem Plugin „Better Search and Replace“ korrigiert werden. Einträge in der Datenbank http://example.com werden dann ersetzt durch https://example.com (example.com musst du natürlich durch deine domain ersetzen). Vorher bitte eine Sicherung erstellen.

    Viele Grüße
    Hans-Gerd

    Scheint jetzt zu klappen? Zumindest wird mir die Website mit gesicherter Übertragung angezeigt.

    @pixolin
    Nein, der Fehler mit mixed content besteht weiterhin. 🤷‍♂️

    Im Shop bekomme ich einen JavaScript-Fehler, aber sonst kann ich das nicht reproduzieren.

    Thread-Starter holica

    (@holica)

    Hallo zusammen und vielen dank für die Hilfe bis jetzt 🙂

    Also ich habe das ganze einmal mit dem Plugin gemacht und dort dann http://webseite.holica.de durch https://holica.de ersetzt. Dort hat er dann 48 Einträge gefunden, aber soweit hat sich auf der Sitecheck Seite nichts geändert.

    Zum Problem selbst, denke ich nicht das der Mixed Content das Problem ist, da der cURL Error erst kommt wenn ich das Template Aktivieren möchte welches ich mir gekauft habe. Bei der Nutzung von WordPress selbst scheint es keine Probleme zu geben nur halt gefühlt das die Installation nicht raustelefonieren kann um zu Überprüfen das mein Kauf-Code für das Template auch richtig ist. Aber dennoch schonmal danke mich auf die Spur zu bringen, falsche Link umzuändern, darüber bin ich gar nicht gestolpert danke 🙂

    Anbei nochmal der Website Zustandsbericht:

    
    ### wp-core ###
    
    version: 6.0.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www/htdocs/w0135cb2/Webseite
    wordpress_size: 53,39 MB (55982791 bytes)
    uploads_path: /www/htdocs/w0135cb2/Webseite/wp-content/uploads
    uploads_size: 327,77 MB (343691559 bytes)
    themes_path: /www/htdocs/w0135cb2/Webseite/wp-content/themes
    themes_size: 20,70 MB (21710423 bytes)
    plugins_path: /www/htdocs/w0135cb2/Webseite/wp-content/plugins
    plugins_size: 84,67 MB (88777966 bytes)
    database_size: 6,12 MB (6415691 bytes)
    total_size: 492,65 MB (516578430 bytes)
    
    ### wp-active-theme ###
    
    name: Necromancers (necromancers)
    version: 1.2.1
    author: Dan Fisher
    author_website: https://dan-fisher.dev
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, automatic-feed-links, title-tag, menus, html5, customize-selective-refresh-widgets, custom-logo, sportspress, woocommerce, widgets
    theme_path: /www/htdocs/w0135cb2/Webseite/wp-content/themes/necromancers
    
    ### wp-plugins-active (24) ###
    
    Advanced Custom Fields: SVG Icon: version: 2.0.4, author: BE API Technical team, Automatische Aktualisierungen deaktiviert
    Advanced Custom Fields PRO: version: 5.12.2, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Advanced Editor Tools (previously TinyMCE Advanced): version: 5.6.0, author: Automattic, Automatische Aktualisierungen deaktiviert
    Arqam: version: 2.0.4, author: TieLabs, Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.4.1, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Cherry Live Demo Mods Switcher: version: 1.1, author: Cherry Team, Automatische Aktualisierungen deaktiviert
    Code Snippets: version: 3.2.0, author: Code Snippets Pro, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.6.2, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Cool Timeline: version: 2.4.4, author: Cool Plugins, Automatische Aktualisierungen deaktiviert
    Duplicate Page: version: 4.4.9, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Favicon by RealFaviconGenerator: version: 1.3.25, author: Philippe Bernard, Automatische Aktualisierungen deaktiviert
    Kirki Customizer Framework: version: 4.0.24, author: David Vongries, Automatische Aktualisierungen deaktiviert
    Loco Translate: version: 2.6.2, author: Tim Whitlock, Automatische Aktualisierungen deaktiviert
    Necromancers Assistant: version: 1.0.2, author: Dan Fisher, Automatische Aktualisierungen deaktiviert
    Necromancers Blocks: version: 1.1.1, author: Dan Fisher, Automatische Aktualisierungen deaktiviert
    Necromancers eSports for SportsPress: version: 1.0.1, author: Dan Fisher, Automatische Aktualisierungen deaktiviert
    One Click Demo Import: version: 3.1.2, author: OCDI, Automatische Aktualisierungen deaktiviert
    Site Kit by Google: version: 1.81.0, author: Google, Automatische Aktualisierungen deaktiviert
    SportsPress: version: 2.7.15, author: ThemeBoy, Automatische Aktualisierungen deaktiviert
    Timeline Block: version: 1.2.2, author: Cool Plugins, Automatische Aktualisierungen deaktiviert
    WooCommerce: version: 6.8.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    WooCommerce Product Details Customiser: version: 0.2.0, author: jameskoster, Automatische Aktualisierungen deaktiviert
    Woo Shortcodes Kit: version: 2.0.2, author: Alberto G., Automatische Aktualisierungen deaktiviert
    WPFront Scroll Top: version: 2.0.7.08086, author: Syam Mohan, Automatische Aktualisierungen deaktiviert
    
    ### code-snippets (4) ###
    
    snippet-1: name: Ändere Upload-Dateinamen in Kleinbuchstaben, scope: global, modified: 2022-08-24 23:47:43, tags: [sample, media]
    snippet-2: name: Admin-Leiste deaktivieren , scope: front-end, modified: 2022-08-24 23:47:43, tags: [sample, admin-bar]
    snippet-3: name: Smileys zulassen, scope: global, modified: 2022-08-24 23:47:43, tags: [sample]
    snippet-4: name: Aktuelles Jahr, scope: content, modified: 2022-08-24 23:47:43, tags: [sample, dates]
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_version: 3.4.4
    file_uploads: File uploads is turned off
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 1.84467440737E+19
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 8
    imagemagick_file_formats: 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JBG, JBIG, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-191-generic x86_64
    httpd_software: Apache
    php_version: 7.4.30 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 3000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.37-nmm1-log
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 67108864
    max_connections: 500
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /www/htdocs/w0135cb2/Webseite/wp-content
    WP_PLUGIN_DIR: /www/htdocs/w0135cb2/Webseite/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### google-site-kit ###
    
    version: 1.81.0
    php_version: 7.4.30
    wp_version: 6.0.1
    reference_url: https://www.holica.de
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    verification_status: verified-file
    connected_user_count: 1
    active_modules: site-verification, search-console, adsense, analytics, analytics-4, pagespeed-insights
    recoverable_modules: none
    required_scopes: 
    	openid: ✅
    	https://www.googleapis.com/auth/userinfo.profile: ✅
    	https://www.googleapis.com/auth/userinfo.email: ✅
    	https://www.googleapis.com/auth/siteverification: ✅
    	https://www.googleapis.com/auth/webmasters: ✅
    	https://www.googleapis.com/auth/adsense.readonly: ✅
    	https://www.googleapis.com/auth/analytics.readonly: ✅
    capabilities: 
    	googlesitekit_authenticate: ✅
    	googlesitekit_setup: ✅
    	googlesitekit_view_posts_insights: ✅
    	googlesitekit_view_dashboard: ✅
    	googlesitekit_manage_options: ✅
    	googlesitekit_view_splash: ✅
    	googlesitekit_view_authenticated_dashboard: ✅
    	googlesitekit_view_wp_dashboard_widget: ✅
    	googlesitekit_view_admin_bar_menu: ✅
    enabled_features: 
    	adsenseSetupV2: ✅
    	dashboardSharing: ⭕
    	ga4ActivationBanner: ⭕
    	ideaHubModule: ⭕
    	twgModule: ⭕
    	userInput: ⭕
    	zeroDataStates: ✅
    search_console_property: https://www.holica.de/
    adsense_account_id: pub-612•••••••••••••
    adsense_client_id: ca-pub-612•••••••••••••
    adsense_account_status: client-getting-ready
    adsense_site_status: none
    adsense_use_snippet: yes
    adsense_web_stories_adunit_id: none
    analytics_account_id: 2363•••••
    analytics_property_id: UA-2363•••••••
    analytics_profile_id: 2723•••••
    analytics_use_snippet: yes
    analytics_4_property_id: 3256659••
    analytics_4_web_data_stream_id: 3876••••••
    analytics_4_measurement_id: G-PL••••••••
    analytics_4_use_snippet: yes
    
    
    Michi91

    (@michi91)

    Dann haben wir dich bisher falsch verstanden gehabt 😀

    Das Problem liegt im Theme oder im Webserver (deinem oder dem des Herstellers…) und sehr wahrscheinlich nicht an WordPress. Das ganze hat nichts mit der HTTPS Verschlüsselung deiner Seite zu tun.

    Da du fürs Theme bezahlt hast, denke ich der Weg über den Support des Theme Herstellers ist der richtigste.

    • Diese Antwort wurde geändert vor 1 Monat von Michi91.
    Thread-Starter holica

    (@holica)

    Hallo zusammen,

    ja ich dachte ich frage zuerst hier nach, da laut recherche im Internet der cURL auch bei anderen Dingen auftauchen kann und nicht unbedingt Template basiert sein muss.

    Aber sonst versuche ich einmal den Hersteller zu kontaktieren und melde mich sonst einmal zurück 🙂 vielen dank!

    Thread-Starter holica

    (@holica)

    Hallo zusammen,

    also ich habe jetzt mit meinem Provider (All-Inkl) sowie dem Hersteller des Templates gesprochen. Beide sagen mir das sie mir nicht helfen können und nicht wissen was der Fehler sei.

    Ich selbst bin jetzt soweit, dass ich denke das der Fehler sein müsste, dass von der subdomain noch das Zertifikat eingetragen ist. Die Seite selbst läuft ja jetzt auf der Hauptdomain. Gibt es irgendwie einen weg das alte Zertifikat sozusagen zu löschen und ein neues drüber zu installieren?

    Liebe Grüße,
    Tim 🙂

    Gibt es irgendwie einen weg das alte Zertifikat sozusagen zu löschen und ein neues drüber zu installieren?

    Das sollte gehen, aber auch da ist dein Provider der richtige Ansprechpartner, das hat nichts mit WordPress zu tun.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)