Support » Allgemeine Fragen » Nach Aktualisierung zu 4.5 kein Bearbeitungsmodus mehr

  • Gelöst simsaladine

    (@simsaladine)


    Nachdem ich eben zur neuesten WordPress-Version aktualisiert habe, kann ich meine Startseite (ich habe eine One-Page) nicht mehr bearbeiten. Es wird mir nicht einmal mehr der Inhalt angezeigt. Was kann ich tun? Gibt es eine Möglichkeit, wieder auf die die alte Version zu wechseln?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 26)
  • Das sind sehr wenig Informationen; deshalb fällt es mir etwas schwer, dir zu helfen. Vielleicht magst du uns etwas mehr Informationen geben?

    • Welche PHP-Version verwendest du?
    • Kann man sich die Website anschauen? Wo? (URL)
    • Welches Theme verwendest du?
    • Welche Plugins verwendest du?
    • Sind Cache-Plugins im Einsatz?
    • Hast du versucht, die Installation erneut auszuführen?
    • Klappt die Eingabe, wenn du auf ein Standard-Theme (Twenty …) wechselst?

    Die neue WordPress-Version enthält eine weniger fehlertolerante Version von jQuery, die bei Fehlern im Theme schneller „aussteigt“ und Funktionen nicht richtig darstellt. Das kann ein Fehler sein. Dazu müssten wir aber wissen, welches Theme du verwendest.

    Thread-Ersteller simsaladine

    (@simsaladine)

    Ich verwende PHP5. Die Website ist noch nicht online bzw. habe ich ein Plugin benutzt, um sie noch nicht öffentlich zu machen, kann sie aber vorübergehend online stellen, wenn notwendig.

    Ich verwende das Theme Patti. Und folgende Plugins: Akismet, Category Order and Taxonomy Terms Order, Contact Form 7, Delicious Shortcodes, Envato WordPress Toolkit, Revolution Slider,
    SI CAPTCHA Anti-Spam, SMK Sidebar Generator,
    Templatera, Ultimate Addons for Visual Composer, WPBakery Visual Composer und Under Construction WP.

    Bei Verwendung eines anderen Themes klappt die Eingabe auch nicht. Ich sehe auch ebenso wie bei Patti meinen Content nicht. Neuinstallation habe ich noch nicht versucht 🙁

    Moderator PraetorIM

    (@praetorim)

    Zu Patti wurde vor 2 Tagen ein Update veröffentlicht, das zu WP 4.5 kompatibel sein soll. Ist das die Version, die Du einsetzt?

    Das Theme benutzt einiges an Javascript. Gut möglich, dass da bei älteren Versionen ein Problem mit der bei WP 4.5 aktualisierten jQuery-Version besteht.

    Thread-Ersteller simsaladine

    (@simsaladine)

    *PHP 5.6.19
    ist die Version

    Thread-Ersteller simsaladine

    (@simsaladine)

    Ich nutze die Patti Version 2.2.2
    Weiß nicht, ob das die aktuellste ist

    Thread-Ersteller simsaladine

    (@simsaladine)

    Aber auch bei Verwendung eines anderen Themes funktionieren die Seitenbearbeitungen nicht. Wenn ich mir die Website anschaue, ist alles, wie vorher. Nichts zerschossen oder ähnliches. Aber ich komme nicht mehr an die Inhalte heran, um sie zu bearbeiten.

    Gibt es eine Möglichkeit, die ältere Version von WP wieder zu verwenden?

    Ich nutze die Patti Version 2.2.2
    Weiß nicht, ob das die aktuellste ist

    Die aktuelle Version ist die 2.6.1 vom 16. April. Deine Version war also, genau genommen, schon am 06. Oktober letzten Jahres nicht mehr aktuell. 😉
    Hier das Changelog deines Themes (unten auf der Seite).
    Also nach vorherigem Backup auf jeden Fall mal das Theme updaten, selbst wenn, wie du sagst, das Problem auch durch einen Theme-Wechsel noch nicht behoben ist. Bei WordPress ein Downgrade durchzuführen ist dagegen keine so gute Idee.

    Ich sehe den Vorschlag oben noch nicht: Hast du vorübergehend mal alle Plugins deaktiviert und es nochmal probiert? Falls es dann klappen sollte, die Plugins einzeln wieder aktivieren und jeweils wieder testen, um den Verursacher herauszufinden.

    Thread-Ersteller simsaladine

    (@simsaladine)

    Ich habe alle Plugins deaktiviert und es funktioniert trotzdem nicht. Ich bin wirklich ratlos… Ich verstehe nicht, warum ich den Inhalt nicht sehen kann. Er ist ja da, wenn ich auf Seitenvorschau gehe. Aber bei keinem Theme (alle anderen habe ich aktualisiert) sehe ich meinen Inhalt.

    Hast du mal versucht, WordPress nochmal zu aktualisieren?
    Dashboard > Aktualisierung > WordPress erneut installieren
    (wobei ohnehin gerade eine neue Version erschienen ist).

    Thread-Ersteller simsaladine

    (@simsaladine)

    @ Bego Mario Garde: Gerade geschehen. Leider auch das ohne Erfolg…

    Verstehe ich das richtig: Wenn du deinen Cursor in den Editor setzt und dann STRG + A (alles markieren) drückst, wird der Text sichtbar (Text ist also weiß)?

    Falls ja, dann gib mal testweise in der wp-config.php folgenden Code ein:

    define('CONCATENATE_SCRIPTS', false);

    Das scheint bei vielen Betroffenen zu helfen, wobei nirgends eindeutig klar wird, wieso das nötig ist, bis auf unterschiedliche Theorien (eine umfangreiche Google-Suche wird da vermutlich letztendlich eine Klärung bringen). Bei Nichterfolg bitte wieder löschen.

    Weiterer Lösungsansatz:
    Kopiere aus einem frisch heruntergeladenen WordPress den Ordner wp-includes/js/tinymce und ersetze damit den bestehenden tinymce-Ordner, den du vorher in tinymce-old umbenannt hast.

    Und – als einfachste Maßnahme – natürlich ein Löschen des Browser-Caches nicht vergessen!

    Quellen:
    (1)
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-white-text-and-missing-buttons-in-wordpress-visual-editor/
    (2)
    http://stackoverflow.com/questions/32996217/forced-to-use-defineconcatenate-scripts-false-all-of-a-sudden

    Thread-Ersteller simsaladine

    (@simsaladine)

    Nein, der Text ist nicht weiß. Alle Textfelder, Inhaltselemente wie Bilder, Fortschrittsbalken, Titel etc. sind nicht da. Ich sehe nur, dass ich einen Revolution Slider drinnen habe.

    Vor dem Update hatte ich dort einzelne Felder, die ich mit verschiedenen Elementen wie Text, Bildern, Buttons etc. „befüllen“ konnte. Ich konnte Space-Elemente einfügen und z.B. das Zeilenlayout ändern…. Dieses gesamte System ist nun futsch. Ich sehe all das nicht mehr. Wenn ich in den Backend Editor gehe, ist der Quelltext (?) ganz normal, wie mir scheint in schwarz zu sehen.

    Kann es sein, dass beim Update ein Plugin oder irgendetwas in der Art verloren gegangen ist, was dieses „Baukastensystem“ zerschossen hat?

    Und wie gesagt, auch bei einem aktuellen Standardtheme (neueste Version) funktioniert es nicht… Ich bin ratlos

    Ich persönlich kann mir durch all die im Verlauf des Threads von dir genannten Bruchstücke, ehrlich gesagt, mittlerweile kein Bild mehr vor meinem geistigen Auge machen, wie es jetzt bei dir im Backend aussieht und was genau im Einzelnen die Probleme sind. Vermutlich auch im Sinne der mithelfenden Profis: Screenshots oder nochmal eine präzise Zusammenfassung wären vielleicht keine schlechte Idee…

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 26)
  • Das Thema „Nach Aktualisierung zu 4.5 kein Bearbeitungsmodus mehr“ ist für neue Antworten geschlossen.