Support » Allgemeine Fragen » Nach Eingabe URL unter „Einstellungen“ > „WordPress-Adresse (URL)“ zerschossen

  • Gelöst itdoku

    (@itdoku)


    Hallo Forum,

    ich habe mich gerade neu hier anmeldet, weil ich einen Bug festgestellt habe im System. Vielleicht hat ja auch jemand eine Idee, wie ich den Fehler wieder beheben kann? Das System ist local bei mir im Netzwerk

    Also folgendes habe ich gemacht:

    Im Backend unter „Einstellungen“ > „WordPress-Adresse (URL)“ habe ich eine andere Seite (mit der ID 17) von mir eingetragen. Danach ist alles sehr chaotisch. Ich habe in riesiger Form diese 3 horizontalen Streifen (Hyperlinks), ein X, eine Lupe und meine Texte ohne Formatierungen und alles von nach unten und nicht wie vorher in strukturierter Form.

    Dummerweise habe ich den Fehler bereits zum zweiten Mal gemacht 🙂 Beim zweiten Mal dahcte ich mir, sicherst du einfach alles ab und bei einem Fehler schiebst du alles wieder hoch. Komischerweise geht das auch nicht, was ich nicht verstehe. Auch ein komplettes Löschen und danach hochlanden des Backups, funtkioniert auch nicht. Auf dieser Datenbank-Reperatur-Vorgang bringt nix. Für mich sieht das im ersten Moment so aus, als wären die css-Dateien kaputt. Spätestens nach Einspielen des Backups sollte es doch gehen..

    • Dieses Thema wurde geändert vor 5 Jahren, 7 Monaten von itdoku.
    • Dieses Thema wurde geändert vor 5 Jahren, 7 Monaten von itdoku.
    • Dieses Thema wurde geändert vor 5 Jahren, 7 Monaten von itdoku.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hallo @itdoku und willkommen im Forum,

    der Bug sitzt in diesem Fall vor dem Monitor. 😉

    Die WordPress-URL gibt einzig und alleine an, wo deine WordPress-Dateien liegen. Wenn du hier einen Link zu einem Beitrag eingibst, sucht WordPress z.B. unter dieser URL nach dem Theme – deshalb sieht das jetzt alles „ein bisschen komisch“ aus. Also: Finger weg davon. Kein drittes Mal machen.

    Wie du das wieder rückgängig machen kannst, haben wir hier im Forum schon mehrfach besprochen. Wenn du keine Lust hast, lange zu suchen, findest du eine Anleitung von mir auch hier: https://pixolin.de/alte-wordpress-installation-manuell-aktualisieren/

    Thread-Starter itdoku

    (@itdoku)

    Vielen Dank für deine Hilfe und den Link. Ich wußte nicht, wonach ich suchen sollte bzw. konnte ich es nicht direkt finden, sorry 🙂

    Ok – das ganze hat was Gutes:

    Ich hatte noch nicht so viel gemacht bisher nur paar leere Seiten anlegt und ein Logo. In diesem Fall ist es daher eher weniger tragisch. So weiß ich auch, was ich beim Backup machen mir berücksichtigen muss: die Db 🙂 Jetzt macht das ganze auch Sinn…

    Ich habe das nach deiner sehr herrvoragend geschriebenen Anleitung gemacht. Das System läuft jetzt wieder, aber meine Inhalte die ich zuvor angelegt habe, sind weg. Sobald ich wieder meinen SQL-Datenbankexport hochlade, dann ist alles wieder zerhockt. Also ist es ein Datenbank-Fehler.

    Was ich auch nicht verstehe ist, wenn es eine bekannter Fehler ist, warum wird das nicht abgefangen? Rhetorische Frage 🙂

    Erstmal vielen Dank. Habe was elematares gelernt 🙂

    • Diese Antwort wurde geändert vor 5 Jahren, 7 Monaten von itdoku.

    Das System läuft jetzt wieder, aber meine Inhalte die ich zuvor angelegt habe, sind weg.

    Kannst du das etwas genauer beschreiben?
    In meiner Anleitung steht ja eigentlich nur, dass du Änderungen in wp_options vornimmst – nicht, dass du die Datenbank austauschst.

    Allerdings kann es sein, dass WordPress im Moment die Permalinks durcheinanderbringt. Dann wäre es bereits ausreichend, wenn du das Menü Permalinks nochmal aufrufst – die gewünschte Permalinkstruktur wird bereits beim Aufruf des Menüs von WordPress neu eingelesen.

    Was ich auch nicht verstehe ist, wenn es eine bekannter Fehler ist, warum wird das nicht abgefangen? Rhetorische Frage 🙂

    Es ist (mir) bekannt, dass Anwender gerne an den Einstellungen „etwas unbedarft rumfummeln“ und wir könnten sicher mal ein Bug-Ticket schreiben, dass diese Felder eine zusätzliche Erklärung benötigen.
    Eigentlich sind sie aber dazu gedacht, die absoluten Pfade für die Website und die WordPress-Dateien vorzugeben. Die Verwendung absoluter Pfade ist, wenn ich es richtig in Erinnerung habe, besser für die Suchmaschinenoptimierung und die Unterscheidung zwischen Site- und WordPress-URL hat damit zu tun, dass du WordPress in einem eigenen Verzeichnis (neben weiteren Webanwendungen) installieren, die Website aber trotzdem ohne Angabe des Verzeichnisses im Browser aufrufen kannst.

    • Diese Antwort wurde geändert vor 5 Jahren, 7 Monaten von Bego Mario Garde. Grund: Nachtrag
    Thread-Starter itdoku

    (@itdoku)

    Es hatte im ersten Moment nichts gebracht. Ich habe meine Datenbank gelöscht und habe die Installation erneut gestartet. Es war so, also würde man quasi eine Neuinstallation machen. Vermutlich habe ich hier irgendwas in der Eile übersehen.

    Wie gesagt, ist in diesem Fall nicht Lebensnotwenig, daher wollte ich jetzt keine weitere Zeit mehr in die Fehlerbehebung investieren. Ich habe vor, mich etwas intensiver mit der Thematik zu beschäftigen. Daher bin ich gerade am Testen und Ausprobieren. Alles gut 🙂 Vielen Dank soweit.

    Kenn ich. 😀

    Ich markiere den Thread dann rasch als „gelöst“. Wenn wieder Fragen sind, einfach neuen Thread starten …

    Thread-Starter itdoku

    (@itdoku)

    Alles klar. Danke 🙂

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „Nach Eingabe URL unter „Einstellungen“ > „WordPress-Adresse (URL)“ zerschossen“ ist für neue Antworten geschlossen.