Support » Allgemeine Fragen » Nach Installation wird keine Seite angezeigt

  • Gelöst sonnenpriester

    (@sonnenpriester)


    Ich habe WordPress frisch installiert und nach dem install Vorgang komme ich zwar ins Dashboard aber ich kann mir keine einzige Seite anschauen. Ich bekomme immer einen 404 Not Found Fehler. Auf das Dashboard komme ich aber ganz normal drauf. Auch die Vorschau im Dashboard funktioniert nicht.

    Ich weiß nicht mehr weiter. Was genau braucht ihr um mir helfen zu können oder ist der Fehler bekannt?

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hallo,
    wenn du dann noch die URL oben einträgst, dann können wir uns das auch ansehen und dir sicher besser helfen.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    sonnenpriester

    (@sonnenpriester)

    Moin Hans-Gerd!

    Danke erstmal … komischerweise kann ich meinen ersten Post nicht editieren. Ist der Knopf irgendwie versteckt? Die URL ist in diesem Fall: timtools.tim-stoffel.de

    Hier der Bericht. Ich denke da kann man sehen wo der Fehler liegt. WP_HOME und WP_SITEURL sind undefined. ich schätze mal das ist das Problem oder? Komischerweise habe ich jedoch in der Seiten Konfiguration eine Startseite gesetzt.

    Auch Permalinks ist undefined was merkwürdig ist weil ich zwecks Behebung dieses Fehlers die Permalinks erneut abgespeichert habe.

    Aber vielleicht seht ihr ja noch mehr hier:

    
    ### wp-core ###
    
    version: 5.5.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: undefined
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web523/b2/39/52669339/htdocs/timtools
    wordpress_size: 44,00 MB (46136993 bytes)
    uploads_path: /mnt/web523/b2/39/52669339/htdocs/timtools/wp-content/uploads
    uploads_size: 0,00 B (0 bytes)
    themes_path: /mnt/web523/b2/39/52669339/htdocs/timtools/wp-content/themes
    themes_size: 3,79 MB (3970285 bytes)
    plugins_path: /mnt/web523/b2/39/52669339/htdocs/timtools/wp-content/plugins
    plugins_size: 235,01 kB (240650 bytes)
    database_size: 896,00 kB (917504 bytes)
    total_size: 48,89 MB (51265432 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Nineteen (twentynineteen)
    version: 1.7
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, editor-color-palette, responsive-embeds, widgets
    theme_path: /mnt/web523/b2/39/52669339/htdocs/timtools/wp-content/themes/twentynineteen
    
    ### wp-themes-inactive (2) ###
    
    Twenty Seventeen: version: 2.4, author: WordPress-Team
    Twenty Twenty: version: 1.5, author: WordPress-Team
    
    ### wp-plugins-inactive (2) ###
    
    Akismet Anti-Spam: version: 4.1.7, author: Automattic
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-47 Q16 x86_64 2019-05-28 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 76M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 256 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 256 GB
    	imagick::RESOURCETYPE_MEMORY: 128 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.43 (Unix)
    php_version: 7.4.12
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web523/b2/39/52669339/htdocs/timtools/wp-content
    WP_PLUGIN_DIR: /mnt/web523/b2/39/52669339/htdocs/timtools/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hallo,

    Ich denke da kann man sehen wo der Fehler liegt. WP_HOME und WP_SITEURL sind undefined.

    Das ist völlig ok, weil damit die WordPress-Konstanten in der wp-config.php genannt sind, die aber nur in bestimmten Fällen gesetzt werden müssen, siehe hier.
    permalink: undefined ist seltsam. Das sollte in dem Bericht z. B. in der Art permalink: /%postname%/ stehen, wenn du unter Einstellungen > Permalinks > Beitragsname gewählt und bestätigt hast.
    Die von dir genannte Webseite scheint falsch zu sein – mehr ist mir im Moment nicht aufgefallen.
    Viele Grüße
    Hans-Gerd

    Moin nochmal … also die Webseite ist richtig oder was meinst du mit falsch? Das ist ja das Problem, dass er da einen Not Found Fehler wirft.

    Habe die Permalinks auf Beitragsnamen gestellt aber an dem Fehlerbild hat sich nichts geändert.
    permalink: /%postname%/ steht jetzt auch im Bericht

    Hallo,

    Die URL ist in diesem Fall: timtools.tim-stoffel.de

    Bei Eingabe der URL erscheint: Not Found – The requested URL was not found on this server.
    Viele Grüße
    Hans-Gerd

    Hallo Hans-Gerd,

    Ja … das ist ja genau das Problem! Aber keine Bange habe es scheinbar gelöst. Strato hatte im Hauptverzeichnis, aus welchen Gründen auch immer, eine htaccess Datei angelgt, die scheinbar eine Weiterleitung auf index.php und admin.php verhindert hat.

    Dummerweise geht meine alte andere Webseite nicht mehr wenn ich die entsprechenden Stelle auskommentiere. Aber die ist sowieso alt und muss neu.

    Von daher behalte ich das jetzt erstmal so …

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)