Support » Allgemeine Fragen » Nach Plug-in Aktualisierung Seite zerschossen

  • Gelöst pixapool

    (@pixapool)


    Hallo ans Forum,

    seit knapp 2 Jahren lief meine HP, basierend auf einem „Oshine“-Template fehlerfrei.
    Zur Neuinstallierung eines Plug-ins musste ich meinen FTP-Namen aktualisieren, damit einhergehend änderte ich das PW bei meinem Host (hosteurope).
    Die Neuinstallierung und die anschließende Aktualisierung lief reibungslos. Daher entschloss ich mich ein weiters Plug-in zu aktualisieren, das „W3 Total Cache“, und zwar von der Version 0.9.4.1. zu 0.9.6.

    Die Aktualisierung wurde mir mit zwei roten, rotierenden Pfeilen angezeigt.
    Meines Erachtens dauerte dieser Vorgang ungewöhnlich lange und nach knapp einer Stunde habe ich den Vorgang abgebrochen.

    DANACH hat´s meine Seite komplett zerschossen (nur noch weißes Feld sichtbar), ebenso habe ich keinen Zugang mehr zum Admin-Bereich, sehe somit also weder das Dashboard noch irgendetwas anderes.

    Meine Frage ans Forum lautet nun, wo lag mein Fehler, ist es evtl. ein bekanntes Problem – und vor allem: gibt es eine Möglichkeit zum letzten Status Quo zurückzukehren?

    Über eine Antwort/Lösungsvorschlag wäre ich sehr dankbar! Gleichzeitig muss ich auch einräumen, dass ich leider über keinerlei Kenntnisse verfüge, das Problem auch nur annähernd selbst zu lösen ;(

    Herzlichen Dank im Voraus für einen Lösungsvorschlag.
    AK

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Moderator Bego Mario Garde

    (@pixolin)

    Eine leere/weiße Seite bedeutet, dass ein schwerwiegender Fehler vorliegt. Statt potentielle Angreifer darauf aufmerksam zu machen, wird einfach gar nichts ausgegeben.

    Zur Neuinstallierung eines Plug-ins musste ich meinen FTP-Namen aktualisieren, damit einhergehend änderte ich das PW bei meinem Host (hosteurope).
    Bei HostEurope kannst du unter Webspace/Nutzer > FTP-Zugänge selbst FTP-Accounts einrichten und ihnen einen Nutzer zuweisen. Hier musst du einen Nutzer mir wp… auswählen, sonst stimmen die Berechtigungen nicht und du wirst aufgefordert, FTP-Zugangsdaten einzugeben.

    Die Neuinstallierung und die anschließende Aktualisierung lief reibungslos. Daher entschloss ich mich ein weiters Plug-in zu aktualisieren … 
    Hast du vorher auch ein Backup deiner Website erstellt?

    Meines Erachtens dauerte dieser Vorgang ungewöhnlich lange und nach knapp einer Stunde habe ich den Vorgang abgebrochen.
    Normalerweise ist die Installation nach ein paar Minuten abgeschlossen.

    Wen du per FTP-Programm auf deinen Webspace zugreifen kannst, kannst du das Plugin auch manuell aktualisieren. Dazu löschst du zuerst das Verzeichnis wp-content/plugins/w3-total-cache, lädst dann hier herunter und entpackst die zip-Datei. Dann das Verzeichnis wieder in wp-content/plugins hochladen – danach sollte die Website schon wieder laufen, wenn es nur an diesem Plugin lag.

    Gib mal eine Rückmeldung, ob’s dann klappt.

    Hallo zurück und danke für die Hilfestellung… 😉

    Ich selbst habe das nicht hinbekommen, jemand Externes hat mir geholfen und die HP gerettet.
    Das Problem war wohl nicht das „W3 Total Cache“, sondern das Plug-in, das ich vorher geupdated habe.

    Hierbei handelte es sich um das BE Page Builder Plug-in, das die Struktur meiner HP benötigt und zwingend NICHT auf die Version 4.6.1 geupdated werden darf, da es sonst (auch mit der allerletzten WP-Version) NICHT kompatibel ist und die gesamte Seite crasht. Interesting…

    Es wurde mittlerweile auf die alte Version zurückgesetzt und Daten konnten z.Tl. über ein altes Backup und über ein restore (?) bei meinem Host gerettet werden.

    Zwischendurch sah’s allerdings nicht gut aus…
    Jetzt läuft aber alles wieder so wie vorher…
    Viele Grüße, AK

    Moderator Bego Mario Garde

    (@pixolin)

    Hierbei handelte es sich um das BE Page Builder Plug-in, das die Struktur meiner HP benötigt und zwingend NICHT auf die Version 4.6.1 geupdated werden darf, da es sonst (auch mit der allerletzten WP-Version) NICHT kompatibel ist und die gesamte Seite crasht. Interesting…

    Das hört sich nicht gut an. Dir ist schon klar, dass die meisten WordPress-Websites gehackt werden, weil Plugins oder Themes mit Sicherheitslücken nicht aktualisiert wurden?

    …ansatzweise ist mir das schon klar. Aber vermutlich werde ich jetzt mit weiteren Aktualisierungen eher vorsichtig sein, wenn DAS im Endeffekt meine Website crashed. Irgendwie kann´s das ja auch nicht sein… ;(

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Nach Plug-in Aktualisierung Seite zerschossen“ ist für neue Antworten geschlossen.