Support » Plugins » Nach Plugin Installation keine Medien Uplaods mehr möglich

  • Gelöst henlan

    (@henlan)


    Hallo allerseits,
    ich habe für meinen Blog das PlugIn „Force Generate Thumbnails“ heruntergeladen, da e svon meinem Theme empfohlen wurde. Ich habe die Funktion ausprobiert, leider mit dem Ergebnis, das all meine Bilder nicht mehr angezeigt wurden. Die Bilder waren ncoh im medien Uplaod Bereich vorhanden, jedoc wurde nur noc heine leere Fläche angezeigt. Auhc im FrontEnd wurden die Bilder nicht mehr angezeigt.
    Ich habe ein BackUp eingespiel, und die Bilder waren alle wieder vorhanden, doch leider kann ich nun keine neuen Medien mehr uploaden. Alle Medien werden lediglich als leeres Feld angezeigt, im FrontEnd kann ich diese auch nicht mehr anzeigen. Woran liegt das?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Hallo @henlan und willkommen im Forum,

    hast du mal den Browser-Cache gelöscht oder einen anderen Browser ausprobiert?

    … leider kann ich nun keine neuen Medien mehr uploaden
    kann ich kaum nachvollziehen. Was passiert, wenn du Bilder hochlädst? Gibt es Fehlermeldungen? Hast du mal alle anderen Plugins vorübergehend deaktiviert, um sie als mögliche Ursache auszuschließen?

    Ein paar weitere Informationen zu deiner Website wären auch hilfreich. Bitte lies dir in unserem FAQ-Bereich den Beitrag zum Health Check durch.

    Vielen Dank erstmal für die Antwort. Ich habe mich undeutlich ausgedrückt, was den Bild Upload betrifft.
    Nachdem ich das PlugIn installierte und die Funktion startete, waren alle Medien lediglich nur noch leere Felder (sowohl im Front- als auch im BackEnd).
    Nach dem Einspielen des BackUp wurden die Medien wieder korrekt angezeigt, jedoch alle neu hinzugefügten Medien sind nur noch freie Felder. Auch im Probelmbehandlungsmodus ist der MedienUpload nicht möglich, bzw. sind alle neuen Medien lediglich leere Felder.

    Das interessante ist, wenn ich ein Bild hochlade (welches dann nur ein leeres Feld ist), anschliessend ein BackUp mache und es direkt einspiele, wird das Bild korrekt angezeigt.

    Den Browser zu wechseln, bzw. den Cache zu löschen hat leider nicht geholfen.

    Anbei die Debugging-Information des Healtch Check plugin

    
    				### WordPress ###
    
    Version: 4.9.6
    Sprache: de_DE
    Permalink-Struktur: /%year%/%monthnum%/%day%/%postname%/
    Verwendet diese Website HTTPS?: Ja
    Kann sich jeder auf dieser Website registrieren?: Nein
    Standard-Kommentarstatus: open
    Ist dies ein Netzwerk?: Nein
    Benutzeranzahl: 2
    Kommunikation mit WordPress.org: WordPress.org ist erreichbar
    Erzeuge Loopback Requests: Der Loopback Request für deine Website wurde erfolgreich abgeschlossen.
    
    ### Größe der Installation ###
    
    Uploads-Verzeichnis: 31,27 MB
    Theme-Verzeichnis: 6,54 MB
    Plugin-Verzeichnis: 29,70 MB
    Datenbank-Größe: 2,88 MB
    Gesamtes WordPress-Verzeichnis: 93,76 MB
    Gesamtgröße der Installation: 96,64 MB
    
    ### Aktives Theme ###
    
    Name: Activello
    Version: 1.3.7
    Autor: Colorlib
    Website des Autors: http://colorlib.com
    Parent Theme: Kein Child Theme
    Unterstützte Theme-Funktionalität: automatic-feed-links, post-thumbnails, menus, post-formats, custom-background, html5, custom-logo, title-tag, infinite-scroll, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets
    
    ### Andere Themes (1) ###
    
    Twenty Seventeen (twentyseventeen): Version 1.6 von dem WordPress-Team
    
    ### Must Use Plugins (1) ###
    
    Health Check Troubleshooting Mode: Version 1.4
    
    ### Aktive Plugins (7) ###
    
    Antispam Bee: Version 2.8.1 von pluginkollektiv
    BackWPup: Version 3.6.0 von Inpsyde GmbH
    Contact Form 7: Version 5.0.2 von Takayuki Miyoshi
    Cookie Consent: Version 2.3.11 von Catapult_Themes
    Health Check: Version 1.1.0 von The WordPress.org community
    Widget Importer & Exporter: Version 1.5.3 von churchthemes.com
    WordPress Importer: Version 0.6.4 von wordpressdotorg
    
    ### Medienhandling ###
    
    Aktiver Editor: WP_Image_Editor_GD
    Imagick Modul Version: Imagick not available
    ImageMagick-Version: Imagick not available
    GD-Version: bundled (2.1.0 compatible)
    Ghostscript-Version: 9.15
    
    ### Server ###
    
    Server-Architektur: Linux 3.14.79-grsec-pvops-xen-x64 x86_64
    PHP-Version: 7.2.3 
    PHP SAPI: cgi-fcgi
    PHP max input variables: 1000
    PHP time limit: 300
    PHP memory limit: 256M
    Max input time: -1
    Maximale Dateigröße Upload: 8M
    PHP post max size: 8M
    cURL-Version: 7.55.1 OpenSSL/1.0.2l
    SUHOSIN installiert: Nein
    Ist die Imagick-Library verfügbar: Nein
    htaccess Regeln: Deine htaccess-Datei enthält nur WordPress-Funktionen
    
    ### Datenbank ###
    
    Erweiterung: mysqli
    Server-Version: 5.6.19-67.0-log
    Client-Version: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    Datenbankpräfix: wp_
    
    ### WordPress-Konstanten ###
    
    ABSPATH: /kunden/561431_60318/webseiten/wordpress/
    WP_HOME: https://www.wilalila.com
    WP_SITEURL: https://www.wilalila.com
    WP_DEBUG: Deaktiviert
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Aktiviert
    WP_DEBUG_LOG: Deaktiviert
    SCRIPT_DEBUG: Deaktiviert
    WP_CACHE: Deaktiviert
    CONCATENATE_SCRIPTS: Nicht definiert
    COMPRESS_SCRIPTS: Nicht definiert
    COMPRESS_CSS: Nicht definiert
    WP_LOCAL_DEV: Nicht definiert
    
    ### Dateisystem-Rechte ###
    
    Das Haupt-WordPress-Verzeichnis: Schreibbar
    Das Verzeichnis wp-content: Schreibbar
    Das Uploads-Verzeichnis: Schreibbar
    Das Plugin-Verzeichnis: Schreibbar
    Das Theme-Verzeichnis: Schreibbar
    Das Must-Use-Plugin-Verzeichnis : Schreibbar
    
    

    So sehen die Medien im Back End aus, mit dem PlugIn
    https://ibb.co/kVGxed

    So sehen die Medien im Back End aus, nachdem das PlugIn deinsalliert wurde und neue Medien hinzugefügt wurden
    https://ibb.co/fpPfXy

    • Diese Antwort wurde geändert vor 2 Jahre, 1 Monat von henlan.

    Edit:
    Beim Hochladen erscheint ein HTTP-Fehler

    Prüf doch bitte mal, ob du diese Datei hochladen kannst:

    https://s.w.org/style/images/about/WordPress-logotype-wmark.png

    Meine erste Vermutung ist, dass der Arbeitsspeicher nicht ausreicht um Bilder in hoher Auflösung komplett einzulesen.

    Auch das Bild kann ich nicht hochladen, es ist der gleiche Fehler

    OK, gehen wir das bitte nochmal schrittweise durch:

    Du hast ein Plugin installiert, dass die Vorschaubilder (Thumbnails) neu erstellen soll und danach hast du in der Mediathek nur noch leere Platzhalter statt der Bilder gesehen. Anschließend hast du ein Backup wiederhergestellt.
    Hast du alle Dateien und die Datenbank wiederhergestellt?

    Das Plugin Health Check bietet einen Problembehandlungs-Modus, der vorübergehend alle Plugins deaktiviert und ein Standard-Theme auswählt. Kannst du im Problembehandlungs-Modus das genannte Bild hochladen oder bekommst du weiterhin einen HTTP-Error?

    Genau.
    Ich habe das PlugIn „Force regenerate Thumbnails“ installiert und es ausgeführt. Dass hat dazu geführt, dass in der Mediathek lediglich die leeren Felder zu sehen waren, wo zuvor die Bilder waren, auch im FrontEnd wurden die Bilder nicht mehr angezeigt.
    Danach habe ich das BackUp über BackWPUp eingespielt, alle Bilder waren wieder normal. Jedoch kann ich seitdem keine weiteren Bilder mehr hinzufügen, alle neuen Bilder erhalten nur noch den leeren Platzhalter.
    Wenn ich jedoch ein Bild hochlade (welches nur als leerer Platzhalter zu sehen ist), ein BackUp starte und direkt danach das BackUp einspiele, wird das neue Bild, welches vor dem BackUp nur ein Platzhalter war, ebenfalls korrekt angezeigt.
    Im Problembehandlungsmodus ist der Upload ebenfalls nicht möglich (gleiches Probelm)

    • Diese Antwort wurde geändert vor 2 Jahre, 1 Monat von henlan.

    Hast du mal geschaut, ob die Fotos in mehreren Größen im Verzeichnis wp-content/uploads vorliegen?

    Du kannst auch mal das Plugin WP Database Manager installieren und mit Repair Database und Optimize Database die Datenbank reparieren.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Und könntest du mal versuchen die Bilder und Thumbnails (sofern sie auf dem FTP-Server ankommen) direkt im Browser aufzurufen? Bekommst du dann eine Fehlermeldung? Wenn ja, welche?

    Gruß, Torsten

    Hast du mal geschaut, ob die Fotos in mehreren Größen im Verzeichnis wp-content/uploads vorliegen?

    Alle Bilder, sowohl die korrekt angezeigten Bilder als auch die nicht korrekt angezeigten, sind in mehreren Versionen in dem Verzeichnis vorhanden.

    Du kannst auch mal das Plugin WP Database Manager installieren und mit Repair Database und Optimize Database die Datenbank reparieren.

    Leider hat das nicht weitergeholfen. Der Fehler besteht nach Repair und Optimize weiterhin.

    Und könntest du mal versuchen die Bilder und Thumbnails (sofern sie auf dem FTP-Server ankommen) direkt im Browser aufzurufen? Bekommst du dann eine Fehlermeldung? Wenn ja, welche?

    Die im BackEnd (und FrontEnd) korrekt angezeigten Bilder kann ich normal über den Browser aufrufen. Bei dem nicht korrekt angezeigten Bildern kommt die Fehlermeldung Fehler 403 Zugriff verweigert.
    Liegt hier ein Problem an den Rechten?

    Edit:
    Vielen Dank, es schien tatsächlich an den Rechten zu liegen. Die Rechte des Uplaod Ordners waren auf 710, ich habe sie nun auf 750 gesetzt, nun funktioniert alles wieder.

    Vielen Dank für die Mühe

    • Diese Antwort wurde geändert vor 2 Jahre, 1 Monat von henlan.
Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Nach Plugin Installation keine Medien Uplaods mehr möglich“ ist für neue Antworten geschlossen.