Support » Plugins » Nach Polylang-Aktivierung Blogseite verschwunden und Menü falsch angezeigt

  • saturno2016

    (@saturno2016)


    Guten Morgen,

    nun bin ich schon wieder da. Habe nun Polylang installiert und nach Anleitung eingestellt. Nun sind meine Blog-Seite aus dem Haeder verschwunden, das Seitenmenü bunt gemischt und die footer-Einträge im Header gelandet. Footer ist jetzt leer. Im Backend wird alles richtig angezeigt, nur wird es falsch ausgegeben. Wisst Ihr hier einen Rat? Ich sitze auf Kohlen!
    Vielen Dank schon mal im Voraus
    Sigrid

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 16 bis 18 (von insgesamt 18)
  • Thread-Starter saturno2016

    (@saturno2016)

    Habe jetzt alles so gemacht, aber es funktioniert trotzdem nicht, bin schon bei der 11. automatischen Wiederaufnahme der Sicherung wegen Fehlers. Jetzt fällt mir nur noch ein, die relevanten Dateien direkt über FTP runterzuladen auf meinen PC und über FTP in den entsprechenden Ordner der anderen Domain wieder hochzuladen.

    Thread-Starter saturno2016

    (@saturno2016)

    Habe mir inzwischen über phpMy Admin ein Update von der deutschen Seite heruntergeladen und könnte es jetzt auf die italienische Domain über phpMyAdmin wieder hochladen. Aber ich bin mir nicht sicher, ob ich da vorher den gesamten Datenbank Inhalt der italienischen Seite (der ist alt und muss entweder überschrieben oder gelöscht werden) löschen muss. Dazu habe ich bisher keine Infos gefunden, die mir weiter helfen.

    • Diese Antwort wurde geändert vor 7 Monaten von saturno2016.
    Thread-Starter saturno2016

    (@saturno2016)

    Guten Morgen Bego,

    danke für Deine ausführliche Anleitung. Da nun leider alle Plugin-Lösungen nicht funktioniert haben, habe ich es direkt im FTP versucht und bin, so wie es aussieht einen Schritt weiter gekommen, und wollte dich nochmals um einen Hinweis bitten.

    Im FTP sieht es so aus:

    die deutsche domain http://www.heilsame-ernaehrung.de läuft unter WordPress_01 mit dem Datenbanknamen DB960236

    die italienische Domain alimentazione-salutare.com läuft unter WordPress_05 mit dem Datenbanknamen DB2021771

    nun habe ich die WordPress_01 komplett heruntergeladen auf meinen PC, habe dann die WordPress_05 umbenannt in WordPress_05_alt. Dann habe ich ein neues Verzeichnis mit dem Namen WordPress_05 angelegt und den kompletten Download der WordPress_01 hochgeladen.

    Das Ergebnis ist folgendes: Wenn ich nun die alimentazione-salutare.com aufrufe in Google, dann öffnet sie sich mit dem kompletten Inhalt der deutschen Seite, so wie ich es wollte, damit ich sie nun einfach nur noch übersetzen muss. Das Ganze hat nur noch einen Fehler, denn im Browser erscheint die deutsche URL heilsame-ernaehrung.de

    Nun habe ich in der wp.config.php nachgeschaut und darin steht der Datenbankname der deutschen Seite, also DB960236 – ist ja auch logisch, denn ich habe ja den Inhalt der deutschen Datenbank auf das neu erstellte Verzeichnis WordPress_05 hochgeladen.

    Nun habe ich mich nicht getraut hier einfach den Datenbanknamen zu ersetzen, also den Datenbanknamen der italienischen Domain einzusetzen, weil ich zu wenig Vorstellung habe, wie das Innenleben der Datenbanken funktioniert.

    Nun meinen Frage, wenn ich den Datenbanknamen austausche, ersheint dann im Browser die richtige URL, also alimentazione-salutare.com und wird dann in allen internen links heilsame-ernaehrung.de mit alimentazione-salutare. com ersetzt oder erscheint dann einfach wieder der alte Inhalt der italienischen Domain?

    Um die Besucher der italienischen Seite nicht zu verwirren, habe ich vorerst den Status quo wieder hergestellt, also die neue WordPress_05 mit dem hochgeladenen deutschen Inhalt umbenannt in WordPress_05_neu und die WordPress_05_alt wieder in WordPress_05 zurück umbenannt. Wenn man nun die italienische Domain aufruft, ist wieder alles wie gehabe, es erscheint wie zuvor der alte italienische Inhalt – also beide Seiten, die deutsche und die italienische sind wieder klar getrennt voneinander.

    Ich hoffe, ich habe es klar beschrieben: Im Moment existieren im FTP also die WordPress_01 mit der domain heilsame-ernaehrung.de, die WordPress_05 mit der domain alimentazione-salutare.com und der neue Mischling WordPress_05_neu mit dem hochgeladenen deutschen Inhalt.

    Wenn ich nun in der WordPress_05_neu in der wp.config.php den Datenbanknamen austausche, sodass sie nicht den der deutschen Seite trägt, sondern den der italienischen Seite, ist dann alles in Ordung? Könnte ich dann die WordPress_05 mit den alten italienischen Inhalten wieder in WordPress_05_alt umbenennen und die WordPress_05_neu mit der geänderten Datenbank in WordPress_05 umbenennen? Kann das so funktionieren oder wird durch das Ersetzen des Datenbanknamens dann der neu hochgeladene deutsche Inhalt mit dem alten Inhalt der italienischen Datenbank einfach überschrieben?

    Vielleicht noch zur Info, den Download im FTP, das Umbenennen von WordPress_5 in WordPress_5_alt, das Anlegen eines neuen Verzeichnisses WordPress_5 und das wieder Hochladen hat ein professioneller Webdesigner gemacht, mit schnellem Internet. Da er aber ein eigenes System entwickelt hat und sich in WordPress nicht so gut auskennt, hat er wegen des oben beschriebenen Fehlers das Handtuch geschmissen und mir einen Webdesigner empfohlen, der nur mit WordPress arbeitet. Zu dem würde ich morgen gehen, wenn meine oben geschilderten Überlegungen zu naiv gedacht und damit falsch sind. Vielleicht siehst du das gleich auf den ersten Blick.

    Viele Grüße Sigrid

Ansicht von 3 Antworten - 16 bis 18 (von insgesamt 18)
  • Das Thema „Nach Polylang-Aktivierung Blogseite verschwunden und Menü falsch angezeigt“ ist für neue Antworten geschlossen.