Support » Installation » Nach SSL einbindung leitet die Webseite nicht automatisch weiter

  • danielkn

    (@danielkn)


    Hallo zusammen,
    ich habe auf meiner Webseite WordPress installiert und direkt das SSL Zertifikat eingebunden (alles so wie schon zig mal davor). Aber die Webseite leitet nicht automatisch auf https weiter, wenn ich die URL ohne https eingebe. Bei allen anderen Webseiten werde ich automatisch auf https weitergeleitet und da habe ich das genau so gemacht. Ich kann mir nicht erklären, warum das jetzt dieses Mal nicht funktioniert hat.
    Ich habe bei der ersten Installation aus Versehen den Hauptordner auf dem FTP genommen. Habe dann aber alles Dateien und Datenbaken der aktuellen Installation gelöscht und alles noch mal installiert. Da das dann mit der Weiterleitung auf https nicht geklappt hat, habe ich noch mal alles heruntergeworfen und neu installiert. Am Fehler hat sich aber nichts geändert.

    Habe in der htaccess Datei jetzt folgendes eingetragen:

    php_value memory_limit 256M
    php_value max_input_vars 10000

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Damit klappt das Ganze jetzt auch. Hatte es vorher mit anderen Änderungen versucht, aber da ließen sich dann keine Seiten mehr speichern und ich habe einen 400 Fehler beim Aufrufen von neuen Seiten erhalten. Mit der Änderung passt nun alles.

    Meine Frage ist nun, warum ich erst diese Änderung machen musste und das nicht auf Anhieb geklappt hat wie bei allen anderen Seiten (bei diesen ist Zeile 7 und 8 in der htaccess nämlich auch nicht da). Außerdem sagte mir mein Webhoster, dass ein Weiterleitungsschleife nicht ideal ist.

    Würde mich freuen, wenn ihr mir helfen könntet mein Problem aufzuschlüsseln. Möchte den Fehler nämlich verstehen und nicht einfach nur hinnehmen, dass es jetzt so ist 🙂
    Danke und Gruß Daniel

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

  • Das Thema „Nach SSL einbindung leitet die Webseite nicht automatisch weiter“ ist für neue Antworten geschlossen.