Support » Allgemeine Fragen » Nach SSL, URL geändert, WordPress tot

  • Liebe Leute,

    ich habe ein riesen Problem, bei dem ich auf eure Hilfe hoffe.

    Bei meinem Webhoster habe ich alle meine Seiten auf SSL umgestellt. Unter anderem meinen Shop.

    Dieser ist unter http://www.shop.domdesignonline.de erreichbar gewesen. Da es Probleme mit dem SSL Zertifikat gab, musste ich im wordpress Bereich die URLs ändern, was ich getan habe.

    Danach ging gar nichts mehr!

    Weder wenn ich SSL aktiviere noch deaktivere komme ich wieder in mein Backend um alles rückgängig zu machen.

    Ja, es gibt hier den Post „URL geändert, kann mich nicht mehr einloggen“, in dem beschrieben wird, dass man in der wp-config einfach define( 'RELOCATE', true ); einfügen soll.

    Damit hat sich bei mir leider nichts verändert

    Habt ihr weitere Ideen? (Der Platz an dem die WordPress-Daten liegen haben sich eigentlich ja nicht verändert.)

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 20)
  • Du bist nicht der Erste und bestimmt auch nicht der Letzte mit diesem Problem sein. Daher hätte dir google auch geholfen 😉

    Siehe z.B. https://www.blogmojo.de/wordpress-auf-https-umstellen/

    Lustiger Zufall. Genau nach Anleitung von blogmojo bin ich vorgegangen.

    Dort hatte ich dann bei Punkt 2 schon ein Problem. Sobald ich nämlich das „s“ zum http hinzugefügt hatte, kam eine Fehlermeldung innerhalb WordPress dass diese URL so nicht erreichbar ist.

    Also habe ich das www entfernt und seitdem ist der oben genannte Fehler 🙂

    Nur deswegen habe ich diesen Post eigentlich eröffnen (müssen) 😉

    Also, ich würde erst einmal ein Backup wieder einspielen, um die Seite überhaupt erst mal wieder zum laufen zu bekommen.

    Und dann hiermit nochmal probieren: https://www.webtimiser.de/wordpress-http-https-ssl-umstellen/

    Ok, also jetzt wirds immer wilder. 🙂

    Das Backup ist drin. Alles gut soweit! Hab nun SSL aktiviert und auch in meinen URLs im Backend hab ich überall das https drin stehen.

    Mein Backend is auch über https erreichbar aber sobald ich die Startseite aufrufe kommt die Browsermeldung: Diese Verbindung ist nicht sicher

    ? Was geht hier ab? 🙂

    Hallo,
    wahrscheinlich hast Du mixed content (also teilweise unsichere Inhalte).
    Die kannst Du z. B. so prüfen bzw. hier sind weitere Infos dazu.

    bscu (@bscu)
    Siehe https://support.mozilla.org/de/kb/verbindung-ist-nicht-sicher-fehlermeldung

    Das bringt mich leider überhaupt nicht weiter.

    hage (@hage)

    wahrscheinlich hast Du mixed content (also teilweise unsichere Inhalte).
    Die kannst Du z. B. so prüfen bzw. hier sind weitere Infos dazu.

    Alles ok hier. „You have no mixed content.“ Wunder mich auch, weil sonst würde ich ja auch nichts in Backend kommen.

    Wenn ich das Rote Dreieck anklicke erscheint ja unter anderem das das Zertifikat ungültig ist.
    Hast du eventuell hier WordPress-Adresse (URL) Website-Adresse (URL) in den Einstellungen einen Fehler gemacht?

    Hab es nochmals aktualisiert und jetzt ist auch die Startseite des Shops an sich tatsächlich wieder erreichbar. Ich danke dir!

    Was mich jetzt verwundert: In der Deskotpversion sind auf einmal die obersten Bilder alle angeschnitten. Also als wäre der Header in der https Version „kürzer“ geworden.

    Kann man irgendwie herausfinden, warum das so ist?

    Bei mir kommt immer noch

    Diese Verbindung ist nicht sicher

    @bscu – dürfte aber nur an deinen Cookies löschen. Ich hab bei mir in Safari, Chrome und Firefox alle Cookies gelöscht und jetzt keine Probleme mehr…

    Hallo,
    im Inkognito- Modus in Chrome wird die (Haupt-)Seite zunächst als sicher gezeigt. Wenn ich allerdings auf den Menüpunkt „Kontakt“ gehe, wird diese Unterseite als nicht sicher angezeigt.
    Wenn Du in Firefox in die developer tools gehst und dort „Konsole“ wählst, werden die unsicheren Inhalte angezeigt. Dabei handelt es sich in erster Linie um die Grafiken der Werbung:
    z. B. „Gemischte (unsichere) Anzeige-Inhalte von“ … http://www.blog.domdesignonline.de …
    Da müsste statt http eben https stehen.
    Das kannst Du z. B. mit dem plugin Better Search and Replace korrigieren. Das habe ich auf diese Weise schon häufger gemacht und das klappt gut.
    Vorher aber bitte Daten (zumindest die Datenbank) sichern

    @hage Danke das wars. So hab ich jetzt (fast) alle Probleme behoben.

    Einzig meine Logo-Datei läuft noch unter http. Das find ich auch mit Better Search Replace nicht. Wo liegt denn diese Datei, damit ich sie noch umbennennen kann? 🙂

    … bist Du sicher ? – vielleicht liegt es am Browsercache.
    Wenn ich die Seite aurufe, dann kann ich in den developer tools folgende Zeile sehen:
    <img src="https://www.shop.domdesignonline.de/wp-content/uploads/2015/11/logo1.jpg" alt="logo" />
    … und da steht https – also alles paletti 🙂

    @hage also laut der Konsole ist das Problem mit diesem Logo: https://i.imgur.com/FW8ysaZ.png

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von fooos.
Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 20)
  • Das Thema „Nach SSL, URL geändert, WordPress tot“ ist für neue Antworten geschlossen.