Ansicht von 8 Antworten – 1 bis 8 (von insgesamt 8)
  • Hallo,
    da gibt es u. a. zwei Möglichkeiten, wenn du …

    • entweder im Kundenmenü deines Webhosters die Datenbankverwaltung öffnest (üblicherweise über phpMyAdmin) und dort in der für WordPress genutzten Datenbank in der Tabelle wp_options die korrekten Einträge für die Felder siteurl und home einträgst (Das Präfix wp_ kann auch anders lauten),
    • oder indem du per FTP in der Konfigurationsdatei wp-config.php mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++, beide kostenlos erhältlich) die Zeile define( 'RELOCATE', true ); oberhalb von /* That's all, stop editing! Happy blogging. */ einfügst.
      Danach solltest du dich über ...\wp-login.php anmelden und unter Einstellungen > Allgemein die URL ändern können. Wurde der Eintrag korrigiert und die Einstellungen per Button aktualisiert, muss man sich erneut anmelden. Die Website sollte dann aber wieder funktionieren. Vorsichtshalber sollte nun noch die in der wp-config.phpeingefügte Zeile wieder entfernt oder die Konstante auf false gesetzt werden: define( 'RELOCATE', false );

    In dem folgenden Beitrag von mir findest du weitere Infos dazu.

    Du solltest vor entsprechenden Änderungen in der von mir genannten Art auf jeden Fall eine Sicherung erstellen.

    Das SSL-Zertifikat muss bei der Domain zuerst eingerichtet werden und aktiv sein. Das kannst du prüfen, in dem du die URL https://example.com/readme.html (mit deiner Domain) aufrufst. Im Browser wird in der URL-Leiste angezeigt, dass die Seite nicht sicher ist. Erst wenn du das SSL-Zertifikat über deinen Hoster angelegt hast, kannst du die Umstellung in WordPress vornehmen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter urbancowboyde

    (@urbancowboyde)

    Hi Hans-Gerd,

    zuerst mal ganz herzlichen Dank für deine schnelle Antwort!

    Ich habe vie Filezilla die wp-config.php heruntergeladen und mit einem Texteditor die Zeile „define( ‚RELOCATE‘, true );“ an der genannten Stelle eingesetzt. Diese Datei habe ich dann wieder erfolgreich hochgeladen (Pfad: /htdocs/wp-admin). Datum der Änderung stimmt.

    Leider ist nun die ganze Seite down (HTML error 500) und über /wp-admin.php komme ich ebenfalls nicht in mein Backend.

    Für jeden weiteren Tipp wäre in super dankbar. Vielen Dank vorab.

    Beste Grüße

    Michael

    Hallo,
    kann es sein, dass du die wp-config.php mit dem Windows-Editor bearbeitet hast?
    Bei der Bearbeitung musst du die folgende Zeile exakt so mit den angegebenen Hochkommata eingeben -beachte auch den Hinweis bezogen auf Notepad++:
    define( 'RELOCATE', true );
    oberhalb von
    /* That's all, stop editing! Happy blogging. */

    Damit die Website zumindest wieder läuft, kannst du auch erst mal die hoffentlich vorher lokal gesicherte Datei wieder hochladen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter urbancowboyde

    (@urbancowboyde)

    Ja, es war der Windows Explorer.
    Nun hab ich mir Notepad++ heruntergeladen und die Zeile nochmal eingesetzt.

    Leider keine Veränderung.

    So schaut das Ende meiner wp-config.php aus. Ist da vielleicht irgendein Fehler zu erlennen? (Backup hab ich leider keins gemacht, das ist für mich gerade sehr lehrreich …)

    /**

    • WordPress Datenbanktabellen-Präfix
      *
    • Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
    • verschiedene WordPress-Installationen betreiben. Nur Zahlen, Buchstaben und Unterstriche bitte!
      */
      $table_prefix = ‚wp_‘;

    /**

    • For developers: WordPress debugging mode.
      *
    • Change this to true to enable the display of notices during development.
    • It is strongly recommended that plugin and theme developers use WP_DEBUG
    • in their development environments.
      */
      define(‚WP_DEBUG‘, false);

    define( ‚RELOCATE‘, true );

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‚ABSPATH‘) )
    define(‚ABSPATH‘, dirname(FILE) . ‚/‘);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‚wp-settings.php‘);

    Hallo,

    Backup hab ich leider keins gemacht, das ist für mich gerade sehr lehrreich …

    tja…

    Ich gehe davon aus, dass in der wp-config.php auch die Zugangsdaten und SALT-Keys stehen, die du vor dem Posten hier gelöscht hast. Das war auch richtig so.

    Bei den letzten Zeilen scheint aber ein Fehler zu sein. Da müsste eigentlich das hier stehen:

    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', __DIR__ . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';

    Alternative: Evtl. gibt es im Ordner noch eine Datei wp-config-sample.php. Sichere die Datei wp-config.php auf deinem lokalen Rechner, lösche dann die Datei und benenne die Datei wp-config-sample.php um in wp-config.php.
    Trage dann die Zugangsdaten und die SALT-Keys aus der lokal gesicherten wp-config.php in die umbenannte Datei wp-config.php auf dem Server ein.
    Teste dann bitte, ob die Seite erst mal wieder funktioniert.
    Trage dann mit Notepad++ die folgende Zeile
    define( 'RELOCATE', true );
    oberhalb von
    /* That's all, stop editing! Happy blogging. */
    ein.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 2 Monaten von Hans-Gerd Gerhards. Grund: Formatierung als Code
    Thread-Starter urbancowboyde

    (@urbancowboyde)

    Das hat leider auch nichts gebracht.

    Eine Sample-Datei wp-config-sample.php finde ich leider auch nicht.

    Ich denke, ich befasse mich langsam mit dem Gedanken, die Seite neu zu bauen, mehr fällt mir auch nicht mehr ein.

    Sehr herzlichen Dank an dich für deine Tipps und die schnellen Reaktionen. Alles Gute!

    Hallo,
    sehr schade, weil das Problem mit Sicherheit schnell behoben werden kann.
    Wenn du WordPress auf der folgenden Seite runterlädst und lokal auf deinem Rechner entpackst, dann findest du im Ordner mit der wp-config.php auch die Datei wp-config-sample.php, die du wie beschrieben anpassen und hochladen kannst.

    Der Aufwand die Website komplett neu aufzusetzen, ist auf jeden Fall größer. Und ein schöner Nebeneffekt: Du hast wieder etwas dazu gelernt.

    Als ich mit WordPress angefangen habe, habe ich die eine oder andere Website geschreddert. Das passiert jedem mal, kann aber in der Regel behoben werden.

    Viele Grüße
    Hans-Gerd

    Eine Website zu nuken, ist zwar nicht erfreulich, abert auch eine Lösung. Bevor weitere Helfende sich den Thread aufmerksam durchlesen um dann festzustellen, dass die Website bereits gelöscht wurde, markiere ich den Thread als „gelöst“.

    Schade, dass die vorgeschlagenen Tipps anscheinend nur halbherzig umgesetzt wurden.

    • Die Änderung in der Datenbank wurde nicht probiert.
    • Eine Fehlermeldung „500–Internal Server Error“ bedeutet, dass etwas schief gelaufen ist. Die vollständige Fehlermeldung mit dem Hinweis, wo der Fehler entsteht, steht im Error-Log der Website.
    • Der Code der wp-config.php wurde nicht als Code formatiert und ist deshalb schwerer zu lesen. Es macht einen großen Unterschied, ob in der Datei define('RELOCATE', true); steht oder z.B. define(,Relocate‘, true); (mal mit einfachen Hochkommas, mal mit typografischen Anführungszeichen).
    • Bereits erwähnt: wir empfehlen immer, vor Änderungen ein Backup zu machen, weil es dann leichter ist, die Änderung zurückzunehmen. Die alte Regel lautet „Kein Backup, kein Mitleid.“

    Aller Anfang ist schwer und ich drücke die Daumen, dass die nächste WordPress-Installation besser läuft.

Ansicht von 8 Antworten – 1 bis 8 (von insgesamt 8)