Support » Allgemeine Fragen » Nach Umstellung auf PHP 8.1 werden die Seiten nicht mehr gefunden

  • Gelöst fritz2015

    (@fritz2015)


    Hallo allerseits,

    mein Provider stellt demnächst die PHP-Version auf 8.1 um. Heute habe ich getestet, ob die Website dann noch läuft. Ja, sie läuft, aber es wird bei der Startseite und jeder über das Menü aufgerufenen Seite statt dem Content die Meldung angezeigt: „Ups! Die Seite konnte leider nicht gefunden werden. Es sieht so aus, als ob an dieser Stelle nicht das gefunden werden konnte, wonach du gesucht habst. Versuche es mit einem der folgenden Links oder der Suche nochmal…“.
    Das gleiche Problem habe ich bei mehreren Vereinssites, die ich ehrenamtlich betreue. Weiß jemand für dieses Problem eine Lösung? Ich möchte nicht bei allen Sites ein frisches WordPress aufsetzen und die Inhalte manuell rüberkopieren müssen. Es wäre sehr schön, wenn es auch einfacher ginge. Bitte helft mir.

    P.S. Habe die PHP-Version jetzt wieder auf 7.4 zurückgestellt, jetzt läuft wieder alles rund.

    Schöne Grüße,
    Fritz

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    es könnte daran liegen, dass Plugins und/oder das Theme von dir Probleme mit PHP 8.x haben.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Viele Grüße
    Hans-Gerd

    Thread-Starter fritz2015

    (@fritz2015)

    Hallo,

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. ... Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    das hatte ich eigentlich gelesen, aber offensichtlich habe ich diesen Absatz irgendwie überlesen. Sorry! Wer lesen kann ist klar im Vorteil. 😉

    Hier also der Website-Bericht:

    
    ### wp-core ###
    
    version: 5.5.3
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /is/htdocs/wp13124666_3WWULEGI39/www
    wordpress_size: 712,40 MB (747005146 bytes)
    uploads_path: /is/htdocs/wp13124666_3WWULEGI39/www/wp-content/uploads
    uploads_size: 29,89 MB (31339099 bytes)
    themes_path: /is/htdocs/wp13124666_3WWULEGI39/www/wp-content/themes
    themes_size: 1,96 MB (2054767 bytes)
    plugins_path: /is/htdocs/wp13124666_3WWULEGI39/www/wp-content/plugins
    plugins_size: 13,06 MB (13697906 bytes)
    database_size: 2,41 MB (2529280 bytes)
    total_size: 759,72 MB (796626198 bytes)
    
    ### wp-active-theme ###
    
    name: Confit Child (confit-child)
    version: 1.3.3
    parent_theme: Confit (confit)
    theme_features: core-block-patterns, automatic-feed-links, post-thumbnails, title-tag, menus, custom-background, custom-header, nova_menu_item, site-logo, jetpack-testimonial, widgets
    theme_path: /is/htdocs/wp13124666_3WWULEGI39/www/wp-content/themes/confit-child
    
    ### wp-parent-theme ###
    
    name: Confit (confit)
    version: 1.3.3
    author: Automattic
    author_website: https://wordpress.com/themes/
    theme_path: /is/htdocs/wp13124666_3WWULEGI39/www/wp-content/themes/confit
    
    ### wp-plugins-active (5) ###
    
    Classic Editor: version: 1.6.2, author: WordPress Contributors
    Full Screen Background Images: version: 2.6, author: MultiMediaMonster, Renske van der Heijden
    Hardcore Google Fonts Localizer: version: 1.2.2, author: Lorem Ipsum web.solutions GmbH
    Really Simple SSL: version: 5.3.1, author: Really Simple Plugins (latest version: 5.3.5)
    WPvivid Backup Plugin: version: 0.9.71, author: WPvivid Team (latest version: 0.9.79)
    
    ### wp-plugins-inactive (1) ###
    
    Posts in Page: version: 1.4.4, author: IvyCat, Inc.
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 50
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.132-xenu-he x86_64
    httpd_software: Apache
    php_version: 8.1.11-he.0 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.39-42-log
    client_version: mysqlnd 8.1.11-he.0
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /is/htdocs/wp13124666_3WWULEGI39/www/wp-content
    WP_PLUGIN_DIR: /is/htdocs/wp13124666_3WWULEGI39/www/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Im PHP-Error-Logfile, das der Provider anbietet sind keine Fehlermeldungen.
    Es läuft noch Version 5.3, da der Core sich nicht updaten lies (warum auch immer).

    Hilft das?

    Schöne Grüße,
    Fritz

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    Crossposting:
    https://wordpress.org/support/topic/is-confit-theme-compatible-with-php-8-1/

    Bitte immer auf Crossposting hinweisen.

    Warten wir also mal die Antwort im Support des Themes ab.
    Das Theme ist übrigens seit 2018 nicht mehr upgedatet worden. Insofern ist es durchaus möglich, dass das Theme Probleme macht.

    Am besten testest du mal. ob es Probleme gibt, indem du ein Standardtheme wie z. B. TWenty Twenty installierst und aktivierst. Vorher bitte sichern.

    Viele Grüße
    Hans-Gerd

    Michi91

    (@michi91)

    Speicher die Permalink Einstellungen und die Einstellungen von dem really simple ssl plugin mal neu ab 🙂 eventuell hilft das auch schon.

    Moderator Hans-Gerd Gerhards

    (@hage)

    @fritz2015
    Das Plugin Really Simple SSL ist übrigens keine gute Lösung für die Umstellung auf https. Bego hat in dem folgenden Beitrag beschrieben, wie man das ohne Plugin machen kann, wobei seit Version 5.7 die Möglichkeit besteht, über WordPress direkt auf https umzustellen, siehe Werkzeuge > Websitezustand > Status unter „Deine Website verwendet kein HTTPS“.

    Es läuft noch Version 5.3, da der Core sich nicht updaten lies (warum auch immer).

    Und was genau wird da angezeigt? – hast du mal versucht, ein manuelles Update von WP durchzuführen?

    Eine weitere sehr gute Anleitung dazu findest du hier, die vielleicht ebenfalls hilfreich ist. Ein Update ist auf jeden Fall schon aus Sicherheitsgründen zu empfehlen.

    Vorher aber bitte eine vollständige Sicherung erstellen.

    Michi91

    (@michi91)

    @hage danke für die Ergänzungen zum ssl plugin 🙂 konnte den Beitrag von bego nicht so schnell finden 🙂

    @fritz2015 Deine wordpress Version ist tatsächlich zu alt.. 5.9 ist minimum für php 8.1

    Thread-Starter fritz2015

    (@fritz2015)

    Hallo,

    erstmal Entschuldigung an alle, weil ich nichts mehr hab von mir hören lassen (war im Krankenhaus). Danke für die vielen Tipps!

    Mittlerweile läuft meine Website mit PHP 8.1. Das Problem löste sich auf wundersame Weise von selbst: ich hatte eine Kopie mit Hilfe des WPVivid-Plugins auf einen anderen Server, auf dem bereits PHP 8.1. lief, zum Testen migriert. Dort updatete sich WordPress sofort automatisch auf die neueste Version. Die Seiten wurden normal eingebunden angezeigt, Theme und Plugins liefen, Probleme gelöst. Musste nur noch auf dem „richtigen“ Server die PHP-Version umstellen und die Website zurück-migrieren.

    @hage

    hast du mal versucht, ein manuelles Update von WP durchzuführen?

    Danke, super Anleitung. Das mache ich dann beim nächsten Mal.

    @hage

    `Das Plugin Really Simple SSL ist übrigens keine gute Lösung für die Umstellung auf https. …, über WordPress direkt auf https umzustellen, siehe Werkzeuge > Websitezustand > Status unter „Deine Website verwendet kein HTTPS“.
    … Eine weitere sehr gute Anleitung dazu findest du hier, die vielleicht ebenfalls hilfreich ist.

    Wenn ich alles richtig verstanden habe, löst das aber nicht das Problem des Cross-Site-Scriptings, oder? Deswegen hatte ich das Plugin installiert.

    Schöne Grüße,
    Fritz

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,

    Wenn ich alles richtig verstanden habe, löst das aber nicht das Problem des Cross-Site-Scriptings, oder? Deswegen hatte ich das Plugin installiert.

    Ich verstehe nicht, was das mit Cross-Site-Scripting zu tun hat: „Cross-Site-Scripting ist eine Art der HTML-Injection. Cross-Site-Scripting tritt dann auf, wenn eine Webanwendung Daten annimmt, die von einem Nutzer stammen, und diese Daten dann an einen Browser weitersendet, ohne den Inhalt zu überprüfen. Damit ist es einem Angreifer möglich, auch Skripte indirekt an den Browser des Opfers zu senden und damit Schadcode auf der Seite des Clients auszuführen.“ Quelle: Wikipedia.

    Das Plugin Really Simple SSL soll eine Website automatisch konfigurieren, um SSL in vollem Umfang zu nutzen. Das funktioniert aber über die bereits genannten Methoden nicht nur viel besser, sondern man spart sich das Plugin.

    Weitere Informationen zu dem Thema findest du z. B. in dem folgenden (bereits etwas älteren) Beitrag von mir.

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Kurioserweise gibt es von den Entwicklern des Plugins einen Blogbeitrag über Cross-site Scripting mit irgendwelchen vagen Andeutungen, dass es unsicherer Themes und Plugins gibt und deshalb regelmäßig aktualisiert werden sollte – eine Empfehlung, der ich mich gerne anschließe, nur brauche ich dafür das Plugin nicht.

    Ganz verstanden habe ich den Sinn des Beitrags nicht. Der Entwickler hätte genauso gut über die tückischen Gefahren von Fußpilz schreiben können, der genauso wenig mit dem Plugin zu tun hat. So klingt das nach „die Welt ist gefährlich, nimm unser Plugin, macht 39 Euro im Jahr“.

    Ich sehe den Sinn des Plugins Really Simple SSL vor allem darin, technisch unbedarften Nutzern die Einstellung auf eine verschlüsselte Verbindung zu erleichtern. Allerdings brauchst du inzwischen nur noch in Werkzeuge > Website-Zustand auf die Empfehlung achten, die Website zu verschlüsseln. Mit Klick auf den dort angezeigten Button wird die Website vollständig umgestellt – ohne zusätzliches Plugin.

    Thread-Starter fritz2015

    (@fritz2015)

    Ich verstehe nicht, was das mit Cross-Site-Scripting zu tun hat

    Okay, gefährliches Halbwissen. 😉

    Die Website lief schon über https. Aber irgendwas (Theme oder Plugin) hatte ich weiß nicht mehr was (Bilder, Skripte?) per http eingebunden und das führte zu einer Fehlermeldung „Achtung Crosssiteskripting“ (oder so in der Art). Wo die Fehlermeldung war, weiß ich auch nicht mehr (Suchmaschine, Antivirenprogramm?). – tut mir leid, ist schon so ewig her.
    Das Plugin brachte da Abhilfe.

    Schöne Grüße,
    Fritz

    Hallo @fritz2015,
    kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Viele Grüße
    Hans-Gerd

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)