Support » Allgemeine Fragen » Nach Umstellung Auf SSL: 404 für alle Unterseiten

  • Gelöst wollvig

    (@wollvig)


    Hallo liebes WordPress Forum,
    ich sitze nun schon seit 2 Tagen an diesem Problem und wende mich nun in meiner Not an euch.

    Ich habe einen rootserver mit ubuntu auf den ich eine wordpressinstallation migrieren sollte. Hatte alles soweit geklappt und lief gut, die Webseite war über normales http zu erreichen. Nachdem ich über certbot SSL installiert hatte war die Hauptseite mit https erreichbar aber seit diesem Zeitpunkt sind alle Unterseiten (bspw: mydomain.de/abc) nicht mehr erreichbar. In den apache access logs sehe ich ein 404 und der Browser meldet auch ein 404 Not Found.

    Seit heute morgen vergleich ich die Installation mit einer anderen funktionierenden https WordPress instanz auf einem anderen Server und habe jetzt alles exakt so eingerichtet wie ich es dort vorgefunden habe: (natürlich bis auf den jeweiligen Pfad und Datenbanken user, passwörter)

    /etc/apache2/sites-enabled/000-default.conf same
    /etc/apache2/sites-enabled/000-default-le-ssl.conf same
    /etc/letsencrypt/options-ssl-apache.conf same
    /etc/apache2/apache2.conf same

    /var/www/html/wordpress/.htaccess same

    /var/www/html/wordpress/wp-config.php same

    mod_rewrite enabled

    Woran könnte das noch liegen? Danke im Voraus für jede noch so kleine Hilfe!

    Mfg w.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Moderator Bego Mario Garde

    (@pixolin)

    Wurde der Apache-Server nach Aktivierung von mod_rewrite neu gestartet?

    Ist eine .htaccess im Web-Stammverzeichnis angelegt?

    Enthält die .htaccess von WordPress erstellte Redirect-Regeln?

    Hast du Einstellungen > Permalinks geprüft und ggf. nochmal gespeichert? Gab es dabei Hinweise, ob in die .htaccess geschrieben wurde?

    Ist die Option IndexFollowSymlinks in der httpd.conf eingetragen?
    Code dazu:

    <Directory /var/www/html>
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    allow from all
    Require all granted
    </Directory>
    wollvig

    (@wollvig)

    Vielen Dank!
    Der Eintrag in die Host Config hat den Wendepunkt gebracht. Vielen Vielen Dank! 😀

    Kurz der Vollständigkeit halber:

    -Apache habe ich zwischendurch immer wieder neugestartet.
    -Die .htaccess lag in meinem Verzeichnis unter /var/www/html/xyz/

    -Durch das Speichern unter wordpress wurde in die .htaccess geschrieben aber die gleichen Regeln standen dort schon drin, von mir manuell eingetragen.

    Hatte aber alles nichts gebracht. Bis zum Eintrag der oben genannten Zeilen.

    Wünsche Ihnen einen schönen Nachmittag!

    Moderator Bego Mario Garde

    (@pixolin)

    Den wünsche ich dir* auch.

    Schön, dass jetzt alles läuft.
    Ich markiere den Thread noch rasch als „gelöst“.

    (* Wir verwenden hier übrigens, wie in Open Source Communities üblich, das respektvolle „du“.)

    wollvig

    (@wollvig)

    Entschuldige, dass ich erst jetzt antworte, aber danke nochmals für deine* Hilfe.
    Wünsche dir ein schönes Wochenende 🙂

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)