Support » Allgemeine Fragen » Nach Umzug keine interne Verlinkung

  • Gelöst wpseins

    (@wpseins)


    Hallo.
    Nach Umzug von localhost auf den Webspace, kann die Website aufgerufen werden, sobald aber Menüpunkte, Seiten oder Beiträge angeklickt werden, kommt die Fehlermeldung „Internal Server Error“.
    Den Umzug habe ich durch Kopieren und anpassen der SQL-DB und „wp-config.php“ durchgeführt.

    – Kann es sein, dass die internen Verlinkungen auf Seiten und Beiträge nicht mitgeführt wurden? Also auf, http://localhost/wordpress/*blabla* weist?
    – Muss jeder Link einzelnd händisch über den Admin-Zugang angepasst werden?

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Bitte Link zu Seite posten.

    Hast du die Datenbank angepasst? Ich nutze dazu gerne „WP Migrate DB“ Damit erhält man einen Dump der Datenbank, den man dann auf einem anderen Server importieren kann.

    Ich habe folgende Anleitung durch geführt;
    https://www.jonasschindler.de/wordpress-umziehen-anleitung/

    manuell wurde eine neue Datenbank angelegt und anschließend die „funktionierende“ Importiert!

    Gute Erfahrungen habe ich gemacht mit dem Plugin All-in-one WP – Migration – allerdings bei der Migration von der Live-Version auf den lokalen Server. Ich sehe allerdings keinen Grund, warum das nicht auch beim umgekehrten Verfahren möglich sein sollte.
    Bei der Migration kann man dann schon angeben, was ersetzt werden soll.
    Dazu habe ich eine Anleitung erstellt (betrifft aber eben die Migration von Live zur lokalen Version).

    manuell wurde eine neue Datenbank angelegt und anschließend die „funktionierende“ Importiert!

    Wenn du dann aber nicht die URL der lokalen Installation durch die „echte“ ersetzt (z. B.
    http://meine_tolle_webseite.test durch https://meine_tolle_webseite.de), dann hast du natürlich ein Problem. Das muss auch nicht nur in der wp-options ersetzt werden, sondern muss z. B. über „Better Search and Replace“ in allen Tabellen der Instanz ersetzt werden, insbesondere auch wegen der serialisierten Daten.

    Meines Wissens arbeitet WP mit absoluten Links.
    Wo innerhalb der SQL-DB sind diese Links hinterlegt.
    Vielleicht reicht es wenn ich diese manuell ändere?

    Im Nachhineien mit PlugIns zu arbeiten, macht wahrscheinlich keinen Sinn.

    • Diese Antwort wurde geändert vor 1 Monat, 3 Wochen von wpseins.

    Vielleicht reicht es wenn ich diese manuell ändere?

    nein, wegen der Serialisierung der Daten wird es zumindest noch Probleme geben.

    Im Nachhineien mit PlugIns zu arbeiten, macht wahrscheinlich keinen Sinn.

    Warum nicht ? – wie gesagt: wenn du die Migration nicht noch mal neu durchführen möchtest (s. o.), dann lassen sich diese Fehler wahrscheinlich über das Plugin „Better Search and Replace“ korrigieren.
    Vorher aber bitte auf jeden Fall eine Sicherung der Datenbank erstellen.

    Im Nachhineien mit PlugIns zu arbeiten, macht wahrscheinlich keinen Sinn.

    Doch! Das Plugin ist ja offensichtlich dafür erfunden worden!
    Und so nebenbei, du kannst einen Probelauf, also ohne Änderung in der Datenbank laufen lassen! Da kannst du sehen wie viele Änderungen wo durchgeührt werden sollen. Wenn das glaubhaft ist den Hacken bei Testlauf entfernen uns starten.
    Wie geschrieben, eine DB-Sicherung ist vorher Pflicht!
    Und mit All-in-One WP Migration klappt das auch in diese Richtung 😉 Lokal > Server.
    Ich habe zuvor auch NICHT die neue URL angegeben, das richtet das Plugin auch ohne Vorarbeit bestens! Free ist das Plugin bis 512MB Import!

    @jostu55
    vor ein paar Tagen habe ich sogar eine Seite migriert, bei der die Dateigröße mehr als 700 MB betragen hat. Ich war auch ein wenig überrascht, dass das funktionierte, weil ich auch irgendwo gelesen hatte, dass es diese Beschränkung gibt.

    Guten Morgen zusammen.

    Über Nacht ruhen lassen – heute morgen waren alle internen Links vorhanden.
    WebSite läuft!
    Scheinbar braucht die SQL-DB (etwas) Länger um seine Verknüpfungen auf zu bauen.

    Auch benötigte es eine bestimmte Zeit (ca.30Min) bis meine DB erreichbar war, nachdem ich in der SQL änderungen vorgenommen habe.

    • Diese Antwort wurde geändert vor 1 Monat, 3 Wochen von wpseins.

    Dann stimmt aber etwas mit dem Server nicht, denn eigentlich sollte soetwas in wenigen Sekunden erledigt sein.

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)