Support » Allgemeine Fragen » Nach Umzug mit Duplicator werden keine Änderungen mehr gespeichert

  • Gelöst eckhardtjoerg

    (@eckhardtjoerg)


    Guten Morgen Forum,

    ich habe meine Seite „https://www.ochsen-denkendorf.de“ mit dem Duplicator Plugin vom Entwicklungs-Server (hier ging noch alles) auf die endültige Domain umgezogen. Es hat alles wunderbar geklappt, die Seite läuft auch. Leider funktioniert aber der Elementor nicht mehr und ich kann auch sonst keine Seiten mehr absichern. Health Check zeigt „ok“ an. Ich habe bereits alle Plugins zum Test deaktiviert – hat aber nichts gebracht.
    „Was tun sprach Zeus?“

    Hier der Bericht des „Health Check & Troubleshooting“-Plugins:

    
    ### wp-core ###
    
    version: 5.2.3
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/598149_73770/webseiten
    wordpress_size: 75,65 MB (79329454 bytes)
    uploads_path: /kunden/598149_73770/webseiten/wp-content/uploads
    uploads_size: 28,48 MB (29867360 bytes)
    themes_path: /kunden/598149_73770/webseiten/wp-content/themes
    themes_size: 4,88 MB (5119652 bytes)
    plugins_path: /kunden/598149_73770/webseiten/wp-content/plugins
    plugins_size: 58,11 MB (60931367 bytes)
    database_size: 1,95 MB (2040709 bytes)
    total_size: 169,08 MB (177288542 bytes)
    
    ### wp-active-theme ###
    
    name: Palmeria (palmeria)
    version: 1.1.3
    author: MotoPress
    author_website: https://motopress.com
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-background, customize-selective-refresh-widgets, custom-logo, align-wide, editor-color-palette, responsive-embeds, editor-style, custom-header, widgets
    theme_path: /kunden/598149_73770/webseiten/wp-content/themes/palmeria
    
    ### wp-themes-inactive (1) ###
    
    Twenty Nineteen: version: 1.4, author: Das WordPress-Team
    
    ### wp-mu-plugins (2) ###
    
    Elementor Safe Mode: version: 1.0.0, author: Elementor.com
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.0
    
    ### wp-plugins-active (11) ###
    
    Cookie Notice: version: 1.2.46, author: dFactory
    DSGVO All in one for WP: version: 2.3.3, author: Michael Leithold
    Elementor: version: 2.7.0, author: Elementor.com
    Getwid: version: 1.1.1, author: MotoPress
    Health Check & Troubleshooting: version: 1.4.0, author: The WordPress.org community
    Mobile Menu: version: 2.7.4.4, author: Rui Guerreiro
    Really Simple SSL: version: 3.2.5, author: Rogier Lankhorst, Mark Wolters
    Server IP & Memory Usage Display: version: 2.1.0, author: Apasionados, Apasionados del Marketing
    Shortcodes Ultimate: version: 5.4.1, author: Vladimir Anokhin
    UpdraftPlus - Backup/Restore: version: 1.16.16, author: UpdraftPlus.Com, DavidAnderson
    WP Fastest Cache: version: 0.8.9.7, author: Emre Vona
    
    ### wp-plugins-inactive (1) ###
    
    iThemes Security: version: 7.4.1, author: iThemes
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.18.114-pvops-xen-x64 x86_64
    httpd_software: Apache/2.4.39
    php_version: 7.3.6
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 8M
    php_post_max_size: 8M
    curl_version: 7.55.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: false
    server-headers: 
    	date: Tue, 10 Sep 2019 07:22:36 GMT
    	server: Apache/2.4.39
    	x-powered-by: PHP/7.3.6
    	link: <https://www.ochsen-denkendorf.de/wp-json/>; rel="https://api.w.org/", <https://www.ochsen-denkendorf.de/>; rel=shortlink
    	upgrade: h2
    	content-type: text/html; charset=UTF-8
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.19
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/598149_73770/webseiten/wp-content
    WP_PLUGIN_DIR: /kunden/598149_73770/webseiten/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Moderator Bego Mario Garde

    (@pixolin)

    „Funktioniert nicht“ ist keine Fehlerbeschreibung, weil nicht klar wird, was nicht funktioniert und wie es funktionieren sollte. Was passiert denn genau? Bekommst du Fehlermeldungen? Passiert gar nichts? Wie sind deine Arbeitsschritte? Warum hast du das Debugging noch nicht aktiviert?

    Meine erste Vermutung wäre, dass der in der wp-config.php eingetragene Datenbank-Nutzer keine ausreichenden Rechte für die Datenbank hat. Ich weiß aber nicht, wie du die Datenbank und den Benutzer angelegt hast.

    Wie bist du mit dem Cache-Plugin vorgegangen? War das bereits installiert, bevor du die lokale Website archiviert hast? Hast du den Cache mal gelöscht?

    Danke schonmal für die schnelle Rückmeldung.

    Wenn ich auf eine Seite gehe, die ich bearbeiten möchte klicke ich auf „Mit Elementor bearbeiten“ dann erscheint oben ein roter Balken „Aktualisieren fehlgeschlagen“ und der Elementor versucht zu laden es bleibt aber die weiße Seite (Elementor wird geladen…) und nach einigen Sekunden kommt dann die Meldung von Elementor, ob der abgesicherte Modus aktiviert werden soll.
    Bei anderen Seiten (die nicht mit Elementor erstellt wurden) ist es so, dass ich zwar auf die Seite komme und Änderungen vornehmen kann, beim Sichern bzw. Aktualsieren kommt dann aber auch die Meldung „Aktualisieren fehlgeschlagen“.

    Die Datenbank habe ich ganz normal bei DomainFactory angelegt. Ohne jeglichen Einfluss auf Einstellungen, was die Rechte betrifft.

    Das Cache-Plugin habe ich nach dem Umzug installiert. Den Cache habe ich schon mehrfach gelöscht, bringt aber nichts.

    Hier noch die Meldungen aus dem Elementor-Plugin:

    == Server Environment ==
    	Operating System: Linux
    	Software: Apache/2.4.39
    	MySQL version: Source distribution v5.6.19-67.0
    	PHP Version: 7.3.6
    	PHP Max Input Vars: 1000
    	PHP Max Post Size: 8M
    	GD Installed: Yes
    	ZIP Installed: Yes
    	Write Permissions: All right
    	Elementor Library: Connected
    
    == WordPress Environment ==
    	Version: 5.2.3
    	Site URL: https://ochsen-denkendorf.de
    	Home URL: https://www.ochsen-denkendorf.de
    	WP Multisite: No
    	Max Upload Size: 8 MB
    	Memory limit: 256M
    	Permalink Structure: /%postname%/
    	Language: de-DE
    	Timezone: Europe/Berlin
    	Debug Mode: Inactive
    
    == Theme ==
    	Name: Palmeria
    	Version: 1.1.3
    	Author: MotoPress
    	Child Theme: No
    
    == User ==
    	Role: administrator
    	WP Profile lang: de_DE
    	User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:68.0) Gecko/20100101 Firefox/68.0
    
    == Active Plugins ==
    	Cookie Notice
    		Version: 1.2.46
    		Author: dFactory
    
    	DSGVO All in one for WP
    		Version: 2.3.3
    		Author: Michael Leithold
    
    	Elementor
    		Version: 2.7.0
    		Author: Elementor.com
    
    	Getwid
    		Version: 1.1.1
    		Author: MotoPress
    
    	Health Check & Troubleshooting
    		Version: 1.4.0
    		Author: The WordPress.org community
    
    	Mobile Menu
    		Version: 2.7.4.4
    		Author: Rui Guerreiro
    
    	Really Simple SSL
    		Version: 3.2.5
    		Author: Rogier Lankhorst, Mark Wolters
    
    	Server IP & Memory Usage Display
    		Version: 2.1.0
    		Author: Apasionados, Apasionados del Marketing
    
    	Shortcodes Ultimate
    		Version: 5.4.1
    		Author: Vladimir Anokhin
    
    	UpdraftPlus - Backup/Restore
    		Version: 1.16.16
    		Author: UpdraftPlus.Com, DavidAnderson
    
    	WP Fastest Cache
    		Version: 0.8.9.7
    		Author: Emre Vona
    
    == Must-Use Plugins ==
    	Health Check Troubleshooting Mode
    		Version: 1.7.0
    		Author: 
    
    == Log ==
    	
    JS: showing 3 of 3JS: 2019-08-28 15:18:05 [error X 5][http://ochsen-denkendorf.de/wp-content/plugins/elementor/assets/lib/inline-editor/js/inline-editor.min.js?ver=2.6.8:1:3196] Object.values is not a function. (In \'Object.values(e)\', \'Object.values\' is undefined) 
    JS: 2019-09-09 12:07:07 [error X 26][http://ochsen-denkendorf.de/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.6.8:7:0] Permission denied to access property \"elementorFrontend\" on cross-origin object 
    JS: 2019-09-09 13:57:03 [error X 3][https://ochsen-denkendorf.de/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.7.0:7:49498] i is undefined 
    
    Log: showing 9 of 92019-09-09 14:08:57 [info] elementor::elementor_updater Started 
    2019-09-09 14:08:57 [info] Elementor/Upgrades - _v_2_7_0_rename_document_types_to_wp Start  
    2019-09-09 14:08:57 [info] Elementor/Upgrades - _v_2_7_0_rename_document_types_to_wp Finished 
    2019-09-09 14:08:57 [info] Elementor/Upgrades - _v_2_7_0_remove_old_usage_data Start  
    2019-09-09 14:08:57 [info] Elementor/Upgrades - _v_2_7_0_remove_old_usage_data Finished 
    2019-09-09 14:08:57 [info] Elementor/Upgrades - _v_2_7_0_recalc_usage_data Start  
    2019-09-09 14:08:58 [info] Elementor/Upgrades - _v_2_7_0_recalc_usage_data Finished 
    2019-09-09 14:08:58 [info] Elementor data updater process has been completed. [array (
      'plugin' => 'Elementor',
      'from' => '2.6.8',
      'to' => '2.7.0',
    )]
    2019-09-09 14:08:58 [info] Elementor data updater process has been queued. [array (
      'plugin' => 'Elementor',
      'from' => '2.6.8',
      'to' => '2.7.0',
    )]
    
    PHP: showing 1 of 1PHP: 2019-09-09 15:50:16 [warning X 1][/kunden/598149_73770/webseiten/wp-content/plugins/elementor/modules/safe-mode/module.php::107] rmdir(/kunden/598149_73770/webseiten/wp-content/mu-plugins): Directory not empty [array (
      'trace' => '
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ',
    )]
    
    == Elements Usage ==
    	
    	Seite
    		Abstand : 1
    		Basic Gallery : 2
    		Bild : 7
    		Shortcode : 1
    		Text-Editor : 8
    		Trenner : 9
    		Überschrift : 1
    • Diese Antwort wurde geändert vor 1 Woche, 5 Tagen von  Bego Mario Garde. Grund: Codeformatierung hinzugefügt
    Moderator Bego Mario Garde

    (@pixolin)

    Geh doch bitte mal ins Backend und …

    1. Prüfe unter Einstellungen > Allgemein die Website- und WordPress-URL.
      • Haben beide das gleiche Schema (https://)?
      • Beginnen beide mit www?
    2. Deaktviere das Plugin Really Simple SSL, du brauchst es meiner Meinung nach nicht, wenn die Website korrekt auf https umgestellt wurde.

    Klappt die Aktualisierung in Elementor dann?

    Super!!!
    Das war’s – vielen Dank!!!

    Moderator Bego Mario Garde

    (@pixolin)

    Schön. Und demnächst dran denken:

    Wenn’s richtig läuft, du hast’s kapiert,
    werden Themen als „gelöst“ markiert,
    damit auch alle in der Runde wissen,
    dass sie hier nicht mehr helfen müssen.
    🌻

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)