Support » Allgemeine Fragen » Nach Umzug von Unterordner auf Root Probleme mit Editor (dringend)

  • Gelöst nichtrick

    (@nichtrick)


    Hallo Leute,

    ich habe ein wirklich nerviges Problem. Ich habe eine neue WordPressseite in einem Unterordner aufgesetzt. Sagen wir meineurl.de/wordpress/.

    Nachdem die Seite Fertig war habe ich in den Einstellungen die Url von meineurl.de/wordpress/ auf meineurl.de geändert und die Domain auf diesen Server zeigen lassen.

    Alles super. Hat geklappt wie immer. Alles läuft nach Umzug gut.

    Wenn ich jetzt aber eine Seite bearbeiten will, bekomme ich folgenden Fehler:

    Failed to load plugin: wordpress from url http://meineurl.de/wp-includes/js/tinymce/plugins/wordpress/plugin.min.js

    Der visuelle Editor funktioniert nicht mehr.

    Die Konsole gibt mir folgende Fehlermeldungen aus:

    Failed to load resource: the server /wp-includes/js/tinymce/plugins/wordpress/plugin.min.js?wp-mce-4607-20180123

    Die plugin.mon.js Datei liegt aber in diesem Ordner.

    Wegen des Anhangs ?wp-mce-4607-20180123 befürchte ich es hat etwas mit einem Cache zu tun?

    Habe schon den gesamten WordPress Cache geleert. WordPress manuell neuinstalliert (Files bis auf config überschrieben) und natürlich auch den Browser Cache. Ich finde nirgends eine brauchbare Lösung.

    Könnt ihr mir evtl weiter helfen

Ansicht von 5 Antworten - 16 bis 20 (von insgesamt 20)
  • Hey Thorsten,

    ich habe auch mit einem Datenbanktool mal alles mit Suchen und Ersetzen versucht. Auch keine Änderung.

    Als alles noch über meineurl.de/wordpress/ erreichbar war ging alles. nach der Umleitung auf den Subfolder geht der Visuelle Editor nicht mehr.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    ich habe auch mit einem Datenbanktool mal alles mit Suchen und Ersetzen versucht. Auch keine Änderung.

    Welches? Unterstützt dein Tool serialisierte Daten?

    Du hast nicht auf meine Frage geantwortet:

    Was passiert denn, wenn du versucht die Datei direkt aufzurufen?
    http://example.de/wp-includes/js/tinymce/plugins/wordpress/plugin.min.js

    Welche Fehlermeldung kommt dann? (Ich nehme an, es kommt eine …)

    Gruß, Torsten

    Es kommt einfach eine 404 auf WordPress, wenn ich die Datei direkt aufrufen will.

    Habe mit einem Suchen & Ersetzen Tool alles ersetzt. Sogar nochmal manuell in der Datenbank.

    Der Firefox Debugger zeigt auch an:

    Laden fehlgeschlagen für das <script> mit der Quelle „http://www.meineurl.de/wp-includes/js/tinymce/plugins/wordpress/plugin.min.js?wp-mce-4607-20180123&#8220;.

    Ich weiß nicht was diese Parameter da sollen. Versucht er auf eine gecachte Ressource zuzugreifen?

    • Diese Antwort wurde geändert vor 1 Jahr, 12 Monate von nichtrick.
    Moderator Torsten Landsiedel

    (@zodiac1978)

    Es kommt einfach eine 404 auf WordPress, wenn ich die Datei direkt aufrufen will.

    Dann stimmen vermutlich Rechte/Besitzer von der Datei nicht. Die Datei sollte normal aufzurufen sein. Wenn dein Server einen 404 zurück gibt, dann stimmt also irgendwas nicht. Da die .htaccess allerdings okay ist und du auch WordPress schon neu installiert hast, ist das jetzt echt schwer von außen zu beurteilen.

    Hast du mal deinen Hoster-Support gefragt?

    Der Parameter ist nur dazu da, um bei einem TinyMCE-Update den Browser-Cache zu invalidieren, damit es da keine Konflikte gibt.

    Gruß, Torsten

    Hallo Leute,

    zunächst einmal: Vielen Dank für euren Einsatz! Ich habe die Lösung gefunden. Auch da ich durch die Beiträge Stück für Stück andere Dinge ausschließen konnte.

    Das Problem lag tatsächlich in der RewriteCond.

    Diese besagt: Leite alle Anfragen, die nicht wordpress/ enthalten auf
    /wordpress/ um. (Ich wollte die Hauptdomain ja in den Ordner „wordpress“ weiterleiten…)

    Der Pfad der plugin.min.js enthält jedoch wordpress, also wird die Anfrage für
    diese Datei nicht umgeschrieben und es wird versucht, die Datei in
    http://www.meineurl.de/wp-includes/js/tinymce/plugins/wordpress/plugin.min.js
    zu finden.

    Ich musste also lediglich Die Installation in den Root verschieben und die Umleitung in der .htaccess raus nehmen.

Ansicht von 5 Antworten - 16 bis 20 (von insgesamt 20)
  • Das Thema „Nach Umzug von Unterordner auf Root Probleme mit Editor (dringend)“ ist für neue Antworten geschlossen.