Support » Installation » nach Umzug weisen die Links auf eine leere weiße Seite

  • Gelöst lorndal

    (@lorndal)


    Hallo,
    nachdem ich einen Shop von Strato mit dem Plugin „All-in-One WP Migration“ auf den firmeneigenen Server umgezogen habe, funktioniert kein einziger Link mehr.
    Jeder Link, ob auf eine Shop-Kategorie oder eine gewöhnliche Seite öffnet sich in einer weißen Seite mit der Info:

    Not Found
    The requested URL /events/ was not found on this server.

    Apache/2.4.29 (Ubuntu) Server at whatsoever.de Port 443

    -In der DB sind alle URL´s richtig gesetzt. Die alte URL ist nirgends wo in der DB zu finden.
    -Ein SSl-Zertifikat war vorher schon mit drin und ist jetzt auch aktiv.
    -Es gibt diverse Plugins, wie „Premmerce Permalink Manager for WooCommerce“ aber auch wenn ich alle erstmal nicht so wichtigen Plugins deaktiviere funktionieren keine Links.

    Zuerst ging ich davon aus, dass dieser firmeneigene Server nicht richtig konfiguriert ist! Dass beim SSL-Zertifikat etwas fehlt denn das Plugin „Really Simple SSL“ sagt: Really Simple SSL hat von der Webseite keine Antwort erhalten.

    Kann dies der Fall sein?
    In der DB sind die Kategorien vorhanden.

    Weiss jemand Rat?

    Vielen Dank, herzlichst S

    Moderationshinweis: Aus „WooCommerce“ in Forum „Installation“ verschoben, da es hier vermutlich nicht vorrangig um ein Problem mit dem Plugin WooCommerce geht.

    • Dieses Thema wurde geändert vor 11 Monaten, 2 Wochen von Bego Mario Garde. Grund: Moderationshinweis: In Installation verschoben
Ansicht von 10 Antworten - 31 bis 40 (von insgesamt 40)
  • keine Änderung.
    habe jetzt auch noch folgende Änderungen beim sysadmin durchführen lassen:

    /etc/apache2/sites-available
    In 000-default.conf
    AllowOverride All

    und
    sudo a2enmod rewrite
    sudo service apache2 restart

    Permalinks im Backend zurückgestellt, cache gelöscht, wieder auf Wunsch-Permalinks gesetzt:
    ERGEBNIS
    NOT FOUND

    Und nun?

    Es ging ja auch um Options Indexes FollowSymLinks.

    Du könntest ja mal mit Local by Flywheel einen lokalen Server auf deinem Rechner aufsetzen und die Website dort klonen. Liegt das Problem nicht an der Serverkonfiguration, müsste es ja in der geklonten Version auch auftreten.

    Aber ansonsten … sorry, da bin ich im Moment überfragt.

    die content-Seite Test lässt sich nun auch nichtmal über das Backend als Vorschau öffnen, was zuvor ging !!!

    Menno !!!1!elf!

    Warum hast du die Änderung in die Site-Configuration (000-default.conf) und nicht in die Service-Configuration (httpd.conf) geschrieben? Scheint OK zu sein. Keine Ahnung, ob dann ein explizites a2enmodsite 000-default; systemctl restart apache2; noch nötig ist, um den Eintrag zu übernehmen.

    • Diese Antwort wurde geändert vor 11 Monaten, 1 Woche von Bego Mario Garde. Grund: Nachtrag

    Ist das eigentlich ein Linux- oder Windows/IIS-Server?

    also ich habe die Umzugsschritte nun 1:1 zu mir hier auf localhost wiederholt und es läuft alles gleich von Anfang an reibungslos !

    Offensichtlich ein Problem mit der Serverkonfiguration.

    es ist ein Ubuntu 18.04 LTS Server

    Hallo nochmal,
    nur zur allgemeinen Info:

    folgende 2 Zeilen haben in der apache/httpd.conf noch gefehlt:

    Order allow,deny
    Allow from all

    <Directory „/Applications/XAMPP/xamppfiles/apache2/htdocs“>
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    Damit funktionieren jetzt auch die entsprechenen Permalinks.

    Vielen Dank nochmal für alles.

    Viele Grüße S

    Mühsames Unterfangen für eine Fehlkonfiguration des Webservers …

    Schön, dass es jetzt klappt. Ich markiere den Thread dann mal als „gelöst“.

Ansicht von 10 Antworten - 31 bis 40 (von insgesamt 40)
  • Das Thema „nach Umzug weisen die Links auf eine leere weiße Seite“ ist für neue Antworten geschlossen.