Support » Allgemeine Fragen » Nach Update auf 5.6 Probleme mit Theme

  • Gelöst Thorsten

    (@hobbyfahrer)


    Hallo,

    nach dem Update auf 5.6 habe ich nun in der Darstellung meines Themes AdventurePress Probleme.

    Ich habe den Entwickler schon angeschrieben aber leider gab es in der Vergangenheit nicht immer eine Lösung bei Problemen.

    Auf meiner Startseite werden immer die neuesten Beitrage durchlaufend angezeigt aber dieser Bereich wird nicht mehr geladen.

    Gibt es Anmerkungen was ich machen kann?

    Danke für die Hilfe.

    • Dieses Thema wurde geändert vor 1 Jahr, 1 Monat von Thorsten.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Moderator Bego Mario Garde

    (@pixolin)

    Seit Update auf WordPress 5.5 werden einige veraltete JavaScript-Bibliotheken nicht mehr unterstützt. Wenn du ein älteres Theme verwendest, kann das Ursache für die genannten Probleme sein. Bis der Theme-Entwickler ein Update liefert kannst du als Übergangslösung das Plugin Enable jQuery Migrate Helper nutzen. Probier mal, ob damit die Probleme verschwinden.

    Thread-Ersteller Thorsten

    (@hobbyfahrer)

    Danke werde ich probieren aber mit 5.5 lief alles ohne Probleme

    Thread-Ersteller Thorsten

    (@hobbyfahrer)

    Leider löster das Plugin nicht das Problem. Mist!

    jQuery Migrate Helper — Warnings encountered
    
    Diese Seite erzeugte folgende Warnungen:
    https://hobbyfahrer.de/wp-admin/js/common.min.js: jQuery.fn.delegate() is deprecated
    https://hobbyfahrer.de/wp-content/plugins/tiny-compress-images/src/js/dashboard-widget.js: jQuery.fn.resize() event shorthand is deprecated
    https://hobbyfahrer.de/wp-content/plugins/tiny-compress-images/src/js/dashboard-widget.js: jQuery.fn.click() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/media-upload.min.js: jQuery.fn.resize() event shorthand is deprecated
    https://hobbyfahrer.de/wp-content/plugins/wordpress-seo-premium/js/dist/api-client-1540.js:1:440: jQuery.isFunction() is deprecated
    https://hobbyfahrer.de/wp-content/plugins/tiny-compress-images/src/js/admin.js: jQuery.fn.click() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/common.min.js: jQuery.fn.click() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/common.min.js: jQuery.fn.bind() is deprecated
    https://hobbyfahrer.de/wp-admin/js/common.min.js: jQuery.fn.mousedown() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/common.min.js: jQuery.fn.focus() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/site-health.min.js: Number-typed values are deprecated for jQuery.fn.css( "strokeDashoffset", value )
    https://hobbyfahrer.de/wp-admin/js/edit-comments.min.js: jQuery.fn.bind() is deprecated
    https://hobbyfahrer.de/wp-admin/js/edit-comments.min.js: jQuery.fn.click() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/edit-comments.min.js: jQuery.fn.keypress() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/edit-comments.min.js: jQuery.fn.dblclick() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/dashboard.min.js: jQuery.fn.click() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/postbox.min.js: jQuery.unique is deprecated; use jQuery.uniqueSort
    https://hobbyfahrer.de/wp-admin/js/postbox.min.js: jQuery.isFunction() is deprecated
    https://hobbyfahrer.de/wp-admin/js/postbox.min.js: jQuery.fn.click() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/postbox.min.js: jQuery.fn.bind() is deprecated
    https://hobbyfahrer.de/wp-admin/js/dashboard.min.js: jQuery.fn.submit() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/dashboard.min.js: jQuery.isFunction() is deprecated
    https://hobbyfahrer.de/wp-admin/js/plugin-install.min.js: jQuery.fn.resize() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/plugin-install.min.js: jQuery.fn.click() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/updates.min.js: jQuery.fn.change() event shorthand is deprecated
    https://hobbyfahrer.de/wp-admin/js/svg-painter.js: jQuery.fn.hover() is deprecated
    https://hobbyfahrer.de/wp-content/plugins/tiny-compress-images/src/js/admin.js: jQuery.fn.unbind() is deprecated
    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von Thorsten.
    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von Bego Mario Garde.
    Thread-Ersteller Thorsten

    (@hobbyfahrer)

    Leider löst das Plugin nicht das Problem und habe nun eine Fehlerlsite vom Plugin.

    Moderator Bego Mario Garde

    (@pixolin)

    Schade, das Plugin war dann offensichtlich nicht die Lösung.
    Du kannst es bitte wieder löschen.

    Scheinbar hat die JavaScript-Funktion einen Programmierfehler, der sich auf weitere JavaScript-Funktionen auswirkt. Ohne Einblick in den Code des Themes kann ich da aber nicht weiterhelfen. Bitte wende dich an den Theme-Entwickler.

    Vorerst kannst du dir behelfen, indem du mit dem Plugin WP Rollback auf die vorherige Version zurückgehst.

    Moderator Bego Mario Garde

    (@pixolin)

    Dein Beitrag mit den Fehlermeldungen, die „Enable Migrate Helper“ ausgibt, weisen allerdings doch auf veraltete jQuery-Bibliotheken hin. So gesehen wäre es nicht verkehrt, wenn du das Plugin verwendest.

    Nach Aktivierung des Plugins kannst du unter Werkzeuge > jQuery Migrate die ältere „Legacy“-Version von jQuery aktivieren.

    (Der Beitrag war von der Foren-Software zur Moderation zurückgehalten worden, deshalb die verspätete Reaktion.)

    Thread-Ersteller Thorsten

    (@hobbyfahrer)

    Hallo,

    der Theme Hersteller schreibt mir nun:

    Hello Hobbyfahrer,

    AdventurePress theme is tested, and it is fully compatible with the latest WP version (3.6): https://prnt.sc/vz0ncg and http://capethemes.com/demo/adventurepress/
    I’ve got ‚internal server error‘ on your site so check out your plugins, addons or contact your hosting provider.
    https://prnt.sc/vz0pea

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von Thorsten.
    Thread-Ersteller Thorsten

    (@hobbyfahrer)

    Ich habe weiter getestet.

    Schalte ich WP Rocket ab läuft die Seite wieder auch ohne „Enable Migrate Helper“. Es muss also etwas mit dem Cache zu tun haben aber was?

    Wie soll ich das WP Rocket technisch erklären?

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von Thorsten.
    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von Thorsten.
    Moderator Bego Mario Garde

    (@pixolin)

    Mit dem Plugin Autoptimize kannst du (wie auch bei WP Rocket) JavaScript-Dateien zusammenfassen und komprimieren. Das scheint aber in der neuen WordPress-Version Probleme zu bereiten. Der Plugin-Autor von Autoptimize empfiehlt, jQuery davon auszunehmen (js/jquery/jquery.min.js). Probier doch mal, ob sich das in WP Rocket auch umsetzen lässt.

    Thread-Ersteller Thorsten

    (@hobbyfahrer)

    Deaktiviere ich in WP Rocket die Funktion

    Remove jQuery Migrate
    (Remove jQuery Migrate eliminates a JS file and can improve load time)

    funktioniert meine Seite wieder.

    Moderator Bego Mario Garde

    (@pixolin)

    Ja, scheint zu funktionieren – Problem gelöst?

    Hello,

    hatten auch Probleme nach dem Upgrade auf WordPress 5.6 und dem gleichzeitigen Update von WP Rocket. Irgendwas scheint bei WP Rocket da nicht zu klappen, das auch noch als ungetestet markiert ist.

    Unter anderem funktionierten die Editor oembeds nicht mehr, generell war das gesamte Backend super langsam.

    Nutzen erstmal die WP Rocket Version 3.6.4 weiter, mit der geht alles ohne Probleme.

    Moderator Bego Mario Garde

    (@pixolin)

    @trooper_d5x

    Bei Fragen zu gekauften Plugins (hier: WP Rocket) können wir dir nicht weiterhelfen, weil sie uns für einen kostenlosen Support nicht kostenlos zur Verfügung stehen.

    Bitte wende dich an die Entwickler des Plugins.

    Thread-Ersteller Thorsten

    (@hobbyfahrer)

    @pixolin

    Ja bei mir ist das Problem gelöst.

    Danke

    Moderator Bego Mario Garde

    (@pixolin)

    @hobbyfahrer Denkst du bitte künftig daran, den Thread dann als „gelöst“ zu markieren? Das hilft uns bei der Auswahl der Themen, bei denen noch Hilfe benötigt wird. Dankeschön.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Das Thema „Nach Update auf 5.6 Probleme mit Theme“ ist für neue Antworten geschlossen.