Support » Allgemeine Fragen » Nach Update auf WordPress 6.4.1 kein Zugriff mehr

  • Gelöst mengana

    (@mengana)


    Hallo

    Nach einer Update letzte Woche habe ich keinen Zugriff mehr auf der Website. Auch nicht auf Backend: egal ob ich https://psycho-basel.ch/ oder https://psycho-basel.ch/admin/ eingebe, lande ich auf gleiche Seite.

    Ich habe versucht auch im Control Panel des Servers die PHP Einstellung zu ändern:

    Die aktuelle Einstellung ist PHP 7.4

    Wenn ich sie auf PHP Version 8.0. 8.1 oder 8.2 ändere, bekomme ich die Meldung: There has been a critical error on this website

    Vielen Dank im Voraus für eure Hilfe.

    Schöne Grüsse

    Bettina

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hallo,
    du solltest dich wieder im Backend anmelden können, wenn du
    https://psy...el.ch/wp-login.php
    eingibst (das wäre auch die „normale“ Möglichkeit, um sich anzumelden).
    Deine Domain musst du natürlich korrekt eingeben. Ich habe bewusst die Angabe der Domain hier verändert.

    Viele Grüße
    Hans-Gerd

    Thread-Starter mengana

    (@mengana)

    Danke Hans-Gerd für die schnelle Antwort. Jetzt hat es geklappt.

    Problem macht offenbar der Plugin Polylang. Ich habe ihn deaktiviert und die Seite ist wieder aufrubbar, allerdings nur auf DE. Ich werde einen anderen Plugin suchen oder so was.

    Vielen Dank nochmals 🙂

    • Diese Antwort wurde geändert vor 5 Monaten, 1 Woche von mengana.

    Hallo,
    so einfach wirst du für das Plugin Polylang keinen Ersatz finden, weil die Mehrsprachigkeit bei diesem Plugin anders geregelt ist als bei ähnlich gelagerten Plugins in dem Bereich.
    Ich gehe eher davon aus, dass das Problem andere Gründe hat. Das solltest du genauer analysieren.

    Viele Grüße
    Hans-Gerd

    Thread-Starter mengana

    (@mengana)

    Hallo Hans-Gerd, das ist aber komisch. Ich habe Polylang wieder aktiviert und jetzt funktioniert alles tipp-topp. Strange……

    Hallo,
    immerhin: Besser als wenn das Problem noch besteht. 😉

    Seltsam ist es aber doch. Viellicht ist es sinnvoll, wenn du debug einschaltest und dir das mal ansiehst:

    Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.
    Gib dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du define('WP_DEBUG', false); überschreibst, falls die Zeile bereits in der wp-config.php steht. Wenn versucht wird, diese Konstante ein zweites mal zu definieren, gibt es einen Fehler, der deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen sagen wir WordPress, dass der Debug-Modus aktiviert werden soll. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden.
    Wenn der Fehler gefunden wurde bzw. wenn die Fehler nicht mehr in die debug.log geschrieben werden sollen, dann musst du daran denken, die Variable
    define( 'WP_DEBUG_LOG', true );
    wieder auf false zu setzen:
    define( 'WP_DEBUG_LOG', false);

    Einen entsprechenden Beitrag, wie man das auch mit Verwendung eines Plugins macht, findest du hier.

    Viele Grüße
    Hans-Gerd

    Thread-Starter mengana

    (@mengana)

    ganz, ganz herzlichen Dank für die detaillierte Einleitung. Ich werde es ausprobieren 🙂

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)