Support » Allgemeine Fragen » Nach Update auf WP 4.2.2 Mediathek und Beitragsbilder weg

  • Gelöst seemoewe67

    (@seemoewe67)


    Ich brauche mal Euren Rat:

    Mir hat’s gestern meine Webseite zerschossen.

    Gestern habe ich WP aktualisiert auf die Version 4.2.2 Zuvor hatte ich mit UpdraftPlus eine Sicherung gemacht. Da gab es schon die erste Fehlermeldung, nämlich, dass die ZIP-Datei nicht richtig erstellt werden kann.

    Ich hatte blöderweise vor dem Update meine Plugins nicht deaktiviert. Jedenfalls ist es jetzt so, dass nach dem Update meine Mediathek leer ist (obohl auf dem Server die Bilder vorhanden sind). In meinen Blogbeiträge sind die Beitragsbilder nicht mehr zu sehen.

    Die Menueleiste ist auf meiner Seite http://www.sylvia-geiss.de nicht mehr zu sehen. Und meine Seiten wurden in die Beiträge verschoben.

    So viel auf einmal, was da nicht mehr funktioniert. Ich könnte heulen.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Auf dem Umschlag des bemerkenswertesten Buch, das die großen Verlage von Ursa Minor je herausbrachten, steht in großen freundlichen Lettern: Don’t Panic.

    Eine mögliche Ursache für die genannten Probleme könnte sein, dass auf dem zugewiesenen Webspace nicht mehr genug Speicherplatz zur Verfügung steht und die Aktualisierung nur unvollständig vorgenommen wurde. Ich würde erst einmal per FTP-Programm oder über das Dateiverwaltungsmenü deines Web Hosts alle Dateien mit folgenden Ausnahmen zu löschen:

    • Konfigurationsdatei wp-config.php
    • (sofern vorhanden) Konfigurationsdatei .htaccess
    • Verzeichnis wp-content

    Danach besorgst du dir einen neuen Dateiensatz, entpackst ihn und löschst aus diesen Dateien das Verzeichnis wp-content. Danach lädst du die verbleibenden Dateien und Verzeichnisse per FTP auf deinen Webserver hoch (dort hin, wo du vorher die Dateien gelöscht hast).

    Wenn der Upload abgeschlossen ist, solltest du dich wieder in WordPress anmelden können und auch deine Mediendateien wieder sehen. Falls nicht, meldest du dich bitte wieder. Und wie gesagt: Keine Panik. 🙂

    Vielen Dank. Meine Seiten, die in den Ordner „Beiträge“ verschoben wurden, hatte ich inzwischen bereits manuell wiederhergestellt, damit die Homepage für Besucher nicht allzu schlimm aussieht.

    Bin eben Deinen Anweisungen gefolgt. In der Mediathek ist immer noch nichts zu sehen. Und auf meinen Seiten bzw. in den Blog-Beiträgen sind die Beitragsbilder nicht zu sehen. In den Blog-Texten selbt waren hin und wieder auch Bilder eingefügt, die werden komischerwiese angezeigt, nur die Beitragsbilder oben nicht. Das ist zwar kein Weltuntergang, sieht aber für den Betrachter blöd aus. Und mich würde schon interessieren, wie ich meine Bilder wieder in der Mediathek sehen kann.

    Wäre für einen Hinweis dankbar.

    LG

    Kannst du mal ein Beispiel nennen?
    Z.B. auf der Webseite „Rezepte aus der Natur“ sehe ich ein Beitragsbild.

    Hast du mal versucht, den Browser-Cache zu leeren?

    Ja, denn ich habe auf den Seiten die Beitragsbilder von Hand wieder neu eingefügt, d. h. neu hochgeladen und als Beitragsbild festgelegt.
    Aber auf den Blogbeiträgen, z. B. http://sylvia-geiss.de/bist-du-gut-verwurzelt/ oder http://sylvia-geiss.de/achat-edelstein-der-froehlichkeit/
    fehlen die Beitragsbilder noch.

    Browser-Cache habe ich gerade geleert. Trotzdem keine Beitragsbilder da. Wenn ich in den Blogbeitrag reingehe, muss ich das Beitragsbild neu festlegen. Es ist gar nicht mehr drin.

    Das ist eher ungewöhnlich. Bei einer Aktualisierung werden die Dateien ausgetauscht, während die Datenbank (in der die Informationen zu Beitragsbildern gespeichert werden) bis auf eine Aktualisierung der Datenbank unverändert bleibt.

    Sind die Beitragsbilder denn auf dem Webserver noch vorhanden?

    Du könntest auch mal das Plugin WP DB Manager installieren und eine Reparatur und Optimierung der Datenbanktabelle anstoßen.

    Vielen Dank, mein Problem hat sich inzwischen gelöst. Es lag an der Speicherkapazität. Ich benutze Strato und hatte noch ein uraltes Web-Paket, das ich upgraden musste. Jetzt passt es wieder.
    Vielen Dank für die hilfreichen Tipps und Hinweise.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „Nach Update auf WP 4.2.2 Mediathek und Beitragsbilder weg“ ist für neue Antworten geschlossen.