Support » Themes » Nach Update fehlen wichtige Teile im Backend

  • Gelöst bettinette101

    (@bettinette101)


    Hallo zusammen,

    auf der Seite, die ich betreue, ist das Avada-Thema installiert. Sie ist auf Strato gehostet. Die PHP-Version ist 8.0.
    Vermutlich seit dem letzten WP-Update auf 6.0.1 fehlen in der Seitenleiste im Backend wichtige Bereiche, wie „Design“, (und somit der „Customizer“ und „Widgets“ etc.) „Plugins“, „Einstellungen“ sowie alle Avada-Funktionen Fusion-Builder und Fusion-Core.
    Über FTP habe ich Avada auf die aktuelle Version 7.8.1 upgegradet. Ebenfalls über FTP habe ich einzelne Plugins gelöscht und neu installiert.

    Nach dem Avada-Update hat sich die Seite lediglich dahingehend verändert, dass viele Bilder im Front-end fehlen, welche aber im Backend alle sichtbar sind.

    Textliche Änderungen sind auf der Seite weiterhin über Live-Edit und auch normal über „Seiten“ möglich. Änderungen zu Form, Farbe etc. sind nur sehr eingeschränkt oder gar nicht möglich, das nicht der volle Zugriff auf den Page-Builder verfügbar ist. Da ich aber Änderungen im Footer vornehmen muss, der als Widget hinterlegt ist, ist mir dies nicht möglich. Bei Versuchen über „Edit Live“ auf z. B. Avada Layouts zuzugreifen, erfolgt die Meldung, dass ich dazu keine Berechtigung habe.

    Yoast SEO wird zwar noch in der Seitenleiste angezeigt, allerdings stehen mir hier keinerlei Funktionen ohne Premium-Account mehr zur Verfügung.

    Leider habe ich nirgends ein ähnliches Problem finden können. Hat jemand dieselben oder ähnliche Erfahrungen gemacht oder weiß, was ich hier noch ausprobieren kann?

    Danke schon mal für Eure Hilfe.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Zu erst einmal würde ich dir empfehlen https in den Einstellungen zu setzen.
    Am besten unter http://www.bauchgefuehl-schwangerschaftsmode.de/wp-admin/options-general.php bei „WordPress-Adresse (URL)“ und „Website-Adresse (URL)“ mit https anfangen. SSL Zertifikat ist vorhanden.

    Kommst du auf https://www.bauchgefuehl-schwangerschaftsmode.de/wp-admin/site-health.php und bekommst dort Hinweise?

    Am besten unter http://www.b***mode.de/wp-admin/options-general.php bei „WordPress-Adresse (URL)“ und „Website-Adresse (URL)“ mit https anfangen. SSL Zertifikat ist vorhanden.

    In dem Fall ist es besser, bei Werkzeuge > Website-Zustand der Empfehlung zu folgen, die Website auf https umzustellen und einfach den Link anzuklicken, der dabei angeboten wird. Das erspart die mühsame Ersetzung der URL in den Datenbanktabellen.

    Thread-Starter bettinette101

    (@bettinette101)

    Kommst du auf https://www.bauchgefuehl-schwangerschaftsmode.de/wp-admin/site-health.php und bekommst dort Hinweise?

    Hier kommt leider auch die Meldung, dass ich keine Berechtigung habe, darauf zuzugreifen.

    Thread-Starter bettinette101

    (@bettinette101)

    In dem Fall ist es besser, bei Werkzeuge > Website-Zustand der Empfehlung zu folgen, die Website auf https umzustellen und einfach den Link anzuklicken, der dabei angeboten wird. Das erspart die mühsame Ersetzung der URL in den Datenbanktabellen.

    Die Seite ist komplett leer, außer der Überschrift „Werkzeuge“.

    Thread-Starter bettinette101

    (@bettinette101)

    Zu erst einmal würde ich dir empfehlen https in den Einstellungen zu setzen.
    Am besten unter http://www.bauchgefuehl-schwangerschaftsmode.de/wp-admin/options-general.php bei „WordPress-Adresse (URL)“ und „Website-Adresse (URL)“ mit https anfangen. SSL Zertifikat ist vorhanden.

    Hier erscheint ebenfalls die Meldung, dass ich nicht berechtigt bin, darauf zuzugreifen.

    Hallo,
    du hast aber bis jetzt immer Adminrechte gehabt?
    Hast du die Anmeldung auch mal in einem anderen Browser und/oder im Inkognito-Modus von Chrome getestet ?
    Das könnte mit dem Anmelde-Cookie im Browser zusammenhängen, weitere Infos siehe hier

    Eine weitere Möglichkeit wäre, in den Error-Logs des Webservers nach Fehler suchen.
    Damit du die Fehler aber auslesen kannst, gibt es die Option, die Fehler in eine Log-Datei auf dem Server schreiben zu lassen, auf die du dann per FTP zugreifen kannst.
    Um das zu ermöglichen, muss der folgende Code in die wp-config.php geschrieben werden (vorher bitte die wp-config.php auf deinen lokalen Rechner per FTP kopieren):

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du das bisherige define('WP_DEBUG', false); überschreibst. Wenn versucht wird, diese Konstante ein zweites Mal zu definieren, führt das zu einem Fehler, der deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen wird der Debug-Modus aktiviert, die Fehlermeldungen werden aber nicht direkt angezeigt, sondern in die Datei .../wp-content/debug.log geschrieben.
    Diese Datei kannst du per FTP auf deinen Rechner laden und möglicherweise findet sich darin ein Hinweis auf die Ursache des Problems.

    Ansonsten besteht noch die Möglichkeit, über den Kundenbereich des Hosters und phpMyAdmin einen neuen Benutzer mit Adminrechten anzulegen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter bettinette101

    (@bettinette101)

    Hallo,
    vielen lieben Dank für Euren Support!!!
    Mit dem neuen Benutzer hat es dann geklappt.
    Der ist Tag (und die Seite) ist gerettet.

    Viele Grüße
    Bettina

    Hallo,
    super – freut uns. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍
    Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Gelöst
    Die Option findest du rechts in der Sidebar. Das habe ich jetzt schon gemacht.

    Viele Grüße
    Hans-Gerd

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)