Support » Installation » Nach Update geänderte keyboard shortcuts

  • Servus!

    Habe jetzt lange im Forum und bei Google gesucht, aber nix sinnvolles gefunden …

    Mein Problem: Mit dem Update auf die aktuelle WP Version 4.2.2 haben sich die Keyboard Shortcuts im Editor (tinymce) geändert:

    Vorher: strg-2 –> H2
    Jetzt: alt-shift-2 –> H2

    Das ist extrem nervig wenn man lange Texte durchstrukturieren muss. Es erfordert eine sehr unbequeme, auf Dauer schmerzhafte Handhaltung (versuch mal mit einer Hand H5 einzugeben)

    Wie kann man denn das zurücksetzen? Oder überlagern mit eigenen Shortcuts?

    Servus,
    Alex

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Hi,
    ich muss passen. In alten Posts findet man die CTRL Variante und im Codex steht die SHIFT+ALT Variante. Ich konnte nur feststellen, das tinymce mit WordPress 3.9 auf tinymce 4 umgestellt wurde. Allerdings ist mir beim Testen aufgefallen, das CTRL+1 in meinem Firefox auf den ersten Tab spring. Vielleicht wurde das deshalb geändert.
    Blöder Seiteneffeckt beim Testen: Shift+ALT stellt das Keyboard auf englische Belegung um.
    Da müsste man sicherlich in die Tiefen von Tinymce einsteigen (Javascript).
    Gruß
    Wolfram

    tinymce 4 ist IMO nicht das Problem, bis WP 4.1 waren die Shortcuts ja noch da.

    AFAIR haben wir das dem neue eingeführten Emoji-Support zu verdanken. (Kann das jemand bestätigen?) Leider behebt das „Disable Emojis“ Plugin das Problem nicht.

    Weiss jemand genaueres WARUM die Shortcuts geändert wurden?

    Servus,
    Alex

    Hi Alex,

    bei WordPress 4.2 wurde auf TinyMCE 4.1.9 aktualisiert, vorher war es glaube ich 4.1.3 (aus dem 4.1-Release).

    Seit 4.1.8 (drittletzte Zeile) gibt es die neuen Shortcuts bei TinyMCE und zwar genau aus dem Grund, den Wolfram schon vermutet hatte – der Tab-Wechsel.

    Viele Grüße,
    Florian

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Nach Update geänderte keyboard shortcuts“ ist für neue Antworten geschlossen.