Support » Installation » Nach WooCommerce-aktualisierung Seite nicht mehr erreichbar

  • Hallo Miteinander,
    ich habe auf meiner Webseite das Plugin WooCommerce von Version 3.9.3 auf Version 4.0.1 aktualisiert.
    Das Aktualisieren wurde abgebrochen und auf einer weißen Seite folgende Fehlermeldung angezeigt.

    > *Uncaught Error*: Call to undefined function is_account_page() in
    > */www/1021/htdocs/wp-content/plugins/woocommerce-germanized/includes/c
    > lass-wc-gzd-customer-helper.php*
    > on line *347*
    >
    > * customer_account_activation_check()
    > wp-includes/class-wp-hook.php:288
    > * apply_filters()
    > wp-includes/class-wp-hook.php:312
    > * do_action()
    > wp-includes/plugin.php:478
    > * do_action()
    > wp-includes/template-loader.php:13
    > * require_once()
    > wp-blog-header.php:19
    > * require()
    > index.php:17

    Ich konnte mich nicht mehr einloggen um die Aktualisierung mit der Sicherungskopie rückgängig zu machen. Gott sei Dank hatte mein Webmaster Zeit und konnte das für mich erledigen, die Seite funktioniert wieder, aber die WooCommerce-aktualisierung ist noch immer nicht drinn.
    Ich traue mich nicht die Aktualisierung erneut aufzurufen, da mich mein Webmaster sonst irgendwann schlägt.
    Frage: Ist der Fehler irgendwie bekannt und hilft es mal ein paar Tage zu warten oder soll ich es mal gleich ganz adakta legen?
    Gruß
    Bernd

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hast du dir die Fehlermeldung mal angeschaut?

    Call to undefined function is_account_page() in */www/1021/htdocs/wp-content/plugins/woocommerce-germanized/includes/class-wc-gzd-customer-helper.php

    Ich mag ja falsch liegen, aber wäre es da nicht naheliegend, den Fehler im Plugin WooCommerce-Germanized zu vermuten? Und wenn das so ist, wäre es dann nicht eine gute Idee, mal den Entwickler dieses Plugins anzusprechen?

    Das Supportforum des Plugins findest du hier: https://wordpress.org/support/plugin/woocommerce-germanized/

    Ok, du hast Recht, aber ich hab über FTP ad Plugin umbenannt und es ging immer noch nichts.

    … es ging immer noch nichts.

    ist eine schlechte Fehlerbeschreibung, weil nicht nachvollziehbar ist, was genau welche Probleme verursacht und was du versucht hast um das Problem zu lösen.

    Grundsätzlich solltest du vor jeder Änderung ein Backup machen – das ist mit den üblichen Backup-Plugins eine Sache von wenigen Minuten und wenn etwas schief geht, stellst du rasch das Backup wieder her. Kein Backup, kein Mitleid.

    Ich hatte übrigens bei der Umstellung auf WooCommerce auch zunächst diverse Probleme, die sich aber in Luft aufgelöst haben, nachem WooCommerce eine Aktualisierung/Optimierung seiner eigenen Datenbanktabellen vorgenommen hat.

    Im Zweifelsfall solltest du dich an die Entwickler von WooCommerce wenden, die können dir dazu sicher mehr sagen.

    Hallo,
    ok, ich konkretisiere meine Frage: Hat WooCommerce das Plugin nachgebessert (oder auch WooCommerce Germanized ) ?
    Meine Seite geht wieder, (weil ich ein Backup gemacht hatte) mich würde nur interessieren ob ich die Plugins mitlerweile auf Grund einer Nachbesserung gefahrlos aktualisieren kann.
    Gruß
    Bernd

    Version 4.0.1 ist eine nachgebesserte Version von WooCommerce 4.0. 🙂

    Ob damit dein Fehler behoben wird, solltest du die Entwickler von WooCommerce fragen – oder es einfach selber ausprobieren (vielleicht erst einmal in einer Testumgebung, wie es jeder Profi machen würde).

    Wir sind hier AnwenderInnen wie du und ich müsste mir genauso erst einmal eine Testumgebung einrichten, in der die genannten Plugins installiert sind. Aber vielleicht wartest du auch noch, bis jemand antwortet, der sich besser auskennt? 🙂

    OK, Danke.
    Ich bin genauso Anwender wie du auch, ich warte mal.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)